aboutsummaryrefslogtreecommitdiff
path: root/games/duke3d
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-11-09 15:54:58 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-11-09 15:54:58 +0000
commit5e4da53f0a9c79d99ae2c53b204d4355a19ccba6 (patch)
tree198290b2a1ea645e4e848f3f57a31fd7f74f3e27 /games/duke3d
parentd3045a1360bbb3a3091d7d5653686d29d54427e1 (diff)
downloadports-5e4da53f0a9c79d99ae2c53b204d4355a19ccba6.tar.gz
ports-5e4da53f0a9c79d99ae2c53b204d4355a19ccba6.zip
Notes
Diffstat (limited to 'games/duke3d')
-rw-r--r--games/duke3d/Makefile50
-rw-r--r--games/duke3d/distinfo1
-rw-r--r--games/duke3d/files/README.bsd20
-rw-r--r--games/duke3d/files/build-wrapper.sh6
-rw-r--r--games/duke3d/files/pkg-message.in26
-rw-r--r--games/duke3d/pkg-message5
-rw-r--r--games/duke3d/pkg-plist28
7 files changed, 78 insertions, 58 deletions
diff --git a/games/duke3d/Makefile b/games/duke3d/Makefile
index 4ba07783e960..91e49418cf5f 100644
--- a/games/duke3d/Makefile
+++ b/games/duke3d/Makefile
@@ -18,28 +18,41 @@ USE_XLIB= yes
USE_GMAKE= yes
USE_SDL= mixer sdl
USE_REINPLACE= yes
+CONFLICTS= jfduke3d-200[0-9]*
WRKSRC= ${WRKDIR}/${PORTNAME}
TARGET_DIR= ${LOCALBASE}/${PORTNAME}
-DATA_FILES= defs.con game.con user.con
PROG_FILES= ${WRKSRC}/source/${PORTNAME} ${WRKSRC}/source/buildengine/build
-DOC_FILES= README BUILDLIC.TXT CONTRIB TODO CHANGELOG ../../readme.txt ../../gnu.txt
+DATA_FILES= defs.con game.con user.con
+BUILD_FILES= ${WRKSRC}/source/buildengine/stuff.dat
+SCRIPT_FILES= ${WRKDIR}/fix.sh ${WRKDIR}/duke3d.sh ${WRKDIR}/build.sh
+PORTDOCS= README BUILDLIC.TXT CONTRIB TODO CHANGELOG
+MOREDOCS= readme.txt gnu.txt
-OPTIONS= DOSBOX "Dependency on dosbox (config editor use it)" on
+OPTIONS= DOSBOX "Dependency on dosbox (required by SETUP.EXE and\
+ SETMAIN.EXE to edit the config file)" on
+
+SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 499999
+DEPRECATED= Please use games/jfduke3d. This port is being kept for RELENG_4 users
+.endif
+
.if !defined(WITHOUT_DOSBOX)
RUN_DEPENDS+= dosbox:${PORTSDIR}/emulators/dosbox
.endif
post-patch:
- @${SED} -e 's|%%DUKEDIR%%|${PREFIX}/${PORTNAME}|g' ${FILESDIR}/fix.sh > \
+ @${SED} -e 's|%%DUKEDIR%%|${DATADIR}|g' ${FILESDIR}/fix.sh > \
${WRKDIR}/fix.sh
- @${SED} -e 's|%%DUKEDIR%%|${PREFIX}/${PORTNAME}|g' ${FILESDIR}/wrapper.sh > \
- ${WRKDIR}/wrapper.sh
+ @${SED} -e 's|%%DUKEDIR%%|${DATADIR}|g' ${FILESDIR}/wrapper.sh > \
+ ${WRKDIR}/duke3d.sh
+ @${SED} -e 's|%%DUKEDIR%%|${DATADIR}|g' ${FILESDIR}/build-wrapper.sh > \
+ ${WRKDIR}/build.sh
@${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
@${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
@@ -51,28 +64,31 @@ do-build:
cd ${WRKSRC}/source && ${GMAKE}
do-install:
- ${INSTALL} -d ${TARGET_DIR}
- ${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR}
- ${INSTALL_SCRIPT} ${WRKDIR}/fix.sh ${TARGET_DIR}
- ${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${TARGET_DIR}/duke.sh
- ${INSTALL} -d ${TARGET_DIR}/testdata
+ ${INSTALL} -d ${DATADIR}
+ ${INSTALL_PROGRAM} ${PROG_FILES} ${DATADIR}
+ ${INSTALL_DATA} ${BUILD_FILES} ${DATADIR}
+ ${INSTALL} -d ${DATADIR}/testdata
.for file in ${DATA_FILES}
- ${INSTALL_DATA} ${WRKSRC}/testdata/${file} ${TARGET_DIR}/testdata
+ ${INSTALL_DATA} ${WRKSRC}/testdata/${file} ${DATADIR}/testdata
.endfor
- ${LN} -s ${TARGET_DIR}/duke.sh ${LOCALBASE}/bin/duke3d
+ ${INSTALL_SCRIPT} ${SCRIPT_FILES} ${DATADIR}
+ ${LN} -fs ${DATADIR}/duke3d.sh ${LOCALBASE}/bin/duke3d
+ ${LN} -fs ${DATADIR}/build.sh ${LOCALBASE}/bin/duke3d-build
post-install:
.ifndef(NOPORTDOCS)
${INSTALL} -d ${DOCSDIR}
-.for file in ${DOC_FILES}
+.for file in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/source/buildengine/${file} ${DOCSDIR}
.endfor
- ${SED} -e 's|%%DUKEDIR%%|${PREFIX}/${PORTNAME}|g' ${FILESDIR}/README.bsd > \
- ${DOCSDIR}/README.bsd
+
+.for file in ${MOREDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
.endif
- @${SED} -e 's|%%DOCSDIR%%|${DOCSDIR}|' ${PKGMESSAGE}
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/games/duke3d/distinfo b/games/duke3d/distinfo
index ff8c94ce4484..e26b222e3dea 100644
--- a/games/duke3d/distinfo
+++ b/games/duke3d/distinfo
@@ -1,2 +1,3 @@
MD5 (duke3d-20041505.tar.gz) = 169258698712de95f21cc085c62924c2
+SHA256 (duke3d-20041505.tar.gz) = 7504160a45ca0e43ee997ee59385185793e0f35df691bcc4cada7eded381caba
SIZE (duke3d-20041505.tar.gz) = 1788037
diff --git a/games/duke3d/files/README.bsd b/games/duke3d/files/README.bsd
deleted file mode 100644
index f2b30e792171..000000000000
--- a/games/duke3d/files/README.bsd
+++ /dev/null
@@ -1,20 +0,0 @@
-You need to copy the following files from the Duke Nukem 3D CD-ROM or from the Sharware
-release to %%DUKEDIR%%:
-
-DUKE3D.GRP
-DUKE3D.CFG
-SETUP.EXE
-SETMAIN.EXE
-
-Afterwards you have to run %%DUKEDIR%%/fix.sh
-
-If you want to edit your config run dosbox, mount %%DUKEDIR%%
-and run SETUP.EXE. Be sure you have write permission. Otherwise your
-changes will get lost.
-
-WARNING: Icculus Duke3D port is still in alpha stage.
-
-Thx go out to
-
-- mezz @ bsdforums.org for cleaning up the code and testing it on -CURRENT
-- clement for his problem reports and for commiting the port
diff --git a/games/duke3d/files/build-wrapper.sh b/games/duke3d/files/build-wrapper.sh
new file mode 100644
index 000000000000..983ca5a0eb68
--- /dev/null
+++ b/games/duke3d/files/build-wrapper.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+# Needed to make symlinks/shortcuts work.
+# Wrap build (editor) binary
+cd %%DUKEDIR%%
+./build $*
+exit $?
diff --git a/games/duke3d/files/pkg-message.in b/games/duke3d/files/pkg-message.in
new file mode 100644
index 000000000000..079ab08cc527
--- /dev/null
+++ b/games/duke3d/files/pkg-message.in
@@ -0,0 +1,26 @@
+-----------------------------------------------------------------
+Icculus Duke Nukem 3D Port has been successfully installed.
+
+You still need the original Duke Nukem 3D data files. Please copy the following
+files to the %%DATADIR%% directory:
+
+DUKE3D.GRG
+DUKE3D.CFG (optional)
+SETUP.EXE (optional)
+SETMAIN.EXE (optional)
+
+Be sure to run the fix.sh script inside %%DATADIR%% afterwards. This step is
+mandatory.
+
+The release notes can be found in %%DOCSDIR%%.
+
+If you have any problems with running this port please contact the maintainer
+of this port and NOT the people at Icculus.
+
+NOTE: This port is based on a CVS snapshot and should be considered unstable.
+Frame rates are very low due to a SDL sound bug in combination with FreeBSD. A
+lot of features that were part of the original Duke Nukem 3D retail release are
+either not present or not working in this release.
+
+Thx.
+-----------------------------------------------------------------
diff --git a/games/duke3d/pkg-message b/games/duke3d/pkg-message
deleted file mode 100644
index b10362ec489c..000000000000
--- a/games/duke3d/pkg-message
+++ /dev/null
@@ -1,5 +0,0 @@
------------------------------------------------------------------
-Duke Nukem 3D has been successfully installed.
-Please take a look at the helpfiles under %%DOCSDIR%% and
-read http://www.icculus.org/duke3d/
------------------------------------------------------------------
diff --git a/games/duke3d/pkg-plist b/games/duke3d/pkg-plist
index ef263a1d9008..c1c0e4201471 100644
--- a/games/duke3d/pkg-plist
+++ b/games/duke3d/pkg-plist
@@ -1,19 +1,15 @@
-duke3d/duke3d
-duke3d/duke.sh
-duke3d/build
-duke3d/fix.sh
-duke3d/testdata/defs.con
-duke3d/testdata/game.con
-duke3d/testdata/user.con
+%%DATADIR%%/duke3d
+%%DATADIR%%/duke3d.sh
+%%DATADIR%%/build
+%%DATADIR%%/build.sh
+%%DATADIR%%/fix.sh
+%%DATADIR%%/stuff.dat
+%%DATADIR%%/testdata/defs.con
+%%DATADIR%%/testdata/game.con
+%%DATADIR%%/testdata/user.con
bin/duke3d
-%%PORTDOCS%%%%DOCSDIR%%/README.bsd
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/BUILDLIC.TXT
-%%PORTDOCS%%%%DOCSDIR%%/CONTRIB
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+bin/duke3d-build
%%PORTDOCS%%%%DOCSDIR%%/readme.txt
%%PORTDOCS%%%%DOCSDIR%%/gnu.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm duke3d/testdata
-@unexec rmdir %D/duke3d 2> /dev/null || true
+@dirrm share/duke3d/testdata
+@unexec rmdir %D/share/duke3d 2> /dev/null || true