aboutsummaryrefslogtreecommitdiff
path: root/games/dunelegacy
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-07-04 21:27:55 +0000
committerSteve Wills <swills@FreeBSD.org>2017-07-04 21:27:55 +0000
commit8ff46c8f9c5952fd0bb4db0f8a9d1de11181c5c2 (patch)
tree26e1f548f813937851c3be723560beaf4157974d /games/dunelegacy
parentb2ef031943ed4011da4e0701f7403f48c8f6f1bd (diff)
downloadports-8ff46c8f9c5952fd0bb4db0f8a9d1de11181c5c2.tar.gz
ports-8ff46c8f9c5952fd0bb4db0f8a9d1de11181c5c2.zip
Notes
Diffstat (limited to 'games/dunelegacy')
-rw-r--r--games/dunelegacy/Makefile8
-rw-r--r--games/dunelegacy/distinfo5
-rw-r--r--games/dunelegacy/files/patch-configure.ac22
-rw-r--r--games/dunelegacy/files/patch-include__misc__functional.h21
-rw-r--r--games/dunelegacy/files/patch-include__misc__memory.h18
-rw-r--r--games/dunelegacy/pkg-plist29
6 files changed, 46 insertions, 57 deletions
diff --git a/games/dunelegacy/Makefile b/games/dunelegacy/Makefile
index 04a5fccb489f..fb574b792251 100644
--- a/games/dunelegacy/Makefile
+++ b/games/dunelegacy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dunelegacy
-PORTVERSION= 0.96.3
-PORTREVISION= 3
+PORTVERSION= 0.96.4
CATEGORIES= games
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -16,10 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc64= fails to compile: functional.h: 'std::bind' has not been declared
-USES= autoreconf compiler:c++11-lib tar:bzip2
+USES= autoreconf compiler:c++11-lib tar:bzip2 pkgconfig
GNU_CONFIGURE= yes
-USE_SDL= sdl mixer
+USE_SDL= sdl2 mixer2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAKE_JOBS_UNSAFE= yes
.include <bsd.port.mk>
diff --git a/games/dunelegacy/distinfo b/games/dunelegacy/distinfo
index 2d7e310e51a6..209c7d082318 100644
--- a/games/dunelegacy/distinfo
+++ b/games/dunelegacy/distinfo
@@ -1,2 +1,3 @@
-SHA256 (dunelegacy-0.96.3-src.tar.bz2) = 677159c174d9f9e8eb20e5e5cec997decf8e5a7091dc1583dc23fe340c5f6222
-SIZE (dunelegacy-0.96.3-src.tar.bz2) = 1652302
+TIMESTAMP = 1497803155
+SHA256 (dunelegacy-0.96.4-src.tar.bz2) = 4740df9e94712b34f5d6fa1ca3c24658c4808b40431aa156ed66c318be9f4de8
+SIZE (dunelegacy-0.96.4-src.tar.bz2) = 2513167
diff --git a/games/dunelegacy/files/patch-configure.ac b/games/dunelegacy/files/patch-configure.ac
index 686fd60cb2dc..6a2bf2ee2d93 100644
--- a/games/dunelegacy/files/patch-configure.ac
+++ b/games/dunelegacy/files/patch-configure.ac
@@ -1,17 +1,17 @@
---- configure.ac.orig 2014-08-15 18:38:46.000000000 +0000
-+++ configure.ac 2014-08-15 18:40:54.000000000 +0000
-@@ -16,13 +16,25 @@
+--- configure.ac.orig 2016-12-26 20:59:49.000000000 +0000
++++ configure.ac 2017-07-04 16:35:44.818612000 +0000
+@@ -18,14 +18,23 @@
AC_SUBST(dunelegacydatadir)
-dnl Some flags for gcc
--CXXFLAGS="-O3 -pipe -pedantic -Wall -Wextra -Wno-unused-parameter -DNDEBUG"
- dnl Additional flags: -Wconversion -Wno-sign-conversion
-
--dnl Some flags for clang
--dnl CXXFLAGS="-O3 -pipe -pedantic -Weverything -Wno-sign-conversion -Wno-conversion -Wno-shadow -Wno-missing-noreturn -Wno-padded -Wno-packed -Wno-weak-vtables -Wno-c++11-narrowing -Wno-cast-align -Wno-unreachable-code -Wno-missing-prototypes -Wno-float-equal -Wno-global-constructors -Wno-exit-time-destructors -Wno-format-nonliteral -Wno-unused-macros -Wextra -Wno-unused-parameter"
+-CXXFLAGS="-std=c++11 -pthread -fPIC -O3 -pipe -pedantic -Wall -Wextra -Wno-unused-parameter -Wno-shift-negative-value -DNDEBUG"
+-CFLAGS="-std=c99 -pthread -fPIC -O3 -pipe -pedantic -Wall -Wextra -Wno-unused-parameter -Wno-shift-negative-value -DNDEBUG"
+-dnl Additional flags: -Wconversion -Wno-sign-conversion -Wlogical-op
+AC_MSG_CHECKING([if compiling with clang])
+-dnl Some flags for clang
+-dnl CXXFLAGS="-std=c++11 -O3 -pipe -pedantic -Weverything -Wno-sign-conversion -Wno-conversion -Wno-shadow -Wno-missing-noreturn -Wno-padded -Wno-packed -Wno-weak-vtables -Wno-c++11-narrowing -Wno-cast-align -Wno-unreachable-code -Wno-missing-prototypes -Wno-float-equal -Wno-global-constructors -Wno-exit-time-destructors -Wno-format-nonliteral -Wno-unused-macros -Wreserved-id-macro -Wextra -Wno-unused-parameter -Wno-narrowing"
+AC_COMPILE_IFELSE(
+[AC_LANG_PROGRAM([], [[
+#ifndef __clang__
@@ -19,7 +19,7 @@
+#endif
+]])],
+[CLANG=yes], [CLANG=no])
-+
+
+AC_MSG_RESULT([$CLANG])
+
+if test "x$CLANG" = xyes; then
@@ -28,5 +28,5 @@
+ CXXFLAGS="-O3 -pipe -pedantic -Wall -Wextra -Wno-unused-parameter -DNDEBUG"
+fi
- dnl test for -ffp-contract=off (gcc >= 4.6) and use -mno-fused-madd instead
- oldCFLAGS="$CFLAGS"
+ AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],
diff --git a/games/dunelegacy/files/patch-include__misc__functional.h b/games/dunelegacy/files/patch-include__misc__functional.h
deleted file mode 100644
index fc0252ad102e..000000000000
--- a/games/dunelegacy/files/patch-include__misc__functional.h
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./include/misc/functional.h.orig 2011-01-07 18:30:22.000000000 +0000
-+++ ./include/misc/functional.h 2014-08-15 18:13:48.592575865 +0000
-@@ -1,14 +1,14 @@
- #ifndef FUNCTIONAL_INCLUDED
- #define FUNCTIONAL_INCLUDED
-
--#include <tr1/functional>
-+#include <functional>
-
- namespace std {
-- using std::tr1::bind;
-- using std::tr1::function;
-+ using std::bind;
-+ using std::function;
-
- namespace placeholders {
-- using namespace std::tr1::placeholders;
-+ using namespace std::placeholders;
- }
- }
-
diff --git a/games/dunelegacy/files/patch-include__misc__memory.h b/games/dunelegacy/files/patch-include__misc__memory.h
deleted file mode 100644
index 9f9ed052212f..000000000000
--- a/games/dunelegacy/files/patch-include__misc__memory.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./include/misc/memory.h.orig 2011-07-15 23:19:01.000000000 +0000
-+++ ./include/misc/memory.h 2014-08-15 18:13:48.594576019 +0000
-@@ -1,12 +1,12 @@
- #ifndef MEMORY_INCLUDED
- #define MEMORY_INCLUDED
-
--#include <tr1/memory>
-+#include <memory>
-
- namespace std {
-- using std::tr1::shared_ptr;
-+ using std::shared_ptr;
-
-- using std::tr1::dynamic_pointer_cast;
-+ using std::dynamic_pointer_cast;
- }
-
- #endif //MEMORY_INCLUDED
diff --git a/games/dunelegacy/pkg-plist b/games/dunelegacy/pkg-plist
index 67deaf8be03b..24a47cbed2bc 100644
--- a/games/dunelegacy/pkg-plist
+++ b/games/dunelegacy/pkg-plist
@@ -1,11 +1,14 @@
bin/dunelegacy
%%DATADIR%%/Dune2-Versions.txt
+%%DATADIR%%/GFXHD.PAK
%%DATADIR%%/LEGACY.PAK
%%DATADIR%%/OPENSD2.PAK
%%DATADIR%%/locale/English.en.po
%%DATADIR%%/locale/French.fr.po
%%DATADIR%%/locale/German.de.po
+%%DATADIR%%/locale/Spanish.es.po
%%DATADIR%%/locale/dunelegacy.pot
+%%DATADIR%%/maps/multiplayer/2P - 32x128 - Gatekeeper.ini
%%DATADIR%%/maps/multiplayer/2P - 32x32 - X-Factor.ini
%%DATADIR%%/maps/multiplayer/2P - 64x32 - Cliffs Of Rene.ini
%%DATADIR%%/maps/multiplayer/2P - 64x64 - Bottle Neck.ini
@@ -14,15 +17,41 @@ bin/dunelegacy
%%DATADIR%%/maps/multiplayer/2P - 64x64 - Face Off.ini
%%DATADIR%%/maps/multiplayer/2P - 64x64 - Great Divide.ini
%%DATADIR%%/maps/multiplayer/2P - 64x64 - Sanctuarys.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - Deserted.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - Equilibrium.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - Four Cities.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - Hungry Hippos.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - Silicon Valley XL.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - Snake Pass.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - Spicestorm.ini
%%DATADIR%%/maps/multiplayer/4P - 128x128 - The Sardaukar Outpost.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - Worm Investation.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - Wormhole.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x64 - Gamma Sector.ini
+%%DATADIR%%/maps/multiplayer/4P - 64x64 - Channels.ini
%%DATADIR%%/maps/multiplayer/4P - 64x64 - Clear Path.ini
+%%DATADIR%%/maps/multiplayer/4P - 64x64 - Combed.ini
%%DATADIR%%/maps/multiplayer/4P - 64x64 - Four Chambers.ini
%%DATADIR%%/maps/multiplayer/4P - 64x64 - Four Courners.ini
%%DATADIR%%/maps/multiplayer/4P - 64x64 - Sietch Stefan.ini
+%%DATADIR%%/maps/multiplayer/4P - 64x64 - Silicon Valley.ini
+%%DATADIR%%/maps/multiplayer/4P - 64x64 - Stronghold.ini
%%DATADIR%%/maps/multiplayer/4P - 64x64 - Vast Armies Have Arrived.ini
+%%DATADIR%%/maps/multiplayer/5P - 128x128 - Fortress.ini
+%%DATADIR%%/maps/multiplayer/5P - 128x128 - Gridlocked.ini
+%%DATADIR%%/maps/multiplayer/5P - 128x128 - Hellvetika.ini
+%%DATADIR%%/maps/multiplayer/5P - 128x128 - Kragetam.ini
+%%DATADIR%%/maps/multiplayer/5P - 128x128 - Meadow.ini
+%%DATADIR%%/maps/multiplayer/5P - 128x64 - Watch Your Track.ini
+%%DATADIR%%/maps/multiplayer/6P - 128x128 - Gargantuan Mountains.ini
+%%DATADIR%%/maps/multiplayer/6P - 64x128 - Rocking Fields.ini
+%%DATADIR%%/maps/multiplayer/6P - 64x64 - Fertile Basin.ini
%%DATADIR%%/maps/singleplayer/2P - 32x128 - Canyon.ini
%%DATADIR%%/maps/singleplayer/2P - 64x64 - Duality.ini
%%DATADIR%%/maps/singleplayer/2P - 64x64 - North vs. South.ini
%%DATADIR%%/maps/singleplayer/2P - 64x64 - Twin Fists.ini
%%DATADIR%%/maps/singleplayer/3P - 64x32 - Middle Man.ini
+%%DATADIR%%/maps/singleplayer/4P - 64x64 - 3 vs 1.ini
%%DATADIR%%/maps/singleplayer/5P - 128x128 - All against Atreides.ini
+%%DATADIR%%/maps/singleplayer/5P - 128x128 - Sardaukar Base Easy.ini
+%%DATADIR%%/maps/singleplayer/5P - 128x128 - Sardaukar Base.ini