aboutsummaryrefslogtreecommitdiff
path: root/games/easyrpg-player/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-13 10:52:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-13 10:52:33 +0000
commit2baf1e0352ede89642e590df6246e34b1bf6e649 (patch)
treeaf33bffeab55ed644a78dd36736f05525524c4d3 /games/easyrpg-player/Makefile
parent300aef18b51dd4c99ae1b20bba267cd8845eeae9 (diff)
downloadports-2baf1e0352ede89642e590df6246e34b1bf6e649.tar.gz
ports-2baf1e0352ede89642e590df6246e34b1bf6e649.zip
Notes
Diffstat (limited to 'games/easyrpg-player/Makefile')
-rw-r--r--games/easyrpg-player/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/games/easyrpg-player/Makefile b/games/easyrpg-player/Makefile
index dfb47469ff62..1a68a450ebb2 100644
--- a/games/easyrpg-player/Makefile
+++ b/games/easyrpg-player/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= easyrpg-player
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5.0
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@@ -13,7 +13,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpng.so:graphics/png \
- liblcf.so:games/liblcf
+ liblcf.so:games/liblcf \
+ libharfbuzz.so:print/harfbuzz \
+ libmpg123.so:audio/mpg123 \
+ libvorbis.so:audio/libvorbis \
+ libsndfile.so:audio/libsndfile \
+ libxmp.so:audio/libxmp \
+ libspeexdsp.so:audio/speexdsp
BUILD_DEPENDS= asciidoc:textproc/asciidoc \
${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
@@ -25,6 +31,7 @@ GH_PROJECT= Player
USES= autoreconf compiler:c++11-lib gmake libtool localbase pkgconfig
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-bash-completion-dir=${PREFIX}/share/bash-completion/completions
USE_XORG= pixman
USE_SDL= sdl2 mixer2