aboutsummaryrefslogtreecommitdiff
path: root/games/eboard/Makefile
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-05-06 14:59:30 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-05-06 15:11:38 +0000
commit76f2c0607d29e6aeaf7fb43dfb74846b50571b68 (patch)
treeea6a86e5c6a9de29b8203759d9263aa64b4a1c28 /games/eboard/Makefile
parent35c6c8453503fbf34fd34da30b81a3993d1c8f7d (diff)
games/eboard: Take maintainership and rework the port a bit
- Add license - Remove nonfunctional joystick option - Comment out timeseal link; remove pkg-message for now - Remake all patchfiles - Change PORT_OPTIONS:MDOCS into post-install-DOCS-on target - pkg-descr: Use secured URL PR: 254278
Diffstat (limited to 'games/eboard/Makefile')
-rw-r--r--games/eboard/Makefile46
1 files changed, 20 insertions, 26 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index c39eb84eb9cf..183a2b2b56a4 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -11,34 +11,31 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
eboard-extras-2.tar.gz:p2
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rhurlin@FreeBSD.org
COMMENT= GTK+ chess board interface (mainly for FICS and chessd)
+LICENSE= GPLv2
+
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libpng.so:graphics/png
-EXTRAS= 1pl2 2
USES= compiler:c++11-lang gnome perl5 pkgconfig shebangfix tar:bzip2
-HAS_CONFIGURE= yes
-USE_PERL5= build
+USE_GITHUB= yes
+GH_ACCOUNT= fbergo
USE_GNOME= cairo gdkpixbuf2 gtk20
USE_GSTREAMER1= yes
-SHEBANG_FILES= configure
+USE_PERL5= build
-USE_GITHUB= yes
-GH_ACCOUNT= fbergo
+SHEBANG_FILES= configure
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--extra-inc=${LOCALBASE}/include \
--extra-ld=${LOCALBASE}/lib
INSTALL_TARGET= install install-man
-OPTIONS_DEFINE= JOYSTICK DOCS
-JOYSTICK_DESC= Enable joystick support
-JOYSTICK_BUILD_DEPENDS= ${LOCALBASE}/include/linux/joystick.h:devel/evdev-proto
-
DESKTOP_ENTRIES="eboard" \
"Play chess" \
"${PREFIX}/share/pixmaps/eboard.xpm" \
@@ -46,7 +43,9 @@ DESKTOP_ENTRIES="eboard" \
"Game;BoardGame;GTK;" \
true
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+
+EXTRAS= 1pl2 2
post-extract:
.for e in ${EXTRAS}
@@ -58,29 +57,24 @@ post-patch:
@${REINPLACE_CMD} -e 's,g++,${CXX},' -e 's|-O6|${CXXFLAGS}|' \
${WRKSRC}/configure
-.if empty(PORT_OPTIONS:MJOYSTICK)
-post-configure:
- @${REINPLACE_CMD} -e '/^#define HAVE_LINUX_JOYSTICK_H 1/ d' \
- ${WRKSRC}/config.h
-.endif
-
pre-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
post-install:
- @${LN} -sf ${LOCALBASE}/bin/timeseal \
- ${STAGEDIR}${DATADIR}/timeseal.FreeBSD
-.if ${PORT_OPTIONS:MDOCS}
+# There is no timeseal port ATM :(
+# @${LN} -sf ${LOCALBASE}/bin/timeseal \
+# ${STAGEDIR}${DATADIR}/timeseal.FreeBSD
+.for extra in ${EXTRAS}
+ @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} EBOARDCONFIG=${STAGEDIR}${PREFIX}/bin/eboard-config ${CONFIGURE_CMD} --prefix=${PREFIX}
+ @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install DATADIR=${STAGEDIR}${DATADIR}
+.endfor
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.for file in Crafty.txt FICS-Timeseal.txt GNUChess4.txt GNUChess5.txt \
Scripts.txt Sjeng.txt Themes.txt
${INSTALL_DATA} ${WRKSRC}/Documentation/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.for extra in ${EXTRAS}
- @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} EBOARDCONFIG=${STAGEDIR}${PREFIX}/bin/eboard-config ${CONFIGURE_CMD} --prefix=${PREFIX}
- @cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install DATADIR=${STAGEDIR}${DATADIR}
-.endfor
.include <bsd.port.mk>