aboutsummaryrefslogtreecommitdiff
path: root/games/eboard
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2012-06-28 16:12:21 +0000
committerJohan van Selst <johans@FreeBSD.org>2012-06-28 16:12:21 +0000
commitf030d9e3ad2aec4db078a31eaadc7194930b2173 (patch)
treea1d9e3b59d20f01dba7e19243dce08711dffebcc /games/eboard
parentca3c5a22d385e501f70c804e35089cf68f78d166 (diff)
Notes
Diffstat (limited to 'games/eboard')
-rw-r--r--games/eboard/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 287d88227ede..4cd2b89c08f4 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -39,7 +39,8 @@ INSTALL_TARGET= install install-man
MAN1= eboard-config.1 eboard-addtheme.1
MAN6= eboard.6
-OPTIONS= JOYSTICK "joystick support" off
+OPTIONS_DEFINE= JOYSTICK
+JOYSTICK_DESC= Enable joystick support
DESKTOP_ENTRIES="eboard" \
"Play chess" \
@@ -48,9 +49,9 @@ DESKTOP_ENTRIES="eboard" \
"Application;Game;" \
true
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_JOYSTICK)
+.if ${PORT_OPTIONS:MJOYSTICK}
BUILD_DEPENDS+= ${LOCALBASE}/include/linux/joystick.h:${PORTSDIR}/devel/linux-js
RUN_DEPENDS+= ${LOCALBASE}/include/linux/joystick.h:${PORTSDIR}/devel/linux-js
.endif
@@ -65,7 +66,7 @@ post-patch:
@${REINPLACE_CMD} -e 's,g++,${CXX},' -e 's,-O6,${CXXFLAGS},' \
${WRKSRC}/configure
-.if !defined(WITH_JOYSTICK)
+.if empty(PORT_OPTIONS:MJOYSTICK)
post-configure:
@${REINPLACE_CMD} -e '/^#define HAVE_LINUX_JOYSTICK_H 1/ d' \
${WRKSRC}/config.h
@@ -89,4 +90,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/icon-eboard.xpm ${PREFIX}/share/pixmaps/eboard.xpm
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>