aboutsummaryrefslogtreecommitdiff
path: root/games/eboard
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-12-24 12:06:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-12-24 12:06:35 +0000
commit0f5d36a748bd4d16195ac9ac2f92e1716e965f2f (patch)
treec92f6a53b9bc2460eecf04b0a0bfa2f15e22159a /games/eboard
parentb73eb6fea33449886711e88ad4f29f9185f691d6 (diff)
downloadports-0f5d36a748bd4d16195ac9ac2f92e1716e965f2f.tar.gz
ports-0f5d36a748bd4d16195ac9ac2f92e1716e965f2f.zip
Notes
Diffstat (limited to 'games/eboard')
-rw-r--r--games/eboard/Makefile2
-rw-r--r--games/eboard/files/patch-cimg.cc10
-rw-r--r--games/eboard/files/patch-libpng1516
3 files changed, 17 insertions, 11 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 23fd89fcb0fc..e8e59428d738 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -16,7 +16,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= johans@FreeBSD.org
COMMENT= GTK+ chess board interface (mainly for FICS and chessd)
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
EXTRAS= 1pl2 2
USES= shebangfix pkgconfig perl5 tar:bzip2
diff --git a/games/eboard/files/patch-cimg.cc b/games/eboard/files/patch-cimg.cc
deleted file mode 100644
index 476a4f82df2a..000000000000
--- a/games/eboard/files/patch-cimg.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- cimg.cc.orig 2008-02-22 16:51:22.000000000 +0100
-+++ cimg.cc 2012-05-08 07:19:55.000000000 +0200
-@@ -27,6 +27,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <png.h>
-+#include <pngpriv.h>
- #include "cimg.h"
-
- CImg::CImg(int w,int h) {
diff --git a/games/eboard/files/patch-libpng15 b/games/eboard/files/patch-libpng15
new file mode 100644
index 000000000000..8ab283259f79
--- /dev/null
+++ b/games/eboard/files/patch-libpng15
@@ -0,0 +1,16 @@
+--- cimg.cc
++++ cimg.cc
+@@ -94,11 +95,11 @@
+ ct == PNG_COLOR_TYPE_GRAY_ALPHA)
+ png_set_gray_to_rgb(pngp);
+
+- alloc(pngp->width,pngp->height);
++ alloc(width,height);
+ if (!ok) { fclose(f); return; }
+ ok = 0;
+
+- for(i=0;i<pngp->height;i++) {
++ for(i=0;i<height;i++) {
+ png_read_row(pngp, (png_bytep) (&data[i*rowlen]), NULL);
+ }
+