aboutsummaryrefslogtreecommitdiff
path: root/games/eboard
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2007-01-17 19:16:30 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2007-01-17 19:16:30 +0000
commit1ba95651c611b89292eb1c2e658b400304a922d5 (patch)
tree87a325a597ccece8c262c597d581abd7d695249b /games/eboard
parent02ad1ac559f3d1501b3407ee18f9dc7fb4281898 (diff)
downloadports-1ba95651c611b89292eb1c2e658b400304a922d5.tar.gz
ports-1ba95651c611b89292eb1c2e658b400304a922d5.zip
Notes
Diffstat (limited to 'games/eboard')
-rw-r--r--games/eboard/Makefile19
-rw-r--r--games/eboard/distinfo6
-rw-r--r--games/eboard/files/patch-network.cc16
-rw-r--r--games/eboard/files/patch-network.h8
-rw-r--r--games/eboard/pkg-plist4
5 files changed, 32 insertions, 21 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 649accc8c7c7..7f09f2760d85 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -6,20 +6,21 @@
#
PORTNAME= eboard
-PORTVERSION= 0.9.5
-PORTREVISION= 4
+PORTVERSION= 1.0.2
EXTRAS= 1pl2 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} eboard-extras-1pl2.tar.gz eboard-extras-2.tar.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= jylefort@FreeBSD.org
COMMENT= GTK+ chess board interface (mainly for FICS and chessd)
+USE_BZIP2= yes
HAS_CONFIGURE= yes
-USE_GNOME= imlib
-USE_X_PREFIX= yes
+USE_PERL5_BUILD=yes
+USE_GNOME= gtk20
CONFIGURE_ARGS= --prefix=${PREFIX} --extra-inc=${LOCALBASE}/include:${X11BASE}/include --extra-ld=${LOCALBASE}/lib:${X11BASE}/lib
@@ -33,7 +34,13 @@ DESKTOP_ENTRIES="eboard" \
"eboard.xpm" \
"eboard" \
"Application;Game;" \
- false
+ true
+
+post-extract:
+.for e in ${EXTRAS}
+ @cd ${WRKDIR} && ${GZIP_CMD} -dc \
+ ${_DISTDIR}/eboard-extras-${e}.tar.gz | ${TAR} -xf -
+.endfor
post-patch:
@${REINPLACE_CMD} -e 's,g++,${CXX},' -e 's,-O6,${CXXFLAGS},' \
@@ -50,7 +57,7 @@ post-install:
.endfor
.endif
.for extra in ${EXTRAS}
- @cd ${WRKDIR}/eboard-extras-${extra} && ./${CONFIGURE_SCRIPT} --prefix=${PREFIX}
+ @cd ${WRKDIR}/eboard-extras-${extra} && EBOARDCONFIG=${PREFIX}/bin/eboard-config ./${CONFIGURE_SCRIPT} --prefix=${PREFIX}
@cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install
.endfor
${MKDIR} ${PREFIX}/share/pixmaps
diff --git a/games/eboard/distinfo b/games/eboard/distinfo
index 1166d43f00a7..6b6fc7bd364d 100644
--- a/games/eboard/distinfo
+++ b/games/eboard/distinfo
@@ -1,6 +1,6 @@
-MD5 (eboard-0.9.5.tar.gz) = 2c22384e0a75c6037eb795df41e3c63b
-SHA256 (eboard-0.9.5.tar.gz) = de9356b5d27b3aca4b48e6521fb2e20222ccf65b87f20f002b249ea640e7ac7f
-SIZE (eboard-0.9.5.tar.gz) = 449330
+MD5 (eboard-1.0.2.tar.bz2) = faea915d4aaaf5ac20fd631ab4d47ea2
+SHA256 (eboard-1.0.2.tar.bz2) = a377f06300537e6e869542c49cb1ab4be0918be9dbf35a3771239c9a283732c5
+SIZE (eboard-1.0.2.tar.bz2) = 408023
MD5 (eboard-extras-1pl2.tar.gz) = d5fb7a541d9ef5f6d1d565d877b1ab9a
SHA256 (eboard-extras-1pl2.tar.gz) = 6849cc104e454167db8b8e9ae0573accade5c941a140b47e58b601164e99fcc3
SIZE (eboard-extras-1pl2.tar.gz) = 361237
diff --git a/games/eboard/files/patch-network.cc b/games/eboard/files/patch-network.cc
index fb79071b3d31..3f203d8d9f34 100644
--- a/games/eboard/files/patch-network.cc
+++ b/games/eboard/files/patch-network.cc
@@ -1,22 +1,22 @@
---- network.cc.orig Thu Nov 27 00:48:49 2003
-+++ network.cc Wed Feb 22 16:33:40 2006
-@@ -554,6 +554,7 @@
+--- network.cc.orig Mon Jan 15 23:59:58 2007
++++ network.cc Wed Jan 17 19:38:11 2007
+@@ -560,6 +560,7 @@
strcpy(HostName,"local pipe");
sprintf(HostAddress,"pipe[%d,%d]",pin,pout);
Quiet=0;
+ use_execve=0;
+ MaxWaitTime = 60000.0; // 1 minute
}
- void PipeConnection::init() {
-@@ -564,6 +565,7 @@
+@@ -571,6 +572,7 @@
strcpy(HostAddress,"unknown");
memset(HelperBin,0,512);
Quiet=0;
+ use_execve=0;
handshake.erase();
+ MaxWaitTime = 60000.0; // 1 minute
}
-
-@@ -594,6 +596,25 @@
+@@ -606,6 +608,25 @@
Port=port;
strncpy(HostName,host,128);
@@ -42,7 +42,7 @@
// build helper path
if (helpersuffix)
sprintf(z,"%s.%s",helperbin,helpersuffix);
-@@ -702,7 +723,10 @@
+@@ -716,7 +737,10 @@
dup2(1,2);
setpgid(getpid(),0); // to broadcast SIGKILL later
diff --git a/games/eboard/files/patch-network.h b/games/eboard/files/patch-network.h
index cc0e82a99a3e..c948b094d892 100644
--- a/games/eboard/files/patch-network.h
+++ b/games/eboard/files/patch-network.h
@@ -1,10 +1,10 @@
---- network.h.orig Thu Nov 27 00:48:49 2003
-+++ network.h Wed Feb 22 16:22:04 2006
-@@ -229,6 +229,7 @@
+--- network.h.orig Mon Jan 15 23:59:58 2007
++++ network.h Wed Jan 17 19:39:10 2007
+@@ -235,6 +235,7 @@
int pid;
int toid; // timeout
string handshake;
+ int use_execve;
+ double MaxWaitTime; // msecs
};
- class FallBackConnection : public NetConnection {
diff --git a/games/eboard/pkg-plist b/games/eboard/pkg-plist
index 813562e81dc7..4f2b7c3ef057 100644
--- a/games/eboard/pkg-plist
+++ b/games/eboard/pkg-plist
@@ -61,7 +61,10 @@ share/eboard/classic.png
share/eboard/eboard.cs.dict
share/eboard/eboard.de.dict
share/eboard/eboard.es.dict
+share/eboard/eboard.fr.dict
share/eboard/eboard.it.dict
+share/eboard/eboard.ja.dict
+share/eboard/eboard.pl.dict
share/eboard/eboard.pt_BR.dict
share/eboard/eboard_themes.conf
share/eboard/extras1.prevconf
@@ -73,4 +76,5 @@ share/eboard/themeconf.extras2
share/eboard/timeseal.FreeBSD
share/pixmaps/eboard.xpm
@dirrm share/eboard
+@dirrmtry share/pixmaps
%%PORTDOCS%%@dirrm %%DOCSDIR%%