aboutsummaryrefslogtreecommitdiff
path: root/games/edge
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-12-17 17:53:59 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-12-17 17:53:59 +0000
commit5cf1286163f80f6a61d51b63efbabbdea12e3940 (patch)
treeeda0afb831eb6cee2492a22aa0b50ae1e10ef6eb /games/edge
parente824eca3a720724995fa8ad46bead4db969f05cd (diff)
downloadports-5cf1286163f80f6a61d51b63efbabbdea12e3940.tar.gz
ports-5cf1286163f80f6a61d51b63efbabbdea12e3940.zip
Notes
Diffstat (limited to 'games/edge')
-rw-r--r--games/edge/Makefile41
-rw-r--r--games/edge/distinfo6
-rw-r--r--games/edge/files/patch-SConstruct17
-rw-r--r--games/edge/files/patch-epi__endianess.h14
-rw-r--r--games/edge/files/patch-epi__filesystem_linux.cc10
-rw-r--r--games/edge/files/patch-src__e_main.cc11
-rw-r--r--games/edge/files/patch-src__unx_net.cc14
-rw-r--r--games/edge/files/patch-src__unx_sysinc.h11
-rw-r--r--games/edge/pkg-descr14
-rw-r--r--games/edge/pkg-plist5
10 files changed, 143 insertions, 0 deletions
diff --git a/games/edge/Makefile b/games/edge/Makefile
new file mode 100644
index 000000000000..efe65d39fbba
--- /dev/null
+++ b/games/edge/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: edge
+# Date created: 2007-11-30
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= edge
+PORTVERSION= 1.29
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}-${PORTVERSION}-linux${EXTRACT_SUFX}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= DOOM style engine aimed at the Total Conversion developer
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ vorbis.4:${PORTSDIR}/audio/libvorbis
+
+USE_SCONS= yes
+USE_SDL= sdl
+SCONS_ARGS= release=true
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%DMDIR%%|${DMDIR}|;' ${WRKSRC}/src/e_main.cc
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gledge32 ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKDIR}/edge.wad ${DMDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/*.txt ${DOCSDIR}
+.endif
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
+
+.include <bsd.port.mk>
diff --git a/games/edge/distinfo b/games/edge/distinfo
new file mode 100644
index 000000000000..31324355803e
--- /dev/null
+++ b/games/edge/distinfo
@@ -0,0 +1,6 @@
+MD5 (edge-1.29-source.tar.gz) = 81b64f079763e84f48ce62f4d28efdab
+SHA256 (edge-1.29-source.tar.gz) = 9ddf455dc2706a6d0efbe22da7a2fb0871a986af85d87c3b48cd5e9239f086a1
+SIZE (edge-1.29-source.tar.gz) = 5513212
+MD5 (edge-1.29-linux.tar.gz) = f734d354873bddb62a058cf9d91d995e
+SHA256 (edge-1.29-linux.tar.gz) = 59f5447fc0f6b8d0bb947f764035f02005f481cd08abf1e219d1555888c7b15f
+SIZE (edge-1.29-linux.tar.gz) = 1918394
diff --git a/games/edge/files/patch-SConstruct b/games/edge/files/patch-SConstruct
new file mode 100644
index 000000000000..4bcf4a4e8498
--- /dev/null
+++ b/games/edge/files/patch-SConstruct
@@ -0,0 +1,17 @@
+--- ./SConstruct.orig Wed Jun 6 10:07:47 2007
++++ ./SConstruct Wed Dec 5 23:19:09 2007
+@@ -27,6 +27,14 @@
+ if build_info['cross']:
+ base_env.Tool('crossmingw', toolpath=['build'])
+
++# Respect CC, CXX, CCFLAGS, CPPPATH and LIBPATH command-line parameters.
++for key in ['CC', 'CXX']:
++ if key in ARGUMENTS:
++ base_env[key] = ARGUMENTS[key]
++for key in ['CCFLAGS', 'CPPPATH', 'LIBPATH']:
++ if key in ARGUMENTS:
++ base_env[key] = Split(ARGUMENTS[key])
++
+ # warnings
+ base_env.Append(CCFLAGS = ['-Wall'])
+
diff --git a/games/edge/files/patch-epi__endianess.h b/games/edge/files/patch-epi__endianess.h
new file mode 100644
index 000000000000..78c8a3c937bb
--- /dev/null
+++ b/games/edge/files/patch-epi__endianess.h
@@ -0,0 +1,14 @@
+--- ./epi/endianess.h.orig Sat Oct 14 05:10:38 2006
++++ ./epi/endianess.h Wed Dec 5 23:19:09 2007
+@@ -41,7 +41,11 @@
+ // The macros used to swap values. Try to use superfast macros on systems
+ // that support them, otherwise use C++ inline functions.
+ #ifdef LINUX
++#ifdef __FreeBSD__
++#include <sys/endian.h>
++#else
+ #include <endian.h>
++#endif
+ #ifdef __arch__swab16
+ #define EPI_Swap16 __arch__swab16
+ #endif
diff --git a/games/edge/files/patch-epi__filesystem_linux.cc b/games/edge/files/patch-epi__filesystem_linux.cc
new file mode 100644
index 000000000000..3e96a1bb2742
--- /dev/null
+++ b/games/edge/files/patch-epi__filesystem_linux.cc
@@ -0,0 +1,10 @@
+--- ./epi/filesystem_linux.cc.orig Sat Oct 14 05:10:39 2006
++++ ./epi/filesystem_linux.cc Wed Dec 5 23:19:09 2007
+@@ -29,6 +29,7 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <limits.h> // for PATH_MAX
+
+ #define MAX_MODE_CHARS 3
+
diff --git a/games/edge/files/patch-src__e_main.cc b/games/edge/files/patch-src__e_main.cc
new file mode 100644
index 000000000000..9d233fcc7448
--- /dev/null
+++ b/games/edge/files/patch-src__e_main.cc
@@ -0,0 +1,11 @@
+--- ./src/e_main.cc.orig Thu Jun 21 00:04:22 2007
++++ ./src/e_main.cc Wed Dec 5 23:35:20 2007
+@@ -1110,6 +1110,8 @@
+
+ if (s && epi::the_filesystem->IsDir(s))
+ iwad_dir.Set(s);
++ else
++ iwad_dir.Set("%%DMDIR%%");
+ }
+
+ // Should the IWAD directory not be set by now, then we
diff --git a/games/edge/files/patch-src__unx_net.cc b/games/edge/files/patch-src__unx_net.cc
new file mode 100644
index 000000000000..2b057fccfcc5
--- /dev/null
+++ b/games/edge/files/patch-src__unx_net.cc
@@ -0,0 +1,14 @@
+--- ./src/unx_net.cc.orig Sat Nov 25 05:25:10 2006
++++ ./src/unx_net.cc Wed Dec 5 23:19:09 2007
+@@ -36,7 +36,11 @@
+ #define htons htons_FUCK
+
+ #include <arpa/inet.h>
++#ifdef __FreeBSD__
++#include <net/if.h>
++#else
+ #include <linux/netdevice.h>
++#endif
+
+ // possible: <linux/if.h>
+ // <linux/sockios.h>
diff --git a/games/edge/files/patch-src__unx_sysinc.h b/games/edge/files/patch-src__unx_sysinc.h
new file mode 100644
index 000000000000..48e4012f7267
--- /dev/null
+++ b/games/edge/files/patch-src__unx_sysinc.h
@@ -0,0 +1,11 @@
+--- ./src/unx_sysinc.h.orig Mon May 28 00:01:49 2007
++++ ./src/unx_sysinc.h Wed Dec 5 23:19:09 2007
+@@ -23,7 +23,7 @@
+
+ #include <sys/ioctl.h>
+
+-#ifndef MACOSX
++#ifdef __linux__
+ #include <linux/cdrom.h>
+ #endif
+
diff --git a/games/edge/pkg-descr b/games/edge/pkg-descr
new file mode 100644
index 000000000000..816079576ef8
--- /dev/null
+++ b/games/edge/pkg-descr
@@ -0,0 +1,14 @@
+The EDGE project is a programming project to develop a DOOM style engine aimed
+at the Total Conversion developer, but still able to play the original DOOM
+games. This project started with the DOOM source released by id software.
+
+Note that it currently does not support playing the original MIDI music, but
+supports OGG Vorbis audio files.
+
+For Total Conversions using Edge see:
+http://www.wadsinprogress.info/
+
+For high resolution textures see:
+http://forums.yaa.dk/viewtopic.php?f=32&t=69
+
+WWW: http://edge.sourceforge.net/
diff --git a/games/edge/pkg-plist b/games/edge/pkg-plist
new file mode 100644
index 000000000000..2a9f0c729f32
--- /dev/null
+++ b/games/edge/pkg-plist
@@ -0,0 +1,5 @@
+bin/edge
+%%DMDIR%%/edge.wad
+%%PORTDOCS%%%%DOCSDIR%%/Changelog-129.txt
+%%PORTDOCS%%%%DOCSDIR%%/Edge-Readme.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%