aboutsummaryrefslogtreecommitdiff
path: root/games/eduke32/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-03 12:16:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-03 12:16:42 +0000
commitf954d1aba37618f793fc112fc566ab7df916f5c1 (patch)
treea0f6e3c784cab13407f439b9d8d6be68b4a90807 /games/eduke32/Makefile
parent6090a2829b3e371fb9845189ba9a81c1e1a911d9 (diff)
downloadports-f954d1aba37618f793fc112fc566ab7df916f5c1.tar.gz
ports-f954d1aba37618f793fc112fc566ab7df916f5c1.zip
Notes
Diffstat (limited to 'games/eduke32/Makefile')
-rw-r--r--games/eduke32/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index bd2298cc4f89..7bd448de2fc9 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= eduke32
-PORTVERSION= 20080206
-PORTREVISION= 1
+PORTVERSION= 20080602
CATEGORIES= games
MASTER_SITES= http://wiki.eduke32.com/stuff/
DISTFILES= ${PORTNAME}_src_${PORTVERSION}${EXTRACT_SUFX}
@@ -21,7 +20,9 @@ USE_GNOME= gtk20
USE_SDL= mixer sdl
WRKSRC= ${WRKDIR}/${PORTNAME}_src_${PORTVERSION}/${PORTNAME}
-OPTIONS= MIDI "Enable MIDI support" on
+OPTIONS= MIDI "Enable MIDI support" On \
+ TIMIDITYPLUS "Use Timidity++ instead of Timidity" Off \
+ VORBIS "Enable Ogg Vorbis support" On
.include "${.CURDIR}/../duke3d-data/Makefile.include"
@@ -31,11 +32,22 @@ OPTIONS= MIDI "Enable MIDI support" on
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
.endif
-.if !defined(WITHOUT_MIDI)
+.if defined(WITH_MIDI)
+.if defined(WITH_TIMIDITYPLUS)
+RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity++
+.else
RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity
.endif
+.endif
+
+.if defined(WITH_VORBIS)
+LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.endif
post-patch:
+.if defined(WITHOUT_VORBIS)
+ @${REINPLACE_CMD} -e '/LIBS+= -lvorbis/d' ${WRKSRC}/Makefile
+.endif
.if ${ARCH} != "i386"
@${REINPLACE_CMD} -Ee 's|^(NOASM =).*|\1 1|' ${WRKSRC}/Makefile
.endif
@@ -47,6 +59,7 @@ post-patch:
${WRKSRC}/Makefile \
${WRKSRC}/../build/Makefile \
${WRKSRC}/../build/Makefile.shared
+ @${REINPLACE_CMD} -e 's|LINUX|BSD|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/usr/share/games/eduke32|${DN3DDIR}|' \
${WRKSRC}/source/game.c ${WRKSRC}/source/astub.c