aboutsummaryrefslogtreecommitdiff
path: root/games/eduke32
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2018-02-23 16:36:37 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2018-02-23 16:36:37 +0000
commit46a5d58e521a63736e110072577c8d594cb69670 (patch)
tree558248e587f941e006ff148b57e7666530327000 /games/eduke32
parent497e37241f79ea338039e9ad5d9cbdba2414f27d (diff)
downloadports-46a5d58e521a63736e110072577c8d594cb69670.tar.gz
ports-46a5d58e521a63736e110072577c8d594cb69670.zip
Notes
Diffstat (limited to 'games/eduke32')
-rw-r--r--games/eduke32/Makefile11
-rw-r--r--games/eduke32/distinfo6
-rw-r--r--games/eduke32/files/patch-source_build_include_collections.h11
-rw-r--r--games/eduke32/files/patch-source_build_src_lz4.c10
4 files changed, 24 insertions, 14 deletions
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index 9ba533a830a6..cf27cf63427c 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= eduke32
-PORTVERSION= 20170614
-PORTREVISION= 1
+PORTVERSION= 20180218
CATEGORIES= games
MASTER_SITES= http://dukeworld.duke4.net/eduke32/synthesis/${PORTVERSION}-${SVNREVISION}/:eduke32 \
http://www.duke4.org/files/nightfright/hrp/:hrp \
@@ -23,20 +22,20 @@ LICENSE_FILE_BUILDLIC= ${WRKSRC}/source/build/buildlic.txt
LICENSE_FILE_GPLv2= ${WRKSRC}/source/duke3d/gpl-2.0.txt
LICENSE_PERMS_BUILDLIC= dist-mirror pkg-mirror auto-accept
+BROKEN_aarch64= fails to compile: polymost.cpp:2403:18: non-constant-expression cannot be narrowed from type 'long' to 'int32_t' (aka 'int') in initializer list
+
LIB_DEPENDS= libFLAC.so:audio/flac \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \
libvpx.so:multimedia/libvpx \
libpng.so:graphics/png
-BROKEN_aarch64= fails to compile: polymost.cpp:2403:18: non-constant-expression cannot be narrowed from type 'long' to 'int32_t' (aka 'int') in initializer list
-
-USES= gmake pkgconfig tar:xz
+USES= dos2unix gmake pkgconfig tar:xz
USE_GL= gl glu
USE_GNOME= gtk20
USE_SDL= sdl2 mixer2
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}-${SVNREVISION}
-SVNREVISION= 6180
+SVNREVISION= 6675
DATADIR= ${PREFIX}/share/duke3d
SUB_FILES= pkg-message
MAKEFILE= GNUmakefile
diff --git a/games/eduke32/distinfo b/games/eduke32/distinfo
index c193458e1644..65d59c7324f3 100644
--- a/games/eduke32/distinfo
+++ b/games/eduke32/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1497598231
-SHA256 (eduke32_src_20170614-6180.tar.xz) = 5afab56358face5e89323dbb9d35051d4878514613c8254ba6557661a3258ea0
-SIZE (eduke32_src_20170614-6180.tar.xz) = 14874472
+TIMESTAMP = 1519048274
+SHA256 (eduke32_src_20180218-6675.tar.xz) = e647b293e9435297bd83f97cb0fc126b89b870bb3da8ba5be8efd09611b68ec1
+SIZE (eduke32_src_20180218-6675.tar.xz) = 14454576
SHA256 (duke3d_hrp.zip) = f217df456b4f11055041731033e35e4402fada99253e714e37c4a27e6fdc78a5
SIZE (duke3d_hrp.zip) = 933440151
SHA256 (duke3d_xxx.zip) = c31713e6400a175a1bfa3bd369d132f8a8abce8915c113549f98262b9a84b534
diff --git a/games/eduke32/files/patch-source_build_include_collections.h b/games/eduke32/files/patch-source_build_include_collections.h
new file mode 100644
index 000000000000..767ddde41304
--- /dev/null
+++ b/games/eduke32/files/patch-source_build_include_collections.h
@@ -0,0 +1,11 @@
+--- source/build/include/collections.h.orig 2018-02-19 14:35:27 UTC
++++ source/build/include/collections.h
+@@ -41,7 +41,7 @@ struct GrowArray
+ void vacuum()
+ {
+ if (size_ < capacity_)
+- reallocate(size);
++ reallocate(size());
+ }
+
+ void clear()
diff --git a/games/eduke32/files/patch-source_build_src_lz4.c b/games/eduke32/files/patch-source_build_src_lz4.c
index 818ae4d53334..d024e911e836 100644
--- a/games/eduke32/files/patch-source_build_src_lz4.c
+++ b/games/eduke32/files/patch-source_build_src_lz4.c
@@ -1,11 +1,11 @@
---- source/build/src/lz4.c.orig 2017-06-16 07:39:10 UTC
+--- source/build/src/lz4.c.orig 2017-07-05 05:37:35 UTC
+++ source/build/src/lz4.c
-@@ -65,7 +65,7 @@
- /**************************************
- * Includes
+@@ -89,7 +89,7 @@
+ /*-************************************
+ * Dependency
**************************************/
-#include "lz4.h"
+#include "../include/lz4.h"
+ /* see also "memory routines" below */
- /**************************************