aboutsummaryrefslogtreecommitdiff
path: root/games/einstein
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-01 14:10:44 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-01 14:10:44 +0000
commitc801b56286dab488605ce76a3228e74f8e52d58a (patch)
tree1acb79ae0c1f3c9e7cfbe9bd003f022cc736178d /games/einstein
parent113296853a52ccf74c1bd1ea0163e12e7fa9b261 (diff)
Notes
Diffstat (limited to 'games/einstein')
-rw-r--r--games/einstein/Makefile5
-rw-r--r--games/einstein/files/patch-convert.h10
-rw-r--r--games/einstein/files/patch-unicode.cpp9
3 files changed, 23 insertions, 1 deletions
diff --git a/games/einstein/Makefile b/games/einstein/Makefile
index f8986a11ebd1..c73a03bf4794 100644
--- a/games/einstein/Makefile
+++ b/games/einstein/Makefile
@@ -3,7 +3,7 @@
PORTNAME= einstein
PORTVERSION= 2.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= http://games.flowix.com/files/einstein/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -20,4 +20,7 @@ post-patch:
-e "s,@@PREFIX@@,${PREFIX}," \
${WRKSRC}/Makefile
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/einstein
+
.include <bsd.port.mk>
diff --git a/games/einstein/files/patch-convert.h b/games/einstein/files/patch-convert.h
new file mode 100644
index 000000000000..ec77561fe4ec
--- /dev/null
+++ b/games/einstein/files/patch-convert.h
@@ -0,0 +1,10 @@
+--- convert.h.orig 2005-08-14 06:40:58.000000000 +0400
++++ convert.h 2015-03-27 02:57:05.826432000 +0300
+@@ -5,6 +5,7 @@
+ #include <iostream>
+ #include <sstream>
+ #include <string>
++#include <typeinfo>
+
+ #include "exceptions.h"
+ #include "unicode.h"
diff --git a/games/einstein/files/patch-unicode.cpp b/games/einstein/files/patch-unicode.cpp
new file mode 100644
index 000000000000..5e7081d18573
--- /dev/null
+++ b/games/einstein/files/patch-unicode.cpp
@@ -0,0 +1,9 @@
+--- unicode.cpp.orig 2005-08-14 06:40:58.000000000 +0400
++++ unicode.cpp 2015-03-27 02:57:47.513365000 +0300
+@@ -1,5 +1,6 @@
+ #include <wchar.h>
+ #include <stdlib.h>
++#include <string.h>
+ #ifdef WIN32
+ #include <windows.h>
+ #endif