aboutsummaryrefslogtreecommitdiff
path: root/games/einstein
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-10-12 22:37:50 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-10-12 22:37:50 +0000
commit1eddbdb2aaf56c8db90f4d5fc7a401409428d386 (patch)
tree44507603b33cc85298992f21608faca6bbee6916 /games/einstein
parent1294ef3f86f9755a851ee5b633e622e3d200d1aa (diff)
downloadports-1eddbdb2aaf56c8db90f4d5fc7a401409428d386.tar.gz
ports-1eddbdb2aaf56c8db90f4d5fc7a401409428d386.zip
Notes
Diffstat (limited to 'games/einstein')
-rw-r--r--games/einstein/Makefile7
-rw-r--r--games/einstein/distinfo4
-rw-r--r--games/einstein/files/patch-Makefile122
-rw-r--r--games/einstein/pkg-descr2
-rw-r--r--games/einstein/pkg-plist3
5 files changed, 30 insertions, 108 deletions
diff --git a/games/einstein/Makefile b/games/einstein/Makefile
index 638852fcfbd4..bc86855d0769 100644
--- a/games/einstein/Makefile
+++ b/games/einstein/Makefile
@@ -6,16 +6,15 @@
#
PORTNAME= einstein
-PORTVERSION= 1.0
-PORTREVISION= 2
+PORTVERSION= 2.0
CATEGORIES= games
-MASTER_SITES= http://www.babichev.info/files/einstein/
+MASTER_SITES= http://games.flowix.com/files/einstein/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= edwin@mavetju.org
COMMENT= Remake of old DOS game Sherlock, which was inspired by Albert Einstein's puzzle.
-USE_SDL= sdl ttf
+USE_SDL= sdl ttf mixer
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
post-install:
diff --git a/games/einstein/distinfo b/games/einstein/distinfo
index b43b5e7b4255..fe7cdcebe272 100644
--- a/games/einstein/distinfo
+++ b/games/einstein/distinfo
@@ -1,2 +1,2 @@
-MD5 (einstein-1.0-src.tar.gz) = b52325a7ec1a552216d25c2f967b6f94
-SIZE (einstein-1.0-src.tar.gz) = 824047
+MD5 (einstein-2.0-src.tar.gz) = c1d98e761c10af63f03462ead625f80c
+SIZE (einstein-2.0-src.tar.gz) = 722301
diff --git a/games/einstein/files/patch-Makefile b/games/einstein/files/patch-Makefile
index 82dd0f6b0b8d..00cbc26156e3 100644
--- a/games/einstein/files/patch-Makefile
+++ b/games/einstein/files/patch-Makefile
@@ -1,112 +1,34 @@
---- Makefile.orig Mon Jan 19 17:41:34 2004
-+++ Makefile Sun Jan 30 21:56:53 2005
-@@ -5,7 +5,6 @@
+--- Makefile.orig Mon Sep 26 07:20:30 2005
++++ Makefile Thu Oct 13 08:35:14 2005
+@@ -5,7 +5,7 @@
########################################
# installation prefix
-PREFIX=/usr/local
++#PREFIX=/usr/local
########################################
#
-@@ -15,8 +14,8 @@
-
+@@ -16,8 +16,8 @@
OPTIMIZE=#-O6 -march=pentium4 -mfpmath=sse -fomit-frame-pointer -funroll-loops
- DEBUG=-ggdb
--CXXFLAGS=-pipe -Wall $(OPTIMIZE) $(DEBUG) `sdl-config --cflags` -DPREFIX=\"$(PREFIX)\"
--LNFLAGS=-pipe -lSDL_ttf -lfreetype `sdl-config --libs` -lz
-+CXXFLAGS=-pipe -Wall $(OPTIMIZE) $(DEBUG) `${SDL_CONFIG} --cflags` -DPREFIX=\"$(PREFIX)\"
-+LNFLAGS=-pipe -lSDL_ttf -lfreetype `${SDL_CONFIG} --libs` -lz
+ PROFILER=#-pg
+ DEBUG=#-ggdb
+-CXXFLAGS=-pipe -Wall $(OPTIMIZE) $(DEBUG) `sdl-config --cflags` -DPREFIX=L\"$(PREFIX)\" $(PROFILER)
+-LNFLAGS=-pipe -lSDL_ttf -lfreetype `sdl-config --libs` -lz -lSDL_mixer $(PROFILER)
++CXXFLAGS=-pipe -Wall $(OPTIMIZE) $(DEBUG) `${SDL_CONFIG} --cflags` -DPREFIX=L\"$(PREFIX)\" $(PROFILER)
++LNFLAGS=-pipe -lSDL_ttf -lfreetype `${SDL_CONFIG} --libs` -lz -lSDL_mixer $(PROFILER)
+ INSTALL=install
TARGET=einstein
-
-@@ -52,86 +51,7 @@
- run: $(TARGET)
+@@ -61,8 +61,9 @@
./$(TARGET)
--# DO NOT DELETE
--
--puzgen.o: /usr/include/stdlib.h /usr/include/features.h
--puzgen.o: /usr/include/sys/cdefs.h /usr/include/gnu/stubs.h
--puzgen.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
--puzgen.o: /usr/include/stdio.h /usr/include/bits/types.h
--puzgen.o: /usr/include/bits/wordsize.h /usr/include/bits/typesizes.h
--puzgen.o: /usr/include/libio.h /usr/include/_G_config.h /usr/include/wchar.h
--puzgen.o: /usr/include/bits/wchar.h /usr/include/gconv.h
--puzgen.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stdarg.h
--puzgen.o: /usr/include/bits/stdio_lim.h /usr/include/bits/sys_errlist.h
--puzgen.o: puzgen.h iconset.h exceptions.h utils.h resources.h widgets.h
--puzgen.o: font.h
--main.o: /usr/include/stdlib.h /usr/include/features.h
--main.o: /usr/include/sys/cdefs.h /usr/include/gnu/stubs.h
--main.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h main.h
--main.o: exceptions.h screen.h resources.h random.h utils.h widgets.h font.h
--main.o: storage.h
--screen.o: screen.h exceptions.h
--resources.o: /usr/include/zlib.h /usr/include/zconf.h resources.h
--resources.o: exceptions.h main.h screen.h random.h utils.h widgets.h font.h
--utils.o: /usr/include/stdio.h /usr/include/features.h
--utils.o: /usr/include/sys/cdefs.h /usr/include/gnu/stubs.h
--utils.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
--utils.o: /usr/include/bits/types.h /usr/include/bits/wordsize.h
--utils.o: /usr/include/bits/typesizes.h /usr/include/libio.h
--utils.o: /usr/include/_G_config.h /usr/include/wchar.h
--utils.o: /usr/include/bits/wchar.h /usr/include/gconv.h
--utils.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stdarg.h
--utils.o: /usr/include/bits/stdio_lim.h /usr/include/bits/sys_errlist.h
--utils.o: /usr/include/stdlib.h /usr/include/sys/time.h /usr/include/time.h
--utils.o: /usr/include/bits/time.h /usr/include/sys/select.h
--utils.o: /usr/include/bits/select.h /usr/include/bits/sigset.h
--utils.o: /usr/include/sys/types.h /usr/include/sys/stat.h
--utils.o: /usr/include/bits/stat.h /usr/include/unistd.h
--utils.o: /usr/include/bits/posix_opt.h /usr/include/bits/confname.h utils.h
--utils.o: resources.h exceptions.h widgets.h font.h main.h screen.h random.h
--game.o: main.h exceptions.h screen.h resources.h random.h utils.h widgets.h
--game.o: font.h puzzle.h iconset.h puzgen.h verthints.h horhints.h topscores.h
--game.o: opensave.h game.h options.h
--widgets.o: widgets.h font.h main.h exceptions.h screen.h resources.h random.h
--widgets.o: utils.h
--iconset.o: /usr/include/string.h /usr/include/features.h
--iconset.o: /usr/include/sys/cdefs.h /usr/include/gnu/stubs.h
--iconset.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
--iconset.o: iconset.h utils.h resources.h exceptions.h widgets.h font.h
--puzzle.o: puzzle.h iconset.h puzgen.h widgets.h font.h main.h exceptions.h
--puzzle.o: screen.h resources.h random.h utils.h
--rules.o: puzgen.h iconset.h utils.h resources.h exceptions.h widgets.h font.h
--rules.o: main.h screen.h random.h
--random.o: random.h utils.h resources.h exceptions.h widgets.h font.h
--horhints.o: horhints.h iconset.h puzgen.h widgets.h font.h main.h
--horhints.o: exceptions.h screen.h resources.h random.h utils.h
--menu.o: main.h exceptions.h screen.h resources.h random.h utils.h widgets.h
--menu.o: font.h topscores.h opensave.h game.h puzgen.h iconset.h verthints.h
--menu.o: horhints.h puzzle.h descr.h options.h
--font.o: font.h main.h exceptions.h screen.h resources.h random.h utils.h
--font.o: widgets.h
--conf.o: /usr/include/ctype.h /usr/include/features.h /usr/include/sys/cdefs.h
--conf.o: /usr/include/gnu/stubs.h /usr/include/bits/types.h
--conf.o: /usr/include/bits/wordsize.h
--conf.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
--conf.o: /usr/include/bits/typesizes.h /usr/include/endian.h
--conf.o: /usr/include/bits/endian.h /usr/include/string.h
--conf.o: /usr/include/stdlib.h /usr/include/stdio.h /usr/include/libio.h
--conf.o: /usr/include/_G_config.h /usr/include/wchar.h
--conf.o: /usr/include/bits/wchar.h /usr/include/gconv.h
--conf.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stdarg.h
--conf.o: /usr/include/bits/stdio_lim.h /usr/include/bits/sys_errlist.h conf.h
--storage.o: storage.h tablestorage.h conf.h
--tablestorage.o: tablestorage.h storage.h conf.h
--topscores.o: topscores.h widgets.h font.h storage.h utils.h resources.h
--topscores.o: exceptions.h
--opensave.o: /usr/include/time.h /usr/include/bits/types.h
--opensave.o: /usr/include/features.h /usr/include/sys/cdefs.h
--opensave.o: /usr/include/gnu/stubs.h /usr/include/bits/wordsize.h
--opensave.o: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/include/stddef.h
--opensave.o: /usr/include/bits/typesizes.h exceptions.h utils.h resources.h
--opensave.o: widgets.h font.h storage.h opensave.h game.h puzgen.h iconset.h
--opensave.o: verthints.h horhints.h puzzle.h
--descr.o: widgets.h font.h
--options.o: options.h widgets.h font.h storage.h main.h exceptions.h screen.h
--options.o: resources.h random.h
-+install:
-+ ${BSD_INSTALL_PROGRAM} einstein ${PREFIX}/bin
-+ mkdir -p ${PREFIX}/share/einstein
-+ ${BSD_INSTALL_DATA} einstein.res ${PREFIX}/share/einstein/einstein.res
+ install: $(TARGET)
+- $(INSTALL) -s -D $(TARGET) $(PREFIX)/bin/$(TARGET)
+- $(INSTALL) -D einstein.res $(PREFIX)/share/einstein/res/einstein.res
++ $(INSTALL) $(TARGET) $(PREFIX)/bin/$(TARGET)
++ mkdir -p $(PREFIX)/share/einstein/res/
++ $(INSTALL) einstein.res $(PREFIX)/share/einstein/res/einstein.res
+
+ # DO NOT DELETE THIS LINE -- make depend depends on it.
+
diff --git a/games/einstein/pkg-descr b/games/einstein/pkg-descr
index 6e8fd7928ba8..1d6158589060 100644
--- a/games/einstein/pkg-descr
+++ b/games/einstein/pkg-descr
@@ -5,5 +5,5 @@ percentile and higher should be able to solve it.
See the WWW site for the rules of the game.
-WWW: http://www.babichev.info/en/projects/einstein/
+WWW: http://games.flowix.com/en/
Author: Alexander Babichev <asso@babichev.info>
diff --git a/games/einstein/pkg-plist b/games/einstein/pkg-plist
index 39e92a4f5f2b..b4fcecec510c 100644
--- a/games/einstein/pkg-plist
+++ b/games/einstein/pkg-plist
@@ -1,3 +1,4 @@
bin/einstein
-share/einstein/einstein.res
+share/einstein/res/einstein.res
+@dirrm share/einstein/res
@dirrm share/einstein