aboutsummaryrefslogtreecommitdiff
path: root/games/el/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-22 13:09:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-22 13:09:29 +0000
commit6720230875cdeb909b35f3c3d701ef1636f40ce4 (patch)
treede36ba7948d16a7442f82cfdb818e5f1f2529ed6 /games/el/Makefile
parent417e6d333c6f7d607a2e9759c9c27ec3aa993133 (diff)
downloadports-6720230875cdeb909b35f3c3d701ef1636f40ce4.tar.gz
ports-6720230875cdeb909b35f3c3d701ef1636f40ce4.zip
Notes
Diffstat (limited to 'games/el/Makefile')
-rw-r--r--games/el/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/games/el/Makefile b/games/el/Makefile
index 2aabda5c3320..19dc04cec85b 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= el
-PORTVERSION= 101
+PORTVERSION= 112
CATEGORIES= games
MASTER_SITES= ftp://ftp.berlios.de/pub/elc/ http://el.tfm.ro/
DISTFILES= ${EL_PROG} ${EL_DATA}
@@ -16,21 +16,27 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Eternal Lands is a free 3D MMORPG
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- vorbis.3:${PORTSDIR}/audio/libvorbis
+ vorbis.3:${PORTSDIR}/audio/libvorbis \
+ cal3d.11:${PORTSDIR}/graphics/cal3d
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-USE_GMAKE= yes
USE_GNOME= libxml2
USE_SDL= sdl net
EL_PROG= elc_${PORTVERSION}.tgz
-EL_DATA= el_${PORTVERSION}.zip
+EL_DATA= el_${PORTVERSION}_linux.zip
WRKSRC= ${WRKDIR}/elc
-ALL_TARGET= el.x86.bsd.bin
+ALL_TARGET= cal3d
MAKEFILE= Makefile.bsd
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+CFLAGS+= -DX86_64
+.endif
+
do-install:
${ECHO} "#!/bin/sh" > ${WRKDIR}/el
${ECHO} "cd ${DATADIR}; ./el.x86.bsd.bin" >> ${WRKDIR}/el
@@ -40,4 +46,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/el.x86.bsd.bin ${DATADIR}
${UNZIP_CMD} ${DISTDIR}/${EL_DATA} -d ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>