aboutsummaryrefslogtreecommitdiff
path: root/games/el
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-07-28 07:50:55 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-07-28 07:50:55 +0000
commit861be7967c8999d3f5c7d8cb190b0db053bfd0d8 (patch)
tree6d22cb0a71e42967e25794beaf81fae67998cc92 /games/el
parent1091dc0943805c6bd21cd08cdf740943e2195adc (diff)
downloadports-861be7967c8999d3f5c7d8cb190b0db053bfd0d8.tar.gz
ports-861be7967c8999d3f5c7d8cb190b0db053bfd0d8.zip
Notes
Diffstat (limited to 'games/el')
-rw-r--r--games/el/Makefile11
-rw-r--r--games/el/distinfo6
-rw-r--r--games/el/files/patch-icon__window.cpp11
-rw-r--r--games/el/files/patch-item__lists.cpp11
-rw-r--r--games/el/files/patch-quest__log.cpp11
5 files changed, 8 insertions, 42 deletions
diff --git a/games/el/Makefile b/games/el/Makefile
index 42db1b145a81..1405d79c3bee 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -2,26 +2,25 @@
# $FreeBSD$
PORTNAME= el
-PORTVERSION= 1.9.4.3
-PORTREVISION= 2
+PORTVERSION= 1.9.5.2
PORTEPOCH= 1
CATEGORIES= games
MAINTAINER= acm@FreeBSD.org
COMMENT= Eternal Lands is a free 3D MMORPG
+BROKEN_powerpc64= fails to compile: cal3d_io_wrapper.cpp: undefined reference to CalCoreAnimation::setFilename
+BROKEN_sparc64= fails to build on sparc64
+
LIB_DEPENDS= libpng.so:graphics/png \
libvorbis.so:audio/libvorbis \
libcal3d.so:graphics/cal3d
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/el.ini:games/el-data
-BROKEN_powerpc64= fails to compile: cal3d_io_wrapper.cpp: undefined reference to CalCoreAnimation::setFilename
-BROKEN_sparc64= fails to build on sparc64
-
USES= compiler:c++11-lang gmake iconv openal:al,alut
USE_GNOME= libxml2
USE_SDL= sdl net image
-USE_GL= yes
+USE_GL= gl
USE_XORG= x11
USE_GITHUB= yes
GH_ACCOUNT= raduprv
diff --git a/games/el/distinfo b/games/el/distinfo
index 64be58f8cf60..7d6578c1ba1b 100644
--- a/games/el/distinfo
+++ b/games/el/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496750892
-SHA256 (raduprv-Eternal-Lands-1.9.4.3_GH0.tar.gz) = 40f46b6a79af480dd39a4333ca54486d6a706f39506f3c25220307431e49bcc5
-SIZE (raduprv-Eternal-Lands-1.9.4.3_GH0.tar.gz) = 2808743
+TIMESTAMP = 1532762837
+SHA256 (raduprv-Eternal-Lands-1.9.5.2_GH0.tar.gz) = 5b452f42e78a27c5dcbd8a8e0e7aee3dfbf3213d96ae5436bf85f2388ca0c67f
+SIZE (raduprv-Eternal-Lands-1.9.5.2_GH0.tar.gz) = 2795612
diff --git a/games/el/files/patch-icon__window.cpp b/games/el/files/patch-icon__window.cpp
deleted file mode 100644
index 2908fc5b94ba..000000000000
--- a/games/el/files/patch-icon__window.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- icon_window.cpp.orig 2014-01-06 13:53:40 UTC
-+++ icon_window.cpp
-@@ -358,7 +358,7 @@ namespace IconWindow
- size_t index = (has_highlight)? 1: 0;
- if (flashing)
- {
-- if (abs(SDL_GetTicks() - last_flash_change) > 250)
-+ if (abs((Sint32)(SDL_GetTicks() - last_flash_change)) > 250)
- {
- last_flash_change = SDL_GetTicks();
- flashing--;
diff --git a/games/el/files/patch-item__lists.cpp b/games/el/files/patch-item__lists.cpp
deleted file mode 100644
index c03cc5358973..000000000000
--- a/games/el/files/patch-item__lists.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- item_lists.cpp.orig 2014-01-06 13:53:40 UTC
-+++ item_lists.cpp
-@@ -796,7 +796,7 @@ namespace ItemLists
- {
- if (!last_mod_time)
- return;
-- if (force || (last_mod_time && abs(last_mod_time - SDL_GetTicks()) > 5000))
-+ if (force || (last_mod_time && abs((Sint32)(last_mod_time - SDL_GetTicks())) > 5000))
- save();
- }
-
diff --git a/games/el/files/patch-quest__log.cpp b/games/el/files/patch-quest__log.cpp
deleted file mode 100644
index 5cc35cb57d27..000000000000
--- a/games/el/files/patch-quest__log.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- quest_log.cpp.orig 2014-01-06 13:53:40 UTC
-+++ quest_log.cpp
-@@ -85,7 +85,7 @@ class Quest_Title_Request
- Uint16 get_id(void) const { return id; }
- void request(void);
- bool been_requested(void) const { return requested; }
-- bool is_too_old(void) const { return (abs(SDL_GetTicks() - request_time) > 5000); }
-+ bool is_too_old(void) const { return (abs((Sint32)(SDL_GetTicks() - request_time)) > 5000); }
- private:
- Uint16 id;
- Uint32 request_time;