aboutsummaryrefslogtreecommitdiff
path: root/games/el
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-01-20 17:29:36 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-01-20 17:29:36 +0000
commit4f9c53f2a49f1d7786d7150799aab1e4ce167efb (patch)
tree45b8611c08a5236db019b0eea697b2c64ab656f6 /games/el
parente7e65734072bb77538c1a034b35e19e9cd78c933 (diff)
downloadports-4f9c53f2a49f1d7786d7150799aab1e4ce167efb.tar.gz
ports-4f9c53f2a49f1d7786d7150799aab1e4ce167efb.zip
- Fix build on amd64
Reported by: itetcu
Notes
Notes: svn path=/head/; revision=226540
Diffstat (limited to 'games/el')
-rw-r--r--games/el/Makefile4
-rw-r--r--games/el/files/patch-Makefile.linux8
-rw-r--r--games/el/files/patch-platform.h11
3 files changed, 15 insertions, 8 deletions
diff --git a/games/el/Makefile b/games/el/Makefile
index 7476d493a7ba..c8ed725709b6 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -35,10 +35,6 @@ PLIST= ${WRKDIR}/pkg-plist
.include <bsd.port.pre.mk>
-.if ${ARCH} == amd64
-CFLAGS+= -DX86_64
-.endif
-
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.endif
diff --git a/games/el/files/patch-Makefile.linux b/games/el/files/patch-Makefile.linux
index 232ae7a6cc14..b7421e37ceda 100644
--- a/games/el/files/patch-Makefile.linux
+++ b/games/el/files/patch-Makefile.linux
@@ -13,10 +13,10 @@
-CXXFLAGS=$(PLATFORM) $(CXXWARN) -O0 -ggdb -pipe $(OPTIONS) $(shell sdl-config --cflags) $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-_CXXFLAGS=$(PLATFORM) -O3 -fomit-frame-pointer -ffast-math -pipe $(OPTIONS) $(shell sdl-config --cflags) $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
+OPTIONS = -DBSD -DLINUX -DELC $(foreach FEATURE, $(FEATURES), -D$(FEATURE))
-+CFLAGS+=$(PLATFORM) $(CWARN) $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-+_CFLAGS=$(CFLAGS) $(PLATFORM) -fomit-frame-pointer -ffast-math -pipe $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-+CXXFLAGS+=$(PLATFORM) $(CXXWARN) $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-+_CXXFLAGS=$(CXXFLAGS) $(PLATFORM) -fomit-frame-pointer -ffast-math -pipe $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
++CFLAGS+=$(CWARN) $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
++_CFLAGS=$(CFLAGS) -fomit-frame-pointer -ffast-math -pipe $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
++CXXFLAGS+=$(CXXWARN) $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
++_CXXFLAGS=$(CXXFLAGS) -fomit-frame-pointer -ffast-math -pipe $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
ZLIB_LIBS = -lz
PNG_SCREENSHOT_LIBS = -lpng
diff --git a/games/el/files/patch-platform.h b/games/el/files/patch-platform.h
new file mode 100644
index 000000000000..281525c0dd1a
--- /dev/null
+++ b/games/el/files/patch-platform.h
@@ -0,0 +1,11 @@
+--- platform.h 2009-01-20 09:51:39.000000000 -0500
++++ platform.h 2009-01-20 09:51:58.000000000 -0500
+@@ -11,7 +11,7 @@
+ // http://predef.sourceforge.net/prearch.html , these ought to work on
+ // gcc, Sun Studio and Visual Studio.
+ // Throw in ia64 as well, though I doubt anyone will play EL on that.
+-#if defined (__x86_64__) || defined (_M_X64) || defined (__ia64__) || defined (_M_IA64)
++#if defined (__x86_64__) || defined (_M_X64) || defined (__ia64__) || defined (_M_IA64) || defined (__amd64__)
+ #define X86_64
+ #endif
+