aboutsummaryrefslogtreecommitdiff
path: root/games/el
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-01-06 15:23:30 +0000
committerRene Ladan <rene@FreeBSD.org>2014-01-06 15:23:30 +0000
commit488eff603e819b80cf488b1394d21cfbd2bd9d99 (patch)
treea16d4cf5ea01f0fa213df644078508ae40c1730b /games/el
parent0189170aed884adc258966d4694fb4483bf4f019 (diff)
downloadports-488eff603e819b80cf488b1394d21cfbd2bd9d99.tar.gz
ports-488eff603e819b80cf488b1394d21cfbd2bd9d99.zip
Notes
Diffstat (limited to 'games/el')
-rw-r--r--games/el/Makefile22
-rw-r--r--games/el/distinfo4
-rw-r--r--games/el/files/patch-Makefile.bsd16
-rw-r--r--games/el/files/patch-make.defaults10
-rw-r--r--games/el/files/patch-platform.h4
5 files changed, 26 insertions, 30 deletions
diff --git a/games/el/Makefile b/games/el/Makefile
index dd584bb1fbbb..64adecde2e87 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -2,23 +2,20 @@
# $FreeBSD$
PORTNAME= el
-PORTVERSION= 192
-PORTREVISION= 3
+PORTVERSION= 193
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
- ${MASTER_SITE_LOCAL:S,$,acm/${PORTNAME}/,}
-DIST_SUBDIR= ${PORTNAME}
+MASTER_SITES= LOCAL/rene \
+ ftp://rene-ladan.nl/pub/distfiles/
MAINTAINER= acm@FreeBSD.org
COMMENT= Eternal Lands is a free 3D MMORPG
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
- libvorbis.so.4:${PORTSDIR}/audio/libvorbis \
- libcal3d.so.12:${PORTSDIR}/graphics/cal3d
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libcal3d.so:${PORTSDIR}/graphics/cal3d
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/el.ini:${PORTSDIR}/games/el-data
-PROJECTHOST= bsdistfiles
-USE_BZIP2= yes
+USE_XZ= yes
USES= gmake openal:al,alut
USE_GNOME= libxml2
USE_SDL= sdl net image
@@ -29,7 +26,6 @@ ALL_TARGET= el.bin
MAKEFILE= Makefile.bsd
PLIST= ${WRKDIR}/pkg-plist
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
@@ -46,8 +42,8 @@ pre-install:
@${ECHO} "@dirrmtry %%DATADIR%%" >> ${PLIST}
do-install:
- @${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKDIR}/el ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/el.bin ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/el ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/el.bin ${STAGEDIR}${DATADIR}
.include <bsd.port.post.mk>
diff --git a/games/el/distinfo b/games/el/distinfo
index 9b42ed9b58b4..000aacbe8ea7 100644
--- a/games/el/distinfo
+++ b/games/el/distinfo
@@ -1,2 +1,2 @@
-SHA256 (el/el-192.tar.bz2) = 0a88f38642d1a05c7b533101201b80632af398cb0bdc616d2d33115e0689cb13
-SIZE (el/el-192.tar.bz2) = 2181980
+SHA256 (el-193.tar.xz) = d8b815a1c1169102ed3fbd440b66afc90fa78589f8e49c4ebd1c31addc0021d0
+SIZE (el-193.tar.xz) = 1941152
diff --git a/games/el/files/patch-Makefile.bsd b/games/el/files/patch-Makefile.bsd
index fa4edcf39b26..da5944138ab1 100644
--- a/games/el/files/patch-Makefile.bsd
+++ b/games/el/files/patch-Makefile.bsd
@@ -1,5 +1,5 @@
---- Makefile.bsd.orig 2011-10-20 11:30:54.000000000 -0500
-+++ Makefile.bsd 2011-10-20 11:40:50.000000000 -0500
+--- Makefile.bsd.orig 2014-01-06 15:25:15.000000000 +0100
++++ Makefile.bsd 2014-01-06 15:49:31.000000000 +0100
@@ -2,17 +2,19 @@
-include make.conf
@@ -12,21 +12,21 @@
-_CFLAGS=$(PLATFORM) -O2 -fomit-frame-pointer -ffast-math -pipe $(OPTIONS) $(shell sdl-config --cflags) $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-CXXFLAGS=$(PLATFORM) $(CXXWARN) -O0 -ggdb -pipe $(OPTIONS) $(shell sdl-config --cflags) $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-_CXXFLAGS=$(PLATFORM) -O3 -fomit-frame-pointer -ffast-math -pipe $(OPTIONS) $(shell sdl-config --cflags) $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-+CFLAGS+=$(CWARN) $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-+_CFLAGS=-fomit-frame-pointer -ffast-math -pipe $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-+CXXFLAGS+=$(CXXWARN) $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
-+_CXXFLAGS=-fomit-frame-pointer -ffast-math $(OPTIONS) `$(SDL_CONFIG) --cflags` $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
++CFLAGS+=$(PLATFORM) $(CWARN) $(OPTIONS) $(shell sdl-config --cflags) $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
++_CFLAGS=-fomit-frame-pointer -ffast-math -pipe $(OPTIONS) $(shell sdl-config --cflags) $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
++CXXFLAGS+=$(CXXWARN) $(OPTIONS) $(shell sdl-config --cflags) $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
++_CXXFLAGS=-fomit-frame-pointer -ffast-math $(OPTIONS) $(shell sdl-config --cflags) $(shell xml2-config --cflags) -fno-strict-aliasing $(EXTRA_INCLUDES)
PNG_SCREENSHOT_LIBS = -lpng
-LDFLAGS=$(shell sdl-config --libs) $(shell xml2-config --libs) -lSDL_net -lSDL_image -lopenal $(XDIR) -lGL -lGLU -lcal3d -lm $(EXTRA_LIBS) -lz -lpng -lvorbis -lvorbisfile \
-+LDFLAGS+=`$(SDL_CONFIG) --libs` $(shell xml2-config --libs) -lSDL_net -lSDL_image -lopenal $(XDIR) -lGL -lGLU -lcal3d -lm $(EXTRA_LIBS) -lz -lpng -lvorbis -lvorbisfile \
++LDFLAGS+=$(shell sdl-config --libs) $(shell xml2-config --libs) -lSDL_net -lSDL_image -lopenal $(XDIR) -lGL -lGLU -lcal3d -lm $(EXTRA_LIBS) -lz -lpng -lvorbis -lvorbisfile \
$(foreach FEATURE, $(FEATURES), $($(FEATURE)_LIBS))
-_LDFLAGS=$(XDIR) -lGL -lpthread -lstdc++
+_LDFLAGS=$(XDIR) -lGL -pthread -lstdc++
# This works on Ubuntu 8.04 (LTS) at least
# Install these packages in addition to those required for a standard build
-@@ -87,16 +89,16 @@
+@@ -86,16 +88,16 @@
DEP_FILES=$(foreach OBJ, $(COBJS), .deps/$(OBJ).P) $(foreach OBJ, $(CXXOBJS), .deps/$(OBJ).P)
#(shell echo $OBJ |sed s/\.o/\.P/))
diff --git a/games/el/files/patch-make.defaults b/games/el/files/patch-make.defaults
index 43a7565672a8..a72d12696501 100644
--- a/games/el/files/patch-make.defaults
+++ b/games/el/files/patch-make.defaults
@@ -1,15 +1,15 @@
---- make.defaults.orig 2011-10-20 11:41:47.000000000 -0500
-+++ make.defaults 2011-10-20 11:42:04.000000000 -0500
-@@ -65,8 +65,6 @@
+--- make.defaults.orig
++++ make.defaults
+@@ -69,8 +69,6 @@ FEATURES += MIDDLE_MOUSE_PASTE # Paste using the middle mouse button from the pr
--PLATFORM=-march=i686
+-PLATFORM=-march=native
-XDIR=-L/usr/X11R6/lib
CWARN=-Wall -Wdeclaration-after-statement
# -Wno-pointer-sign -Wno-sign-compare -Werror
CXXWARN=-Wall
-@@ -82,7 +80,3 @@
+@@ -86,7 +84,3 @@ CXXWARN=-Wall
#EXTRA_INCLUDES=-IC:\\Programme\\Dev-Cpp\\Include
#EXTRA_LIBS=-lz
#EXTRA_STATICLIBS=libs/zlib.a
diff --git a/games/el/files/patch-platform.h b/games/el/files/patch-platform.h
index 281525c0dd1a..e9b6c6748687 100644
--- a/games/el/files/patch-platform.h
+++ b/games/el/files/patch-platform.h
@@ -1,5 +1,5 @@
---- platform.h 2009-01-20 09:51:39.000000000 -0500
-+++ platform.h 2009-01-20 09:51:58.000000000 -0500
+--- platform.h.orig
++++ platform.h
@@ -11,7 +11,7 @@
// http://predef.sourceforge.net/prearch.html , these ought to work on
// gcc, Sun Studio and Visual Studio.