aboutsummaryrefslogtreecommitdiff
path: root/games/el
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-02-01 20:26:50 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-02-01 20:26:50 +0000
commit78f4c2788131109fff9ea76edc442756d2239667 (patch)
treed670aabd0faff6ba90e97e60625412b4d2228f41 /games/el
parenta268088162eecd3e5850162b68a9f70c6a4f5f4e (diff)
downloadports-78f4c2788131109fff9ea76edc442756d2239667.tar.gz
ports-78f4c2788131109fff9ea76edc442756d2239667.zip
Notes
Diffstat (limited to 'games/el')
-rw-r--r--games/el/Makefile3
-rw-r--r--games/el/distinfo6
-rw-r--r--games/el/files/patch-sound.c56
3 files changed, 4 insertions, 61 deletions
diff --git a/games/el/Makefile b/games/el/Makefile
index 38ebd7e180f4..ee0fe2e1ef48 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= el
-PORTVERSION= 132
-PORTREVISION= 1
+PORTVERSION= 133
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= acm/${PORTNAME}
diff --git a/games/el/distinfo b/games/el/distinfo
index fc88aa89b2dc..8207cf069c77 100644
--- a/games/el/distinfo
+++ b/games/el/distinfo
@@ -1,3 +1,3 @@
-MD5 (el/el-132.tar.bz2) = 77d8f6d22ba87e2bf84569ebaaa408d3
-SHA256 (el/el-132.tar.bz2) = 0cb557bd567d952ee613663a3cf31d807153d92d6e8327dd86ac4d83333741c0
-SIZE (el/el-132.tar.bz2) = 802765
+MD5 (el/el-133.tar.bz2) = d8353219e21ccdb9e3c4143d05f7aa71
+SHA256 (el/el-133.tar.bz2) = 60a4adb6ed5065f28c8610118f64d085456aac3f883f1fee42ea9a005f539e19
+SIZE (el/el-133.tar.bz2) = 799859
diff --git a/games/el/files/patch-sound.c b/games/el/files/patch-sound.c
deleted file mode 100644
index 8cc374a1967a..000000000000
--- a/games/el/files/patch-sound.c
+++ /dev/null
@@ -1,56 +0,0 @@
---- sound.c Mon Aug 21 11:20:53 2006
-+++ sound.c Mon Aug 21 11:25:49 2006
-@@ -313,10 +313,11 @@
- ALuint get_loaded_buffer(int i)
- {
- int error;
-- ALsizei size,freq;
-+ ALsizei size;
- ALenum format;
-- ALvoid *data;
- ALboolean loop;
-+ ALfloat freq;
-+ ALvoid* data = 0;
- FILE *fin;
-
- if(!alIsBuffer(sound_buffer[i]))
-@@ -349,10 +350,10 @@
- // OS X alutLoadWAVFile doesn't have a loop option... Oh well :-)
- alutLoadWAVFile (sound_files[i], &format, &data, &size, &freq);
- #else
-- alutLoadWAVFile (sound_files[i], &format, &data, &size, &freq, &loop);
-+ data = alutLoadMemoryFromFile (sound_files[i], &format, &size, &freq);
- #endif
-- alBufferData(sound_buffer[i],format,data,size,freq);
-- alutUnloadWAV(format,data,size,freq);
-+ alBufferData(sound_buffer[i],format,data,size,(int)freq);
-+ free(data);
- }
- return sound_buffer[i];
- }
-@@ -377,14 +378,14 @@
- #ifndef OSX
- alutLoadWAVFile(szPath,&pSample->format,&data,&pSample->size,&pSample->freq,&loop);
- #else
-- alutLoadWAVFile(szPath,&pSample->format,&data,&pSample->size,&pSample->freq);
-+ data = alutLoadMemoryFromFile(szPath, &pSample->format, &pSample->size, &pSample->freq);
- #endif
- if(!data)
- {//couldn't load the file
- #ifdef ELC
- LOG_ERROR("%s: %s",snd_buff_error, "NO SOUND DATA");
- #else
-- printf("ensure_sample_loaded : alutLoadWAVFile(%s) = %s\n",
-+ printf("ensure_sample_loaded : alutLoadMemoryFromFile(%s) = %s\n",
- szPath, "NO SOUND DATA");
- #endif
- return 1;
-@@ -420,7 +421,7 @@
- pSample->length = (pSample->size*1000) / ((pSample->bits >> 3)*pSample->channels*pSample->freq);
-
- //get rid of the temporary data
-- alutUnloadWAV(pSample->format,data,pSample->size,pSample->freq);
-+ free(data);
- }
-
- pSample->loaded_status = 1;