aboutsummaryrefslogtreecommitdiff
path: root/games/emacs-chess/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 05:02:22 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 05:02:22 +0000
commita49cffc503ae37904a71d3d509f37a0e27187f09 (patch)
treefa54f5fbf163547f8258c3dca5e1282d93ab0994 /games/emacs-chess/Makefile
parente58ac308df15f648e541fbfd695134721652a165 (diff)
downloadports-a49cffc503ae37904a71d3d509f37a0e27187f09.tar.gz
ports-a49cffc503ae37904a71d3d509f37a0e27187f09.zip
Notes
Diffstat (limited to 'games/emacs-chess/Makefile')
-rw-r--r--games/emacs-chess/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/emacs-chess/Makefile b/games/emacs-chess/Makefile
new file mode 100644
index 000000000000..394d21e7948d
--- /dev/null
+++ b/games/emacs-chess/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: emacs-chess
+# Date created: 05 March 2003
+# Whom: Steffen Mazanek
+#
+# $FreeBSD$
+#
+
+PORTNAME= emacs-chess
+PORTVERSION= 2.0b3
+CATEGORIES= games elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= emacs-chess
+DISTFILES= chess-2.0b3.tar.bz2 \
+ sounds.tar.bz2 \
+ pieces.tar.bz2
+
+MAINTAINER= steffen.mazanek@unibw-muenchen.de
+COMMENT= Play chess with emacs
+
+RUN_DEPENDS= gnuchess:${PORTSDIR}/games/gnuchess
+
+EMACS_PORT_NAME= emacs21
+USE_BZIP2= yes
+PLIST_SUB= EMACS-CHESS-DIR=${EMACS_VERSION_SITE_LISPDIR}
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/chess-${PORTVERSION}
+LISPDIR= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}
+
+pre-build:
+ @(cd ${WRKSRC} && ${RM} -f *.elc)
+do-install:
+ @(mkdir ${LISPDIR}/${PORTNAME} || ${ECHO} "directory exists")
+ ${CP} ${WRKSRC}/*.elc ${LISPDIR}/${PORTNAME}
+ ${CP} -r ${WRKDIR}/sounds ${LISPDIR}/${PORTNAME}
+ ${CP} -r ${WRKDIR}/pieces ${LISPDIR}/${PORTNAME}
+
+.include <bsd.port.mk>