aboutsummaryrefslogtreecommitdiff
path: root/games/ember/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-10-29 15:01:49 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-10-29 15:01:49 +0000
commit38d03f1c51cfc03cb6f54d7e27b98bc8e92593b5 (patch)
tree096c0c1480c17424e9911fb8e463e7b7c755e1f6 /games/ember/Makefile
parent62954dc35607cbea9609e5f62d201b309f50380e (diff)
downloadports-38d03f1c51cfc03cb6f54d7e27b98bc8e92593b5.tar.gz
ports-38d03f1c51cfc03cb6f54d7e27b98bc8e92593b5.zip
Notes
Diffstat (limited to 'games/ember/Makefile')
-rw-r--r--games/ember/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 01122880d758..5f2fe20b0647 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ember
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.4
PORTREVISION= 0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR=worldforge
MAINTAINER= oliver@FreeBSD.org
COMMENT= Ember is a WorldForge 3d client using the OGRE 3d library
+RUN_DEPENDS= ${X11BASE}/bin/WFUT.jar:${PORTSDIR}/devel/wfut
LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
OgreMain.9:${PORTSDIR}/graphics/ogre3d \
eris-1.3:${PORTSDIR}/devel/eris \
@@ -22,16 +23,14 @@ LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
mercator-0.2.4:${PORTSDIR}/devel/mercator \
openal.0:${PORTSDIR}/audio/openal
-RUN_DEPENDS= ${X11BASE}/bin/WFUT.jar:${PORTSDIR}/devel/wfut
-
-CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc --program-transform-name=
-USE_LIBTOOL= 15
+CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc --program-transform-name= --disable-cppunit
+USE_LIBTOOL_VER=15
USE_SDL= sdl image
USE_REINPLACE= YES
GNU_CONFIGURE= YES
INSTALLS_SHLIB= YES
USE_GCC= 3.4
-USE_ZIP= YES
+USE_BZIP2= YES
USE_X_PREFIX= YES
USE_GNOME= gnomehack
CPPFLAGS= -DBR_NO_MACROS
@@ -41,29 +40,26 @@ CPPFLAGS= -DBR_NO_MACROS
post-patch:
@${REINPLACE_CMD} -e '\
s|sdl-config|${SDL_CONFIG}|g; \
- s|"-lopenal|"-L${LOCALBASE}/lib -lopenal ${PTHREAD_LIBS}|g; \
s|"-lIL|"-L${LOCALBASE}/lib -lIL|g; \
s|CEGUI-OGRE_\([A-Z]*=\)|CEGUI_OGRE_\1|g; \
s|\$$CEGUI-OGRE_\([A-Z]*\)|\$$CEGUI_OGRE_\1|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e '\
+ s|^CFLAGS =.*|& $${SDL_CFLAGS} -I${X11BASE}/include|g' \
+ ${WRKSRC}/src/framework/Makefile.in
+ @${REINPLACE_CMD} -e '\
s|<SDL/|<|g; \
s|libSDL_image-1\.2\.so\.0|libSDL_image\.so|g' \
${WRKSRC}/configure \
- ${WRKSRC}/src/components/ogre/EmberOgre.cpp
- @${REINPLACE_CMD} -e 's|#include "framework/float_cast.h"||g' \
- ${WRKSRC}/src/components/ogre/environment/meshtree/TStem.cpp
+ ${WRKSRC}/src/components/ogre/EmberOgre.cpp \
+ ${WRKSRC}/src/framework/scrap.c
@${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
${WRKSRC}/src/components/ogre/SceneManagers/EmberPagingSceneManager/src/filetutils.cpp
- @${REINPLACE_CMD} -e 's|#include "OgrePagingLandScapeIntersectionSceneQuery.h"||' \
- ${WRKSRC}/src/components/ogre/SceneManagers/EmberPagingSceneManager/src/OgrePagingLandScapeSceneManager.cpp
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '\
/Plugin=Plugin_CgProgramManager.so/d; \
s|/usr/lib/OGRE|${X11BASE}/lib/OGRE|' \
${WRKSRC}/src/components/ogre/plugins.cfg
- @${REINPLACE_CMD} -e 's|(br_thread_local_store (br_prepend_prefix ((void \*) "", "\([^"]*\)")))|"${PREFIX}\1"|g' \
- ${WRKSRC}/src/framework/prefix.h
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|lrintf|(long int)rintf|g' \
${WRKSRC}/src/components/ogre/environment/meshtree/TStem.cpp \