aboutsummaryrefslogtreecommitdiff
path: root/games/ember
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:30:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:30:56 +0000
commit941c31ac7a3207a98179dd300f278e403bbb7429 (patch)
treea6146451714d833c93796dc754a7f017110bbcc5 /games/ember
parente836ab008ac38916a93472f2840e03e2e8470ef5 (diff)
downloadports-941c31ac7a3207a98179dd300f278e403bbb7429.tar.gz
ports-941c31ac7a3207a98179dd300f278e403bbb7429.zip
Notes
Diffstat (limited to 'games/ember')
-rw-r--r--games/ember/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/games/ember/Makefile b/games/ember/Makefile
index fb47d8f31f23..df2442e2be43 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -27,17 +27,14 @@ LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc \
--program-transform-name= --disable-cppunit --disable-debug \
--with-toluaxx=${TOLUAXX_CMD}
-CONFIGURE_ENV+= LUA_LIBS="-L${LUA_LIBDIR} -llua" \
+CONFIGURE_ENV+= LUA_LIBS="-L${LUA_LIBDIR} -llua-${LUA_VER}" \
LUA_CFLAGS="-I${LUA_INCDIR}" \
TOLUAXX="${TOLUAXX_CMD}"
USE_SDL= sdl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_LUA= 5.1
-LUA_COMPS= toluaxx
-USES= openal:al,alut pathfix pkgconfig compiler:c++11-lib
-USE_BZIP2= YES
+USES= openal:al,alut pathfix pkgconfig compiler:c++11-lib tar:bzip2
OPTIONS_DEFINE= DOCS