aboutsummaryrefslogtreecommitdiff
path: root/games/ember
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-10-05 18:08:44 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-10-05 18:08:44 +0000
commit8ce70f7ffe0d30d0fa17130f88f43b99ec3960ae (patch)
treee9c82077d7b231f5cb5392e6194caa146037372c /games/ember
parent2b01d3cac19384c971a20431320935b7c911c00c (diff)
downloadports-8ce70f7ffe0d30d0fa17130f88f43b99ec3960ae.tar.gz
ports-8ce70f7ffe0d30d0fa17130f88f43b99ec3960ae.zip
Notes
Diffstat (limited to 'games/ember')
-rw-r--r--games/ember/Makefile7
-rw-r--r--games/ember/files/patch-ember9
2 files changed, 12 insertions, 4 deletions
diff --git a/games/ember/Makefile b/games/ember/Makefile
index f5f86d7ac573..44dadde6229f 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ember
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=worldforge
@@ -25,6 +26,8 @@ LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
mercator-0.2.4:${PORTSDIR}/devel/mercator \
openal.0:${PORTSDIR}/audio/openal
+RUN_DEPENDS= ${X11BASE}/bin/WFUT.jar:${PORTSDIR}/devel/wfut
+
CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc --program-transform-name=
USE_SDL= sdl image
USE_REINPLACE= YES
@@ -57,6 +60,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|#include "OgrePagingLandScapeIntersectionSceneQuery.h"||' \
${WRKSRC}/src/components/ogre/SceneManagers/EmberPagingSceneManager/src/OgrePagingLandScapeSceneManager.cpp
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '\
+ /Plugin=Plugin_CgProgramManager.so/d; \
+ s|/usr/lib/OGRE|${X11BASE}/lib/OGRE|' \
+ ${WRKSRC}/src/components/ogre/plugins.cfg
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|lrintf|(long int)rintf|g' \
${WRKSRC}/src/components/ogre/environment/meshtree/TStem.cpp \
diff --git a/games/ember/files/patch-ember b/games/ember/files/patch-ember
index 18aa9e40e171..0a5e86dfba96 100644
--- a/games/ember/files/patch-ember
+++ b/games/ember/files/patch-ember
@@ -1,6 +1,6 @@
--- /dev/null Mon Oct 3 20:13:37 2005
+++ ember Mon Oct 3 20:17:51 2005
-@@ -0,0 +1,128 @@
+@@ -0,0 +1,129 @@
+#!/bin/sh
+
+
@@ -80,12 +80,12 @@
+ # See if Updater exists in home dir
+ if [ ! -e $homedata/$WFUT_JAR ] ; then
+ # Check to see if its in the install dir
-+ if [ -e $datadir/$WFUT_JAR ] ; then
++ if [ -e $bindir/$WFUT_JAR ] ; then
+ # Install into home dir
+ echo "Installing Updater"
+
+ # Copy WFUT to home dir
-+ cp $datadir/$WFUT_JAR $homedata
++ cp $bindir/$WFUT_JAR $homedata
+
+ fi
+ fi
@@ -127,5 +127,6 @@
+# Execute real ember binary
+echo "Starting Ember...."
+#we have to do the LD_PRELOAD thing, because else at least I get an error: libnvidia-tls.so.1: cannot handle TLS data /ehj
-+LD_PRELOAD=libGL.so.1 $bindir/ember.bin --binrelocloading
++[ ! -f $homedata/plugins.cfg ] && cp $etcdir/plugins.cfg $homedata/
++LD_PRELOAD=libGL.so.1 $bindir/ember.bin
+