aboutsummaryrefslogtreecommitdiff
path: root/games/empire
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-10-30 15:52:36 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-10-30 15:52:36 +0000
commit4293d7ce2e0eb74431f5e2d58f467887923044ff (patch)
tree10173de0245d48825c9614fe5a9153e50751cc1d /games/empire
parent1c6d758f75f4c012002b80d9de0a4824a1a7fb98 (diff)
downloadports-4293d7ce2e0eb74431f5e2d58f467887923044ff.tar.gz
ports-4293d7ce2e0eb74431f5e2d58f467887923044ff.zip
Notes
Diffstat (limited to 'games/empire')
-rw-r--r--games/empire/Makefile7
-rw-r--r--games/empire/distinfo5
-rw-r--r--games/empire/files/patch-Makefile23
-rw-r--r--games/empire/files/patch-aa53
-rw-r--r--games/empire/files/patch-ab11
-rw-r--r--games/empire/files/patch-ac38
-rw-r--r--games/empire/files/patch-ad9
7 files changed, 29 insertions, 117 deletions
diff --git a/games/empire/Makefile b/games/empire/Makefile
index 4e3ab9adca77..641b06c76dd9 100644
--- a/games/empire/Makefile
+++ b/games/empire/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= empire
-PORTVERSION= 1.7
-PORTREVISION= 1
+PORTVERSION= 1.8
CATEGORIES= games
MASTER_SITES= http://www.catb.org/~esr/vms-empire/
DISTNAME= vms-${PORTNAME}-${PORTVERSION}
@@ -15,6 +14,8 @@ DISTNAME= vms-${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Solitaire empire game "VMS Empire"
+LICENSE= GPLv2
+
MAN6= empire.6
PLIST_FILES= bin/empire
PORTDOCS= BUGS README
@@ -29,7 +30,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vms-empire ${PREFIX}/bin/empire
- ${INSTALL_MAN} ${WRKSRC}/vms-empire.6 ${MANPREFIX}/man/man6/empire.6
+ ${INSTALL_MAN} ${WRKSRC}/empire.6 ${MANPREFIX}/man/man6/empire.6
.if !defined(NOPORTDOCS)
.for file in BUGS README
@${MKDIR} ${DOCSDIR}
diff --git a/games/empire/distinfo b/games/empire/distinfo
index ea869787528c..da5271c4c416 100644
--- a/games/empire/distinfo
+++ b/games/empire/distinfo
@@ -1,3 +1,2 @@
-MD5 (vms-empire-1.7.tar.gz) = d458082c1052e63c1700fa5b54d4ef6f
-SHA256 (vms-empire-1.7.tar.gz) = 6295d7e6d88c0d6680035b5924c36665d68c4cf62e88bba2228c8d3e7d132d94
-SIZE (vms-empire-1.7.tar.gz) = 84726
+SHA256 (vms-empire-1.8.tar.gz) = 32712ff7256587b65135a1e6a95de1c83b2cd35784ff6f5fcb22ddd18da293dd
+SIZE (vms-empire-1.8.tar.gz) = 89528
diff --git a/games/empire/files/patch-Makefile b/games/empire/files/patch-Makefile
new file mode 100644
index 000000000000..5f40ab845f52
--- /dev/null
+++ b/games/empire/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig 2010-10-21 13:29:25.000000000 +0200
++++ Makefile 2010-10-24 15:49:36.000000000 +0200
+@@ -11,17 +11,17 @@
+ # Use -g to compile the program for debugging.
+
+ #DEBUG = -g -DDEBUG -Wall
+-DEBUG = -O2
++#DEBUG = -O2
+
+ # Use -p to profile the program.
+ #PROFILE = -p -DPROFILE
+ PROFILE =
+
+-LIBS = -lncurses
++LIBS = -lcurses
+
+ # You shouldn't have to modify anything below this line.
+
+-CFLAGS = $(DEBUG) $(PROFILE)
++CFLAGS+= $(DEBUG) $(PROFILE)
+
+ FILES = \
+ attack.c \
diff --git a/games/empire/files/patch-aa b/games/empire/files/patch-aa
deleted file mode 100644
index 498dcce6a594..000000000000
--- a/games/empire/files/patch-aa
+++ /dev/null
@@ -1,53 +0,0 @@
-*** Makefile.orig Fri Aug 2 04:04:02 2002
---- Makefile Sat Jan 25 06:35:29 2003
-***************
-*** 12,35 ****
- # Change the line below for your system. If you are on a Sun or Vax,
- # you may want BSD.
-
-! SYS = LINUX
-! #SYS = BSD
- #SYS = SYSV
-
- # Use -g to compile the program for debugging.
-
- #DEBUG = -g -DDEBUG -Wall
-! DEBUG = -O2
-
- # Use -p to profile the program.
- #PROFILE = -p -DPROFILE
- PROFILE =
-
-! LIBS = -lncurses
-
- # You shouldn't have to modify anything below this line.
-
-! CFLAGS = $(DEBUG) $(PROFILE) -D$(SYS)
-
- FILES = \
- attack.c \
---- 12,35 ----
- # Change the line below for your system. If you are on a Sun or Vax,
- # you may want BSD.
-
-! #SYS = LINUX
-! SYS = BSD
- #SYS = SYSV
-
- # Use -g to compile the program for debugging.
-
- #DEBUG = -g -DDEBUG -Wall
-! #DEBUG = -O2
-
- # Use -p to profile the program.
- #PROFILE = -p -DPROFILE
- PROFILE =
-
-! LIBS = -lcurses
-
- # You shouldn't have to modify anything below this line.
-
-! CFLAGS+= $(DEBUG) $(PROFILE) -D$(SYS)
-
- FILES = \
- attack.c \
diff --git a/games/empire/files/patch-ab b/games/empire/files/patch-ab
deleted file mode 100644
index 131bd102e43d..000000000000
--- a/games/empire/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- empire.h.orig Sat Sep 18 18:34:59 1999
-+++ empire.h Sat Sep 18 18:35:39 1999
-@@ -25,7 +25,7 @@
- #ifndef SYSV
- #define memcpy(dst,src,len) bcopy((src),(dst),(len))
- #define strchr(s,c) index(s,c)
--typedef char chtype;
-+typedef char chartype;
- #define beep() (putchar('\7'))
- #define napms(d) (usleep((d)*1000))
- #else
diff --git a/games/empire/files/patch-ac b/games/empire/files/patch-ac
deleted file mode 100644
index 32f69e475a68..000000000000
--- a/games/empire/files/patch-ac
+++ /dev/null
@@ -1,38 +0,0 @@
---- display.c.orig Sat Sep 18 18:35:53 1999
-+++ display.c Sat Sep 18 18:36:16 1999
-@@ -236,7 +236,7 @@
- for (r = 0; jnkbuf[r] != '\0'; r++) {
- if (r+NUMTOPS >= MAP_HEIGHT) break;
- (void) move (r+NUMTOPS, cols-NUMSIDES+4);
-- (void) addch ((chtype)jnkbuf[r]);
-+ (void) addch ((chartype)jnkbuf[r]);
- }
- }
-
-@@ -278,7 +278,7 @@
- break;
- }
- #endif /* A_COLOR */
-- (void) addch ((chtype)vp->contents);
-+ (void) addch ((chartype)vp->contents);
- #ifdef A_COLOR
- attrset(0);
- attron(COLOR_PAIR(COLOR_WHITE));
-@@ -420,7 +420,7 @@
- cell = vmap[row_col_loc(r,c)].contents;
-
- (void) move (row/row_inc + NUMTOPS, col/col_inc);
-- (void) addch ((chtype)cell);
-+ (void) addch ((chartype)cell);
- }
-
- /*
-@@ -498,7 +498,7 @@
- print_zoom_cell (vmap, row, col, row_inc, col_inc);
- else {
- (void) move (row/row_inc + NUMTOPS, col/col_inc);
-- (void) addch ((chtype)cell);
-+ (void) addch ((chartype)cell);
- }
- }
-
diff --git a/games/empire/files/patch-ad b/games/empire/files/patch-ad
deleted file mode 100644
index 6e53d48566cb..000000000000
--- a/games/empire/files/patch-ad
+++ /dev/null
@@ -1,9 +0,0 @@
---- game.c.orig Sat Sep 18 18:36:29 1999
-+++ game.c Sat Sep 18 18:36:40 1999
-@@ -850,5 +850,5 @@
- cell = mbuf[row_col_loc(r,c)];
-
- (void) move (row/row_inc + NUMTOPS, col/col_inc);
-- (void) addch ((chtype)cell);
-+ (void) addch ((chartype)cell);
- }