aboutsummaryrefslogtreecommitdiff
path: root/games/empire
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-24 16:25:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-24 16:25:41 +0000
commitc57053cf0ea711439dd9950ad0ee5d1ae8b11097 (patch)
treeb8be795c034b3d1e3803b4c2b874e3ee3215e1b5 /games/empire
parent507b4c8ad120c59db0eccf394d702a47b6539d41 (diff)
Notes
Diffstat (limited to 'games/empire')
-rw-r--r--games/empire/Makefile18
-rw-r--r--games/empire/distinfo4
-rw-r--r--games/empire/files/patch-Makefile23
3 files changed, 12 insertions, 33 deletions
diff --git a/games/empire/Makefile b/games/empire/Makefile
index b9e4e1984515..1212101cef43 100644
--- a/games/empire/Makefile
+++ b/games/empire/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= empire
-PORTVERSION= 1.8
+PORTVERSION= 1.9
CATEGORIES= games
MASTER_SITES= http://www.catb.org/~esr/vms-empire/
DISTNAME= vms-${PORTNAME}-${PORTVERSION}
@@ -15,25 +15,27 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Solitaire empire game "VMS Empire"
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+MAKE_JOBS_SAFE= yes
MAN6= empire.6
-PLIST_FILES= bin/empire
PORTDOCS= BUGS README
-USE_GMAKE= yes
-
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/empire
post-patch:
+ @${REINPLACE_CMD} -e 's/^CFLAGS/#CFLAGS/ ; \
+ s/-lncurses/-lcurses/' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's/static void/void/g' ${WRKSRC}/game.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vms-empire ${PREFIX}/bin/empire
- ${INSTALL_MAN} ${WRKSRC}/empire.6 ${MANPREFIX}/man/man6/empire.6
+ ${INSTALL_MAN} ${WRKSRC}/empire.6 ${MAN6PREFIX}/man/man6/empire.6
.if !defined(NOPORTDOCS)
-.for file in BUGS README
+.for file in ${PORTDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/empire/distinfo b/games/empire/distinfo
index da5271c4c416..f6bdac6c1811 100644
--- a/games/empire/distinfo
+++ b/games/empire/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vms-empire-1.8.tar.gz) = 32712ff7256587b65135a1e6a95de1c83b2cd35784ff6f5fcb22ddd18da293dd
-SIZE (vms-empire-1.8.tar.gz) = 89528
+SHA256 (vms-empire-1.9.tar.gz) = 9fc3f2cd03fd02b3a7cb5de0598fa981f7462bb4f9e819c63a02eca6ad76dff2
+SIZE (vms-empire-1.9.tar.gz) = 97370
diff --git a/games/empire/files/patch-Makefile b/games/empire/files/patch-Makefile
deleted file mode 100644
index 5f40ab845f52..000000000000
--- a/games/empire/files/patch-Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- Makefile.orig 2010-10-21 13:29:25.000000000 +0200
-+++ Makefile 2010-10-24 15:49:36.000000000 +0200
-@@ -11,17 +11,17 @@
- # Use -g to compile the program for debugging.
-
- #DEBUG = -g -DDEBUG -Wall
--DEBUG = -O2
-+#DEBUG = -O2
-
- # Use -p to profile the program.
- #PROFILE = -p -DPROFILE
- PROFILE =
-
--LIBS = -lncurses
-+LIBS = -lcurses
-
- # You shouldn't have to modify anything below this line.
-
--CFLAGS = $(DEBUG) $(PROFILE)
-+CFLAGS+= $(DEBUG) $(PROFILE)
-
- FILES = \
- attack.c \