aboutsummaryrefslogtreecommitdiff
path: root/games/endless-sky
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-05-03 02:44:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-05-03 02:44:46 +0000
commite8a530a3bcec02ac516b51493b4f2c4da0c71bc7 (patch)
tree73d77232cd838d65aec337162d483244a7b6ddcd /games/endless-sky
parent29c878486a166e7ccaeecaf6568d1f6e25056ea5 (diff)
Notes
Diffstat (limited to 'games/endless-sky')
-rw-r--r--games/endless-sky/Makefile2
-rw-r--r--games/endless-sky/distinfo6
-rw-r--r--games/endless-sky/files/patch-SConstruct19
3 files changed, 9 insertions, 18 deletions
diff --git a/games/endless-sky/Makefile b/games/endless-sky/Makefile
index ea3b988c7127..9e083e8103b3 100644
--- a/games/endless-sky/Makefile
+++ b/games/endless-sky/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= endless-sky
-PORTVERSION= 0.9.10
+PORTVERSION= 0.9.12
DISTVERSIONPREFIX= v
CATEGORIES= games
diff --git a/games/endless-sky/distinfo b/games/endless-sky/distinfo
index 066808ca8483..8c682f87455f 100644
--- a/games/endless-sky/distinfo
+++ b/games/endless-sky/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1569936654
-SHA256 (endless-sky-endless-sky-v0.9.10_GH0.tar.gz) = 58f2e405e171be8426004216df4df7bb3a2792a507a5d01f77a0f02346332f6f
-SIZE (endless-sky-endless-sky-v0.9.10_GH0.tar.gz) = 98348108
+TIMESTAMP = 1588440467
+SHA256 (endless-sky-endless-sky-v0.9.12_GH0.tar.gz) = 31f76ac11666415478678d924174d43a620a7fd1093e95131776aed12b912eb4
+SIZE (endless-sky-endless-sky-v0.9.12_GH0.tar.gz) = 103105695
diff --git a/games/endless-sky/files/patch-SConstruct b/games/endless-sky/files/patch-SConstruct
index 0f1b2b956c16..6595593e6704 100644
--- a/games/endless-sky/files/patch-SConstruct
+++ b/games/endless-sky/files/patch-SConstruct
@@ -1,15 +1,6 @@
---- SConstruct.orig 2019-09-28 17:59:47 UTC
+--- SConstruct.orig 2020-02-24 15:50:12 UTC
+++ SConstruct
-@@ -2,6 +2,8 @@ import os
-
- # Load environment variables, including some that should be renamed.
- env = Environment(ENV = os.environ)
-+if 'CXX' in os.environ:
-+ env['CXX'] = os.environ['CXX']
- if 'CXXFLAGS' in os.environ:
- env.Append(CCFLAGS = os.environ['CXXFLAGS'])
- if 'LDFLAGS' in os.environ:
-@@ -22,7 +24,7 @@ Help(opts.GenerateHelpText(env))
+@@ -24,7 +24,7 @@ Help(opts.GenerateHelpText(env))
flags = ["-std=c++11", "-Wall"]
if env["mode"] != "debug":
@@ -18,7 +9,7 @@
if env["mode"] == "debug":
flags += ["-g"]
if env["mode"] == "profile":
-@@ -57,7 +59,7 @@ sky = env.Program("endless-sky", Glob(buildDirectory +
+@@ -59,7 +59,7 @@ sky = env.Program("endless-sky", Glob(buildDirectory +
# Install the binary:
@@ -27,7 +18,7 @@
# Install the desktop file:
env.Install("$DESTDIR$PREFIX/share/applications", "endless-sky.desktop")
-@@ -85,7 +87,7 @@ if env.get("PREFIX").startswith("/usr/"):
+@@ -87,7 +87,7 @@ if env.get("PREFIX").startswith("/usr/"):
# Install the man page.
env.Command(
@@ -36,7 +27,7 @@
"endless-sky.6",
"gzip -c $SOURCE > $TARGET")
-@@ -98,11 +100,11 @@ def RecursiveInstall(env, target, source):
+@@ -100,11 +100,11 @@ def RecursiveInstall(env, target, source):
RecursiveInstall(env, os.path.join(target, name), node.abspath)
else:
env.Install(target, node)