aboutsummaryrefslogtreecommitdiff
path: root/games/enigma/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-20 11:15:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-20 11:15:39 +0000
commitf93a811dcf3422b83bf82051439815e2aced4e6f (patch)
tree003334cdc2282106c8065c00caad376d7e8594d2 /games/enigma/Makefile
parent586aceca850efd2d1be07e66c5555e4fd81c59aa (diff)
downloadports-f93a811dcf3422b83bf82051439815e2aced4e6f.tar.gz
ports-f93a811dcf3422b83bf82051439815e2aced4e6f.zip
Notes
Diffstat (limited to 'games/enigma/Makefile')
-rw-r--r--games/enigma/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index 7a80d3d50ed1..91e04913a302 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -16,24 +16,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= edwin@mavetju.org
COMMENT= Enigma is a reimplementation of Oxyd, a puzzle game
-BUILD_DEPENDS= sdl11-config:${PORTSDIR}/devel/sdl12 \
- lua:${PORTSDIR}/lang/lua
-LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image \
- SDL_gfx.10:${PORTSDIR}/graphics/sdl_gfx
+BUILD_DEPENDS= lua:${PORTSDIR}/lang/lua
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_GMAKE= yes
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+USE_SDL= gfx image mixer sdl
CONFIGURE_ARGS= --target=""
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CXXFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include"
MAN6= enigma.6
post-install:
- @${CAT} pkg-message
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>