aboutsummaryrefslogtreecommitdiff
path: root/games/enigma
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
commitc5aeb93cd5e4998728da54611bdf63c686a2fdfd (patch)
treef418d7aa01e7bae10fc4d0734eec45cd9e925529 /games/enigma
parentf4c5a682e5c43c1c1477307463458409ae3b3de5 (diff)
downloadports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.tar.gz
ports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.zip
Notes
Diffstat (limited to 'games/enigma')
-rw-r--r--games/enigma/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index 5e35d45dc76d..8c33648d3237 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -15,21 +15,23 @@ DISTNAME= enigma-${PORTVERSION}
MAINTAINER= anholt@FreeBSD.org
COMMENT= Enigma is a reimplementation of Oxyd, a puzzle game
-BUILD_DEPENDS= ${LOCALBASE}/bin/tolua:${PORTSDIR}/lang/tolua4
-LIB_DEPENDS= zipios.0:${PORTSDIR}/archivers/zipios++ \
- lua.4:${PORTSDIR}/lang/lua4
+LIB_DEPENDS= zipios.0:${PORTSDIR}/archivers/zipios++
USE_GCC= 3.4
-
-GNU_CONFIGURE= yes
-USE_XLIB= yes
USE_GMAKE= yes
USE_GETTEXT= yes
+USE_LUA= 4.0
+LUA_COMPS= lua tolua
USE_SDL= gfx image mixer sdl ttf
+USE_XLIB= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target="" \
--with-libintl-prefix="${LOCALBASE}"
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CXXFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${LOCALBASE}/include -I${LUA_INCDIR}
+CXXFLAGS= -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${LUA_LIBDIR} ${PTHREAD_LIBS}
MAN6= enigma.6