aboutsummaryrefslogtreecommitdiff
path: root/games/epiar/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-06-25 18:32:58 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-06-25 18:32:58 +0000
commitcba2cdbee26ab34a403e7ddbf417fdb6ebfdd7d2 (patch)
tree9f1c8389e70e686212615fe9e7c50a1318842628 /games/epiar/Makefile
parent189ab8aa6920f27c05303525c1f6c1a6fb113c1e (diff)
downloadports-cba2cdbee26ab34a403e7ddbf417fdb6ebfdd7d2.tar.gz
ports-cba2cdbee26ab34a403e7ddbf417fdb6ebfdd7d2.zip
Notes
Diffstat (limited to 'games/epiar/Makefile')
-rw-r--r--games/epiar/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/games/epiar/Makefile b/games/epiar/Makefile
index 89723d644441..3c9f394d6e87 100644
--- a/games/epiar/Makefile
+++ b/games/epiar/Makefile
@@ -3,9 +3,9 @@
PORTNAME= epiar
PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= http://epiar.net/files/epiar/releases/0.5/
+MASTER_SITES= GH
MAINTAINER= nemysis@gmx.ch
COMMENT= Space trading/exploring sim with RPG elements
@@ -21,20 +21,25 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
xml2:${PORTSDIR}/textproc/libxml2 \
physfs:${PORTSDIR}/devel/physfs
+USE_GITHUB= yes
+GH_ACCOUNT= knowknowledge
+GH_PROJECT= Epiar
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 44046e3
+
USES= pkgconfig
-USE_BZIP2= yes
USE_SDL= image mixer sdl
USE_GL= glu
+USE_AUTOTOOLS= aclocal autoheader automake autoconf
+AUTOMAKE_ARGS= --add-missing
+ACLOCAL_ARGS=
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= aclocal
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
PORTDOCS= AUTHORS ChangeLog README
-pre-configure:
- @${REINPLACE_CMD} -e 's|9.22|2.4|' ${WRKSRC}/configure.in
- @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
+OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>