aboutsummaryrefslogtreecommitdiff
path: root/games/etracer/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-09-02 06:05:58 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-09-02 06:05:58 +0000
commit75676e9db829d37ae9bd096db665175401dd414c (patch)
treecd016b195c8f76b0d252248ab06a82c3d4219006 /games/etracer/Makefile
parent583cedac19dbc9e99ff7972212315f854327b2fe (diff)
downloadports-75676e9db829d37ae9bd096db665175401dd414c.tar.gz
ports-75676e9db829d37ae9bd096db665175401dd414c.zip
Notes
Diffstat (limited to 'games/etracer/Makefile')
-rw-r--r--games/etracer/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/games/etracer/Makefile b/games/etracer/Makefile
index 879d1d766a15..2b666445aec8 100644
--- a/games/etracer/Makefile
+++ b/games/etracer/Makefile
@@ -1,28 +1,24 @@
# Created by: Peter Dunning
# $FreeBSD$
-PORTNAME= etracer
-PORTVERSION= 0.6.0
-PORTREVISION= 7
+PORTNAME= etr
+PORTVERSION= 0.7.5
CATEGORIES= games
MASTER_SITES= SF/extremetuxracer/releases/${PORTVERSION}
-DISTNAME= etr-${PORTVERSION}
+PKGNAMESUFFIX= acer
MAINTAINER= tobik@FreeBSD.org
COMMENT= Extreme Tux Racer
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libpng.so:graphics/png \
- libfreetype.so:print/freetype2
+LIB_DEPENDS= libsfml-system.so:devel/sfml
-USES= compiler gmake localbase pkgconfig tar:xz tcl
-USE_SDL= mixer sdl image
+USES= compiler:c++11-lang pkgconfig tar:xz
USE_GL= gl glu
-
GNU_CONFIGURE= yes
-CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
-CXXFLAGS_clang= -Wno-c++11-narrowing
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>