aboutsummaryrefslogtreecommitdiff
path: root/games/evq3
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-01-25 19:15:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-01-25 19:15:18 +0000
commit14ac881764759575af0262836b114bc66a99657e (patch)
treea7e7d123112721b2a5babd136cee15a4432f25e5 /games/evq3
parente935b9c75650d661139f3fc8612780c824d7ce74 (diff)
Notes
Diffstat (limited to 'games/evq3')
-rw-r--r--games/evq3/Makefile4
-rw-r--r--games/evq3/files/patch-code_client_snd_openal.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/games/evq3/Makefile b/games/evq3/Makefile
index bd6e393f81bb..4881cd667fe2 100644
--- a/games/evq3/Makefile
+++ b/games/evq3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= evq3
PORTVERSION= 1.3.20080810
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL:S|$|alepulver/|}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -76,7 +76,7 @@ MAKE_ENV+= USE_CURL_DLOPEN=1
. endif
# OpenAL
. if defined(WITH_OPENAL)
-LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+USE_OPENAL= al
MAKE_ENV+= USE_OPENAL=1
. if defined(WITH_OPENAL_DLOPEN)
MAKE_ENV+= USE_OPENAL_DLOPEN=1
diff --git a/games/evq3/files/patch-code_client_snd_openal.c b/games/evq3/files/patch-code_client_snd_openal.c
new file mode 100644
index 000000000000..60bba3c924d8
--- /dev/null
+++ b/games/evq3/files/patch-code_client_snd_openal.c
@@ -0,0 +1,11 @@
+--- code/client/snd_openal.c.orig 2009-12-26 18:05:56.000000000 +0100
++++ code/client/snd_openal.c 2009-12-26 18:06:06.000000000 +0100
+@@ -1707,7 +1707,7 @@
+ #elif defined(MACOS_X)
+ #define ALDRIVER_DEFAULT "/System/Library/Frameworks/OpenAL.framework/OpenAL"
+ #else
+-#define ALDRIVER_DEFAULT "libopenal.so.0"
++#define ALDRIVER_DEFAULT "libopenal.so"
+ #endif
+
+ /*