aboutsummaryrefslogtreecommitdiff
path: root/games/excido
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2006-04-23 10:14:30 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2006-04-23 10:14:30 +0000
commitc36bc8fc881f6eb4d76f3f8f7844854f3a828226 (patch)
treeaaf30a64e30860d610400f7306d965534b1f9570 /games/excido
parentf17a91a7d963df9d89cec69323edd437ef8eb1ea (diff)
downloadports-c36bc8fc881f6eb4d76f3f8f7844854f3a828226.tar.gz
ports-c36bc8fc881f6eb4d76f3f8f7844854f3a828226.zip
Notes
Diffstat (limited to 'games/excido')
-rw-r--r--games/excido/Makefile3
-rw-r--r--games/excido/files/patch-Makefile2
2 files changed, 3 insertions, 2 deletions
diff --git a/games/excido/Makefile b/games/excido/Makefile
index 6c696cbd4cc0..e53bd15fd92d 100644
--- a/games/excido/Makefile
+++ b/games/excido/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= alepulver@FreeBSD.org
COMMENT= A portable fast-paced 3d shooter
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- physfs-1.0.1:${PORTSDIR}/devel/physfs
+ physfs-1.0.1:${PORTSDIR}/devel/physfs \
+ alut.0:${PORTSDIR}/audio/freealut
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/excido/files/patch-Makefile b/games/excido/files/patch-Makefile
index c109c3ad00b0..114ba0dfd42e 100644
--- a/games/excido/files/patch-Makefile
+++ b/games/excido/files/patch-Makefile
@@ -7,7 +7,7 @@
#CFLAGS=`sdl-config --cflags` -I./physfs#-g -Wall #-O2
OBJS := ${patsubst %.cpp, %.o, ${wildcard src/*.cpp}}
-LIBS = -s -Bstatic `sdl-config --static-libs` -lSDL_image -lSDL_ttf -L. -lphysfs -lopenal -Bdynamic -lGL -lGLU
-+LIBS = -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lSDL_image -lSDL_ttf -lphysfs -lopenal -lGL -lGLU
++LIBS = -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lSDL_image -lSDL_ttf -lphysfs -lopenal -lalut -lGL -lGLU
#LIBS = -s -Bstatic `sdl-config --static-libs` SDL_image/*.o SDL_ttf/*.o -L. physfs/*.o openal/*.o -ljpeg -lpng -ltiff -lfreetype -Bdynamic -lGL -lGLU
-PREFIX=/usr/local
BINDIR=$(PREFIX)/bin/