aboutsummaryrefslogtreecommitdiff
path: root/games/exhaust-doc
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-01 13:27:16 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-01 13:27:16 +0000
commit622e6db24c98e92586cd8bf872f78c64ddb75f8a (patch)
tree98fc43bc331618d9df300eea32a08a8121a83f55 /games/exhaust-doc
parent0efe68c7dca0ed8907cb5536e30805e4d8c3de8b (diff)
downloadports-622e6db24c98e92586cd8bf872f78c64ddb75f8a.tar.gz
ports-622e6db24c98e92586cd8bf872f78c64ddb75f8a.zip
Notes
Diffstat (limited to 'games/exhaust-doc')
-rw-r--r--games/exhaust-doc/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/games/exhaust-doc/Makefile b/games/exhaust-doc/Makefile
index c81e1ffa47ad..65a74ec706e1 100644
--- a/games/exhaust-doc/Makefile
+++ b/games/exhaust-doc/Makefile
@@ -12,25 +12,27 @@ COMMENT= Redcode simulator easy to embed into applications (docs)
NO_BUILD= yes
-NO_STAGE= yes
+USES= shebangfix
+SHEBANG_FILES= ${WRKSRC}/test.pl
+
post-patch:
@${REINPLACE_CMD} -e 's|./\(exhaust\)|\1|g' ${WRKSRC}/test.pl
do-install:
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in README test.pl
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
- ${MKDIR} ${DOCSDIR}/src
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/src
.for f in asm.c asm.h exhaust.c exhaust.h insn.h pspace.c pspace.h
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/src
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/src
.endfor
- ${MKDIR} ${DOCSDIR}/warriors
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/warriors
.for f in pin1a.rc pin1a.red pin1b.rc pin1b.red pin2a.rc pin2a.red \
pin2b.rc pin2b.red ptest1.rc ptest1.red ptest2.rc ptest2.red \
ptest3.rc ptest3.red ptest4.rc ptest4.red ptest5.rc \
ptest5.red ptest6.rc ptest6.red validate.rc validate.red
- ${INSTALL_DATA} ${WRKSRC}/t/${f} ${DOCSDIR}/warriors
+ ${INSTALL_DATA} ${WRKSRC}/t/${f} ${STAGEDIR}${DOCSDIR}/warriors
.endfor
.include <bsd.port.mk>