aboutsummaryrefslogtreecommitdiff
path: root/games/exhaust-ma/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-10 21:03:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-10 21:03:20 +0000
commita1f2bea42032ab227ac0750858b72708498183c0 (patch)
tree445d61fae28b5be330f0445055eefec3a56eb79e /games/exhaust-ma/Makefile
parentab7d6a3dfadf9155bfdd8ee809214166fb507804 (diff)
Notes
Diffstat (limited to 'games/exhaust-ma/Makefile')
-rw-r--r--games/exhaust-ma/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/exhaust-ma/Makefile b/games/exhaust-ma/Makefile
new file mode 100644
index 000000000000..41c7acbe0beb
--- /dev/null
+++ b/games/exhaust-ma/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: games/exhaust-ma
+# Date created: 7 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exhaust-ma
+PORTVERSION= 1.9
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= pav
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Redcode simulator easy to embed into applications
+
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e 's| ||'
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/exhaust ${PREFIX}/bin/${PORTNAME}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>