aboutsummaryrefslogtreecommitdiff
path: root/games/exult
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-09-18 08:47:31 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-09-18 08:47:31 +0000
commit03cf2e0916b5eadaaa5d50ad8034f0f648102053 (patch)
tree2e7efe898622c1415ef112d3cb11991db31f4790 /games/exult
parent0d005beba9e28875a2ea08dc3dd55d446547630a (diff)
downloadports-03cf2e0916b5eadaaa5d50ad8034f0f648102053.tar.gz
ports-03cf2e0916b5eadaaa5d50ad8034f0f648102053.zip
Conditionalize the addition of -Wno-c++11-narrowing to fix clang6 errors
in CFLAGS to affect clang-based archs. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=479998
Diffstat (limited to 'games/exult')
-rw-r--r--games/exult/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/games/exult/Makefile b/games/exult/Makefile
index c8b04d8ab77f..53a3f15eb2a0 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -12,13 +12,13 @@ COMMENT= Ultima VII engine
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libvorbis.so:audio/libvorbis \
- libpng.so:graphics/png
-
BROKEN_armv6= fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
BROKEN_armv7= fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
BROKEN_aarch64= fails to compile: constant expression evaluates to -1 which cannot be narrowed to type char
+LIB_DEPENDS= libvorbis.so:audio/libvorbis \
+ libpng.so:graphics/png
+
USE_GITHUB= yes
GH_TAGNAME= b15afba
@@ -27,6 +27,7 @@ USE_XORG= xext
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa \
--with-icondir=${PREFIX}/share/pixmaps
+CFLAGS+= -Wno-c++11-narrowing
SUB_FILES= pkg-message