aboutsummaryrefslogtreecommitdiff
path: root/games/f1spirit-remake
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-18 00:02:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-18 00:02:03 +0000
commit3cb8ed77a3896308fdf4e8b6a0411d8b49228d65 (patch)
tree5262b692172fae522e7e24f2971ed98934272159 /games/f1spirit-remake
parent552539df30681d50cc9bebaf54a8c72eee3c2b1d (diff)
downloadports-3cb8ed77a3896308fdf4e8b6a0411d8b49228d65.tar.gz
ports-3cb8ed77a3896308fdf4e8b6a0411d8b49228d65.zip
Notes
Diffstat (limited to 'games/f1spirit-remake')
-rw-r--r--games/f1spirit-remake/Makefile50
-rw-r--r--games/f1spirit-remake/distinfo3
-rw-r--r--games/f1spirit-remake/files/patch-sources-CCar.h11
-rw-r--r--games/f1spirit-remake/files/patch-sources-CPlayer.cpp42
-rw-r--r--games/f1spirit-remake/files/patch-sources-F1SpiritGame.cpp12
-rw-r--r--games/f1spirit-remake/files/patch-sources-Makefile16
-rw-r--r--games/f1spirit-remake/files/patch-sources-main.cpp33
-rw-r--r--games/f1spirit-remake/pkg-descr12
-rw-r--r--games/f1spirit-remake/pkg-plist303
9 files changed, 482 insertions, 0 deletions
diff --git a/games/f1spirit-remake/Makefile b/games/f1spirit-remake/Makefile
new file mode 100644
index 000000000000..0a6f5a67e567
--- /dev/null
+++ b/games/f1spirit-remake/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: f1spirit-remake
+# Date created: 15 May 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= f1spirit-remake
+PORTVERSION= 1.0
+CATEGORIES= games
+# Original braingames site is really slow
+MASTER_SITES= http://www.amdmi3.ru/distfiles/ \
+ http://www.braingames.getput.com/f1spirit/downloads/
+DISTNAME= f1spirit-linux
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Remake of classic F1 Spirit racing game
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
+
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_SDL= sdl net image mixer sound
+USE_GL= gl glu
+MAKE_ENV= CXX="${CXX}"
+
+WRKSRC= "${WRKDIR}/F-1 Spirit"
+BUILD_WRKSRC= ${WRKSRC}/sources
+
+PORTDOCS= readme.txt
+
+post-patch:
+ @${FIND} ${BUILD_WRKSRC} -name '*.cpp' -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ -e 's|"demos"|"${DATADIR}/demos"|g; s|designs/|${DATADIR}/&|g; \
+ s|f1spirit2.cfg|${DATADIR}/&|g; s|graphics/|${DATADIR}/&|g; \
+ s|sound/|${DATADIR}/&|g; s|tracks/|${DATADIR}/&|g'
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/f1s ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} 'demos designs f1spirit2.cfg graphics sound tracks' ${DATADIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/f1spirit-remake/distinfo b/games/f1spirit-remake/distinfo
new file mode 100644
index 000000000000..7c6d0e9f476f
--- /dev/null
+++ b/games/f1spirit-remake/distinfo
@@ -0,0 +1,3 @@
+MD5 (f1spirit-linux.zip) = a39b136d88b94cc829a3828947404c7e
+SHA256 (f1spirit-linux.zip) = 5dda67f6e23c5d15f07658c1f376596a27e6d662892e24d3522ae8236ae28318
+SIZE (f1spirit-linux.zip) = 18111204
diff --git a/games/f1spirit-remake/files/patch-sources-CCar.h b/games/f1spirit-remake/files/patch-sources-CCar.h
new file mode 100644
index 000000000000..735215afac1b
--- /dev/null
+++ b/games/f1spirit-remake/files/patch-sources-CCar.h
@@ -0,0 +1,11 @@
+--- sources/CCar.h.orig 2006-02-11 13:48:14.000000000 +0300
++++ sources/CCar.h 2008-05-15 00:17:13.000000000 +0400
+@@ -119,6 +119,8 @@
+
+ };
+
++class F1SpiritGame;
++class CTrack;
+
+ class CCar {
+ friend class EnemyCCar;
diff --git a/games/f1spirit-remake/files/patch-sources-CPlayer.cpp b/games/f1spirit-remake/files/patch-sources-CPlayer.cpp
new file mode 100644
index 000000000000..c00e451aa130
--- /dev/null
+++ b/games/f1spirit-remake/files/patch-sources-CPlayer.cpp
@@ -0,0 +1,42 @@
+--- sources/CPlayer.cpp.orig 2008-05-17 02:59:23.000000000 +0400
++++ sources/CPlayer.cpp 2008-05-17 03:01:31.000000000 +0400
+@@ -204,7 +204,8 @@
+ struct tm *today;
+
+ gettimeofday(&ttime, NULL);
+- today=localtime(&(ttime.tv_sec));
++ time_t tmp = (time_t)ttime.tv_sec;
++ today=localtime(&tmp);
+
+ position_date[i].year=today->tm_year;
+ position_date[i].month=today->tm_mon;
+@@ -231,7 +232,8 @@
+ struct tm *today;
+
+ gettimeofday(&ttime, NULL);
+- today=localtime(&(ttime.tv_sec));
++ time_t tmp = (time_t)ttime.tv_sec;
++ today=localtime(&tmp);
+
+ time_date[i].year=today->tm_year;
+ time_date[i].month=today->tm_mon;
+@@ -258,7 +260,8 @@
+ struct tm *today;
+
+ gettimeofday(&ttime, NULL);
+- today=localtime(&(ttime.tv_sec));
++ time_t tmp = (time_t)ttime.tv_sec;
++ today=localtime(&tmp);
+
+ lap_date[i].year=today->tm_year;
+ lap_date[i].month=today->tm_mon;
+@@ -285,7 +288,8 @@
+ struct tm *today;
+
+ gettimeofday(&ttime, NULL);
+- today=localtime(&(ttime.tv_sec));
++ time_t tmp = (time_t)ttime.tv_sec;
++ today=localtime(&tmp);
+
+ position_date[i].year=today->tm_year;
+ position_date[i].month=today->tm_mon;
diff --git a/games/f1spirit-remake/files/patch-sources-F1SpiritGame.cpp b/games/f1spirit-remake/files/patch-sources-F1SpiritGame.cpp
new file mode 100644
index 000000000000..d657228b4cd1
--- /dev/null
+++ b/games/f1spirit-remake/files/patch-sources-F1SpiritGame.cpp
@@ -0,0 +1,12 @@
+--- sources/F1SpiritGame.cpp.orig 2006-02-18 13:33:34.000000000 +0300
++++ sources/F1SpiritGame.cpp 2008-05-17 04:03:21.000000000 +0400
+@@ -1615,7 +1615,8 @@
+ struct tm *today;
+
+ gettimeofday(&ttime, NULL);
+- today=localtime(&(ttime.tv_sec));
++ time_t tmp = ttime.tv_sec;
++ today=localtime(&tmp);
+
+ fputc(today->tm_year,replay_fp);
+ fputc(today->tm_mon,replay_fp);
diff --git a/games/f1spirit-remake/files/patch-sources-Makefile b/games/f1spirit-remake/files/patch-sources-Makefile
new file mode 100644
index 000000000000..642ae6803694
--- /dev/null
+++ b/games/f1spirit-remake/files/patch-sources-Makefile
@@ -0,0 +1,16 @@
+--- sources/Makefile.orig 2005-11-03 09:49:06.000000000 +0300
++++ sources/Makefile 2008-05-15 00:16:20.000000000 +0400
+@@ -19,11 +19,11 @@
+ all: f1s
+
+ %.o: %.cpp
+- c++ -c -g3 -O3 $< -o $@ `sdl-config --cflags` -I/usr/local/include/SDL
++ ${CXX} ${CXXFLAGS} -c $< -o $@ `${SDL_CONFIG} --cflags`
+
+ # dynamically linked binary:
+ f1s: $(OBJS)
+- c++ $^ -o $@ `sdl-config --libs` `curl-config --libs` -lSDL_net -lSDL_image -lSDL_mixer -lSDL_sound -lSDL_sound -lGL -lGLU -I/usr/local/include/SDL
++ ${CXX} $^ -o $@ `${SDL_CONFIG} --libs` `curl-config --libs` -lSDL_net -lSDL_image -lSDL_mixer -lSDL_sound -lGL -lGLU
+
+ clean:
+ rm -f f1s
diff --git a/games/f1spirit-remake/files/patch-sources-main.cpp b/games/f1spirit-remake/files/patch-sources-main.cpp
new file mode 100644
index 000000000000..e198bd6ad88b
--- /dev/null
+++ b/games/f1spirit-remake/files/patch-sources-main.cpp
@@ -0,0 +1,33 @@
+--- sources/main.cpp.orig 2006-02-18 00:31:24.000000000 +0300
++++ sources/main.cpp 2008-05-15 00:44:41.000000000 +0400
+@@ -2,6 +2,10 @@
+ #include <windows.h>
+ #endif
+
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <unistd.h>
++#include <err.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include "math.h"
+@@ -235,6 +239,19 @@
+ int main(int argc, char** argv)
+ {
+ #endif
++ if (chdir(getenv("HOME")) != 0)
++ err(1, "Cannot chdir to $HOME");
++
++ struct stat sb;
++ if (stat(".f1spirit-remake", &sb) != 0 &&
++ (mkdir(".f1spirit-remake", 0755) != 0 ||
++ mkdir(".f1spirit-remake/highscores", 0755) != 0 ||
++ mkdir(".f1spirit-remake/players", 0755) != 0 ||
++ mkdir(".f1spirit-remake/replays", 0755) != 0))
++ err(1, "Cannot make directory");
++
++ if (chdir(".f1spirit-remake") != 0)
++ err(1, "Cannot chdir to $HOME/.f1spirit-remake");
+
+ SDL_Surface *screen_sfc;
+ F1SpiritApp *game;
diff --git a/games/f1spirit-remake/pkg-descr b/games/f1spirit-remake/pkg-descr
new file mode 100644
index 000000000000..b33c9c805da3
--- /dev/null
+++ b/games/f1spirit-remake/pkg-descr
@@ -0,0 +1,12 @@
+The F-1 Spirit remake is mostly identical to the original Konami
+classic F-1 Spirit game in that you first have to clear tracks in
+a top-down view with stock cars, rally cars and so on by accumulating
+points given for finishing in the first places until you actually
+get to play the Formula 1 tracks.
+
+Otherwise there are quite some enhancements, namely improved graphics,
+improved music, more realistic physics, real shape shown in the
+maps, camera rotation and zoom, split screen for up to four players,
+(online) highscore tables and replay saving.
+
+WWW: http://www.braingames.getput.com/f1spirit/default.asp
diff --git a/games/f1spirit-remake/pkg-plist b/games/f1spirit-remake/pkg-plist
new file mode 100644
index 000000000000..f8f7d9a623c0
--- /dev/null
+++ b/games/f1spirit-remake/pkg-plist
@@ -0,0 +1,303 @@
+bin/f1s
+%%DATADIR%%/demos/demo1.rpl
+%%DATADIR%%/demos/demo2.rpl
+%%DATADIR%%/demos/demo3.rpl
+%%DATADIR%%/demos/demo4.rpl
+%%DATADIR%%/demos/demo5.rpl
+%%DATADIR%%/demos/demo6.rpl
+%%DATADIR%%/designs/f1/popolon.car
+%%DATADIR%%/designs/f1/popolon2.car
+%%DATADIR%%/designs/rally/fastest.car
+%%DATADIR%%/designs/stock/fastest.car
+%%DATADIR%%/f1spirit2.cfg
+%%DATADIR%%/graphics/brake-1.png
+%%DATADIR%%/graphics/brake-2.png
+%%DATADIR%%/graphics/brake-3.png
+%%DATADIR%%/graphics/car-endurance-1-side.png
+%%DATADIR%%/graphics/car-endurance-1-top.png
+%%DATADIR%%/graphics/car-endurance-2-side.png
+%%DATADIR%%/graphics/car-endurance-2-top.png
+%%DATADIR%%/graphics/car-endurance-3-side.png
+%%DATADIR%%/graphics/car-endurance-3-top.png
+%%DATADIR%%/graphics/car-f1-1-side.png
+%%DATADIR%%/graphics/car-f1-1-top.png
+%%DATADIR%%/graphics/car-f1-2-side.png
+%%DATADIR%%/graphics/car-f1-2-top.png
+%%DATADIR%%/graphics/car-f1-3-side.png
+%%DATADIR%%/graphics/car-f1-3-top.png
+%%DATADIR%%/graphics/car-f3-1-side.png
+%%DATADIR%%/graphics/car-f3-1-top.png
+%%DATADIR%%/graphics/car-f3-2-side.png
+%%DATADIR%%/graphics/car-f3-2-top.png
+%%DATADIR%%/graphics/car-f3-3-side.png
+%%DATADIR%%/graphics/car-f3-3-top.png
+%%DATADIR%%/graphics/car-f3000-1-side.png
+%%DATADIR%%/graphics/car-f3000-1-top.png
+%%DATADIR%%/graphics/car-f3000-2-side.png
+%%DATADIR%%/graphics/car-f3000-2-top.png
+%%DATADIR%%/graphics/car-f3000-3-side.png
+%%DATADIR%%/graphics/car-f3000-3-top.png
+%%DATADIR%%/graphics/car-rally-1-side.png
+%%DATADIR%%/graphics/car-rally-1-top.png
+%%DATADIR%%/graphics/car-rally-2-side.png
+%%DATADIR%%/graphics/car-rally-2-top.png
+%%DATADIR%%/graphics/car-rally-3-side.png
+%%DATADIR%%/graphics/car-rally-3-top.png
+%%DATADIR%%/graphics/car-stock-1-side.png
+%%DATADIR%%/graphics/car-stock-1-top.png
+%%DATADIR%%/graphics/car-stock-2-side.png
+%%DATADIR%%/graphics/car-stock-2-top.png
+%%DATADIR%%/graphics/car-stock-3-side.png
+%%DATADIR%%/graphics/car-stock-3-top.png
+%%DATADIR%%/graphics/cars-endurance.png
+%%DATADIR%%/graphics/cars-f1.png
+%%DATADIR%%/graphics/cars-f3.png
+%%DATADIR%%/graphics/cars-f3000.png
+%%DATADIR%%/graphics/cars-rally.png
+%%DATADIR%%/graphics/cars-stock.png
+%%DATADIR%%/graphics/cloud1.png
+%%DATADIR%%/graphics/cloud1w.png
+%%DATADIR%%/graphics/cloud2.png
+%%DATADIR%%/graphics/cloud2w.png
+%%DATADIR%%/graphics/cloud3.png
+%%DATADIR%%/graphics/cloud3w.png
+%%DATADIR%%/graphics/damage.png
+%%DATADIR%%/graphics/disclaimer.jpg
+%%DATADIR%%/graphics/end.png
+%%DATADIR%%/graphics/endurance/Thumbs.db
+%%DATADIR%%/graphics/endurance/extras.png
+%%DATADIR%%/graphics/endurance/lroad-chicane.png
+%%DATADIR%%/graphics/endurance/rroad-chicane.png
+%%DATADIR%%/graphics/engine-1.png
+%%DATADIR%%/graphics/engine-2.png
+%%DATADIR%%/graphics/engine-3.png
+%%DATADIR%%/graphics/engine-4.png
+%%DATADIR%%/graphics/engine-5.png
+%%DATADIR%%/graphics/engine-6.png
+%%DATADIR%%/graphics/extras.png
+%%DATADIR%%/graphics/f1-brazil/Thumbs.db
+%%DATADIR%%/graphics/f1-brazil/grass.png
+%%DATADIR%%/graphics/f1-france/Thumbs.db
+%%DATADIR%%/graphics/f1-france/isle.png
+%%DATADIR%%/graphics/f1-france/lroad-chicane.png
+%%DATADIR%%/graphics/f1-france/road3.png
+%%DATADIR%%/graphics/f1-france/rroad-chicane.png
+%%DATADIR%%/graphics/f1-portugal/Thumbs.db
+%%DATADIR%%/graphics/f1-portugal/extras.png
+%%DATADIR%%/graphics/f1-sanmarino/Thumbs.db
+%%DATADIR%%/graphics/f1-sanmarino/grass.png
+%%DATADIR%%/graphics/f1-westgermany/Thumbs.db
+%%DATADIR%%/graphics/f1-westgermany/isle.png
+%%DATADIR%%/graphics/f1-westgermany/lroad-chicane.png
+%%DATADIR%%/graphics/f1-westgermany/rroad-chicane.png
+%%DATADIR%%/graphics/f3/Thumbs.db
+%%DATADIR%%/graphics/f3/extras.png
+%%DATADIR%%/graphics/f3/isle.png
+%%DATADIR%%/graphics/f3/lfences.png
+%%DATADIR%%/graphics/f3/rfences.png
+%%DATADIR%%/graphics/flag0.png
+%%DATADIR%%/graphics/flag1.png
+%%DATADIR%%/graphics/font-unicode-alpha.png
+%%DATADIR%%/graphics/gamestart1.png
+%%DATADIR%%/graphics/gamestart2.png
+%%DATADIR%%/graphics/gear-1.png
+%%DATADIR%%/graphics/gear-2.png
+%%DATADIR%%/graphics/gear-3.png
+%%DATADIR%%/graphics/hud/Thumbs.db
+%%DATADIR%%/graphics/hud/fuel.png
+%%DATADIR%%/graphics/hud/hud_damage.png
+%%DATADIR%%/graphics/hud/hud_fixed_1.png
+%%DATADIR%%/graphics/hud/hud_fixed_2.png
+%%DATADIR%%/graphics/hud/hud_fixed_3.png
+%%DATADIR%%/graphics/hud/hud_fixed_3_sidefuel.png
+%%DATADIR%%/graphics/hud/hud_fixed_4.png
+%%DATADIR%%/graphics/hud/hud_gears.png
+%%DATADIR%%/graphics/hud/hud_rpm_1.png
+%%DATADIR%%/graphics/hud/hud_rpm_10.png
+%%DATADIR%%/graphics/hud/hud_rpm_11.png
+%%DATADIR%%/graphics/hud/hud_rpm_2.png
+%%DATADIR%%/graphics/hud/hud_rpm_3.png
+%%DATADIR%%/graphics/hud/hud_rpm_4.png
+%%DATADIR%%/graphics/hud/hud_rpm_5.png
+%%DATADIR%%/graphics/hud/hud_rpm_6.png
+%%DATADIR%%/graphics/hud/hud_rpm_7.png
+%%DATADIR%%/graphics/hud/hud_rpm_8.png
+%%DATADIR%%/graphics/hud/hud_rpm_9.png
+%%DATADIR%%/graphics/hud/hud_speed_font.png
+%%DATADIR%%/graphics/hud/hud_time_font.png
+%%DATADIR%%/graphics/hud/minihud_fuel.png
+%%DATADIR%%/graphics/konami1.jpg
+%%DATADIR%%/graphics/konami2.png
+%%DATADIR%%/graphics/laps.png
+%%DATADIR%%/graphics/locked.png
+%%DATADIR%%/graphics/menu_background.jpg
+%%DATADIR%%/graphics/minimap-car.png
+%%DATADIR%%/graphics/minimap-enemycar.png
+%%DATADIR%%/graphics/rally/Thumbs.db
+%%DATADIR%%/graphics/rally/crowd.png
+%%DATADIR%%/graphics/rally/extras.png
+%%DATADIR%%/graphics/rally/lroad-chicane.png
+%%DATADIR%%/graphics/rally/road1.png
+%%DATADIR%%/graphics/rally/road3.png
+%%DATADIR%%/graphics/rally/rock.png
+%%DATADIR%%/graphics/rally/rroad-chicane.png
+%%DATADIR%%/graphics/rally/tiles.png
+%%DATADIR%%/graphics/rally/walls.png
+%%DATADIR%%/graphics/rpm.png
+%%DATADIR%%/graphics/scoreboard.png
+%%DATADIR%%/graphics/semaphore.png
+%%DATADIR%%/graphics/signs.png
+%%DATADIR%%/graphics/smallfont-unicode-alpha.png
+%%DATADIR%%/graphics/splash640x480.jpg
+%%DATADIR%%/graphics/stock/Thumbs.db
+%%DATADIR%%/graphics/stock/arrows.png
+%%DATADIR%%/graphics/stock/crowd.png
+%%DATADIR%%/graphics/stock/fences.png
+%%DATADIR%%/graphics/stock/lroad-chicane.png
+%%DATADIR%%/graphics/stock/lroad.png
+%%DATADIR%%/graphics/stock/pit.png
+%%DATADIR%%/graphics/stock/road-lines.png
+%%DATADIR%%/graphics/stock/road1.png
+%%DATADIR%%/graphics/stock/road2.png
+%%DATADIR%%/graphics/stock/road3.png
+%%DATADIR%%/graphics/stock/rroad-chicane.png
+%%DATADIR%%/graphics/stock/rroad.png
+%%DATADIR%%/graphics/stock/tiles.png
+%%DATADIR%%/graphics/suspension-1.png
+%%DATADIR%%/graphics/suspension-2.png
+%%DATADIR%%/graphics/suspension-3.png
+%%DATADIR%%/graphics/title1-a-alpha.png
+%%DATADIR%%/graphics/title1-b-alpha.png
+%%DATADIR%%/graphics/title1-c-alpha.png
+%%DATADIR%%/graphics/title1-d-alpha.png
+%%DATADIR%%/graphics/title2-alpha.png
+%%DATADIR%%/graphics/track-previews/Thumbs.db
+%%DATADIR%%/graphics/track-previews/endurance.png
+%%DATADIR%%/graphics/track-previews/f1-1.png
+%%DATADIR%%/graphics/track-previews/f1-10.png
+%%DATADIR%%/graphics/track-previews/f1-11.png
+%%DATADIR%%/graphics/track-previews/f1-12.png
+%%DATADIR%%/graphics/track-previews/f1-13.png
+%%DATADIR%%/graphics/track-previews/f1-14.png
+%%DATADIR%%/graphics/track-previews/f1-15.png
+%%DATADIR%%/graphics/track-previews/f1-16.png
+%%DATADIR%%/graphics/track-previews/f1-2.png
+%%DATADIR%%/graphics/track-previews/f1-3.png
+%%DATADIR%%/graphics/track-previews/f1-4.png
+%%DATADIR%%/graphics/track-previews/f1-5.png
+%%DATADIR%%/graphics/track-previews/f1-6.png
+%%DATADIR%%/graphics/track-previews/f1-7.png
+%%DATADIR%%/graphics/track-previews/f1-8.png
+%%DATADIR%%/graphics/track-previews/f1-9.png
+%%DATADIR%%/graphics/track-previews/f3.png
+%%DATADIR%%/graphics/track-previews/f3000.png
+%%DATADIR%%/graphics/track-previews/micro.png
+%%DATADIR%%/graphics/track-previews/oval.png
+%%DATADIR%%/graphics/track-previews/rally.png
+%%DATADIR%%/graphics/track-previews/stock.png
+%%DATADIR%%/sound/endurance/WS_FTP.LOG
+%%DATADIR%%/sound/endurance/car_brake.ogg
+%%DATADIR%%/sound/endurance/car_pass.ogg
+%%DATADIR%%/sound/endurance/car_running.ogg
+%%DATADIR%%/sound/endurance/music.ogg
+%%DATADIR%%/sound/endurance/tire_squeal.ogg
+%%DATADIR%%/sound/f1/WS_FTP.LOG
+%%DATADIR%%/sound/f1/car_brake.ogg
+%%DATADIR%%/sound/f1/car_pass.ogg
+%%DATADIR%%/sound/f1/car_running.ogg
+%%DATADIR%%/sound/f1/music.ogg
+%%DATADIR%%/sound/f1/tire_squeal.ogg
+%%DATADIR%%/sound/f3/WS_FTP.LOG
+%%DATADIR%%/sound/f3/car_brake.ogg
+%%DATADIR%%/sound/f3/car_pass.ogg
+%%DATADIR%%/sound/f3/car_running.ogg
+%%DATADIR%%/sound/f3/tire_squeal.ogg
+%%DATADIR%%/sound/f3000/WS_FTP.LOG
+%%DATADIR%%/sound/f3000/car_brake.ogg
+%%DATADIR%%/sound/f3000/car_pass.ogg
+%%DATADIR%%/sound/f3000/car_running.ogg
+%%DATADIR%%/sound/f3000/music.ogg
+%%DATADIR%%/sound/f3000/tire_squeal.ogg
+%%DATADIR%%/sound/game_ending.ogg
+%%DATADIR%%/sound/game_menu.ogg
+%%DATADIR%%/sound/game_next.ogg
+%%DATADIR%%/sound/game_start.ogg
+%%DATADIR%%/sound/game_title.ogg
+%%DATADIR%%/sound/menu_cursor.ogg
+%%DATADIR%%/sound/menu_select.ogg
+%%DATADIR%%/sound/pause.ogg
+%%DATADIR%%/sound/rally/WS_FTP.LOG
+%%DATADIR%%/sound/rally/car_hit1.ogg
+%%DATADIR%%/sound/rally/car_pass.ogg
+%%DATADIR%%/sound/rally/car_running.ogg
+%%DATADIR%%/sound/rally/music.ogg
+%%DATADIR%%/sound/stock/WS_FTP.LOG
+%%DATADIR%%/sound/stock/car_brake.ogg
+%%DATADIR%%/sound/stock/car_finish.ogg
+%%DATADIR%%/sound/stock/car_fuel.ogg
+%%DATADIR%%/sound/stock/car_hit1.ogg
+%%DATADIR%%/sound/stock/car_hit2.ogg
+%%DATADIR%%/sound/stock/car_hit3.ogg
+%%DATADIR%%/sound/stock/car_hit4.ogg
+%%DATADIR%%/sound/stock/car_pass.ogg
+%%DATADIR%%/sound/stock/car_running.ogg
+%%DATADIR%%/sound/stock/curbs.ogg
+%%DATADIR%%/sound/stock/music.ogg
+%%DATADIR%%/sound/stock/semaphore_high.ogg
+%%DATADIR%%/sound/stock/semaphore_low.ogg
+%%DATADIR%%/sound/stock/tire_squeal.ogg
+%%DATADIR%%/sound/stock/water_splash.ogg
+%%DATADIR%%/sound/wrong.ogg
+%%DATADIR%%/tracks/endurance.f1t
+%%DATADIR%%/tracks/extras/micro.f1t
+%%DATADIR%%/tracks/extras/oval.f1t
+%%DATADIR%%/tracks/f1-australia.f1t
+%%DATADIR%%/tracks/f1-austria.f1t
+%%DATADIR%%/tracks/f1-belgium.f1t
+%%DATADIR%%/tracks/f1-brazil.f1t
+%%DATADIR%%/tracks/f1-france.f1t
+%%DATADIR%%/tracks/f1-greatbritain.f1t
+%%DATADIR%%/tracks/f1-hungary.f1t
+%%DATADIR%%/tracks/f1-italy.f1t
+%%DATADIR%%/tracks/f1-japan.f1t
+%%DATADIR%%/tracks/f1-mexico.f1t
+%%DATADIR%%/tracks/f1-monaco.f1t
+%%DATADIR%%/tracks/f1-portugal.f1t
+%%DATADIR%%/tracks/f1-sanmarino.f1t
+%%DATADIR%%/tracks/f1-spain.f1t
+%%DATADIR%%/tracks/f1-usa.f1t
+%%DATADIR%%/tracks/f1-westgermany.f1t
+%%DATADIR%%/tracks/f3.f1t
+%%DATADIR%%/tracks/f3000.f1t
+%%DATADIR%%/tracks/rally.f1t
+%%DATADIR%%/tracks/stock.f1t
+@dirrm %%DATADIR%%/tracks/extras
+@dirrm %%DATADIR%%/tracks
+@dirrm %%DATADIR%%/sound/stock
+@dirrm %%DATADIR%%/sound/rally
+@dirrm %%DATADIR%%/sound/f3000
+@dirrm %%DATADIR%%/sound/f3
+@dirrm %%DATADIR%%/sound/f1
+@dirrm %%DATADIR%%/sound/endurance
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/graphics/track-previews
+@dirrm %%DATADIR%%/graphics/stock
+@dirrm %%DATADIR%%/graphics/rally
+@dirrm %%DATADIR%%/graphics/hud
+@dirrm %%DATADIR%%/graphics/f3
+@dirrm %%DATADIR%%/graphics/f1-westgermany
+@dirrm %%DATADIR%%/graphics/f1-sanmarino
+@dirrm %%DATADIR%%/graphics/f1-portugal
+@dirrm %%DATADIR%%/graphics/f1-france
+@dirrm %%DATADIR%%/graphics/f1-brazil
+@dirrm %%DATADIR%%/graphics/endurance
+@dirrm %%DATADIR%%/graphics
+@dirrm %%DATADIR%%/designs/stock
+@dirrm %%DATADIR%%/designs/rally
+@dirrm %%DATADIR%%/designs/f3000
+@dirrm %%DATADIR%%/designs/f3
+@dirrm %%DATADIR%%/designs/f1
+@dirrm %%DATADIR%%/designs/endurance
+@dirrm %%DATADIR%%/designs
+@dirrm %%DATADIR%%/demos
+@dirrm %%DATADIR%%