aboutsummaryrefslogtreecommitdiff
path: root/games/fairymax
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2011-05-04 20:18:47 +0000
committerJohan van Selst <johans@FreeBSD.org>2011-05-04 20:18:47 +0000
commit03d99884cd4fe85587e902f447f18dbaf341d7ac (patch)
tree004ae7477ea1fa8a6f1053cbb4186efcfe016fd3 /games/fairymax
parent35f9fa4f8edf5d0c9da01a5931d7eef616949043 (diff)
downloadports-03d99884cd4fe85587e902f447f18dbaf341d7ac.tar.gz
ports-03d99884cd4fe85587e902f447f18dbaf341d7ac.zip
Notes
Diffstat (limited to 'games/fairymax')
-rw-r--r--games/fairymax/Makefile53
-rw-r--r--games/fairymax/distinfo2
-rw-r--r--games/fairymax/files/patch-Makefile31
-rw-r--r--games/fairymax/files/patch-fairymax.pod23
-rw-r--r--games/fairymax/pkg-descr10
5 files changed, 119 insertions, 0 deletions
diff --git a/games/fairymax/Makefile b/games/fairymax/Makefile
new file mode 100644
index 000000000000..6df03ee3cf9e
--- /dev/null
+++ b/games/fairymax/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: fairy-max
+# Date created: 22 April 2011
+# Whom: Kalten <kalten@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fairymax
+PORTVERSION= 4.8Q
+CATEGORIES= games
+MASTER_SITES= http://freeheimdall.homeunix.org/files/
+DISTNAME= ${PORTNAME}-c7a129e
+# http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=fairymax.git;a=snapshot;h=c7a129ead81286990efb8409f238c48c7109c83b;sf=tgz
+
+MAINTAINER= kalten@gmx.at
+COMMENT= Chess engine (e.g. xboard) for shatranj, courier chess, ...
+
+DIST_SUBDIR= ${PORTNAME}
+
+PLIST_FILES= bin/fairymax \
+ bin/shamax \
+ bin/maxqi \
+ ${DATADIR_REL}/fmax.ini \
+ ${DATADIR_REL}/qmax.ini
+PLIST_DIRS= ${DATADIR_REL}
+
+MAN6= fairymax.6
+MLINKS= fairymax.6 shamax.6 \
+ fairymax.6 maxqi.6
+
+USE_GMAKE= yes
+USE_PERL5_BUILD=yes
+MAKE_ARGS+= INI_FILE_fmax=${DATADIR}/fmax.ini \
+ INI_FILE_qmax=${DATADIR}/qmax.ini
+
+post-patch:
+ @${CP} ${WRKSRC}/fairymax.pod ${WRKSRC}/fairymax.pod.ori
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g;s|%%DATADIR%%|${DATADIR}|g' \
+ ${WRKSRC}/fairymax.pod.ori > ${WRKSRC}/fairymax.pod
+
+post-build:
+ @${CP} ${WRKSRC}/fmax.man ${WRKSRC}/fairymax.6
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fairymax ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/shamax ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/maxqi ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/fmax.ini ${DATADIR}/fmax.ini
+ ${INSTALL_DATA} ${WRKSRC}/data/qmax.ini ${DATADIR}/qmax.ini
+ ${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MANPREFIX}/man/man6
+
+.include <bsd.port.mk>
diff --git a/games/fairymax/distinfo b/games/fairymax/distinfo
new file mode 100644
index 000000000000..ef3c0b366989
--- /dev/null
+++ b/games/fairymax/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fairymax/fairymax-c7a129e.tar.gz) = ec8e75c92e345e0f0db56095ac576156f54fb9320af05e86f8e589a8300c5a9a
+SIZE (fairymax/fairymax-c7a129e.tar.gz) = 34229
diff --git a/games/fairymax/files/patch-Makefile b/games/fairymax/files/patch-Makefile
new file mode 100644
index 000000000000..0907c0f00a4d
--- /dev/null
+++ b/games/fairymax/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- Makefile.orig 2010-12-08 10:03:32.000000000 +0100
++++ Makefile 2011-04-23 17:09:50.000000000 +0200
+@@ -1,21 +1,22 @@
+ srcdir = .
+
+-CC=gcc
+-CFLAGS += -O2
+-
++CC?=gcc
++CFLAGS +=
++INI_FILE_fmax?="/usr/share/games/fairymax/fmax.ini"
++INI_FILE_qmax?="/usr/share/games/fairymax/qmax.ini"
+
+ ALL= fairymax shamax maxqi fairymax.6.gz
+
+ all: ${ALL}
+
+ fairymax: fairymax.c
+- $(CC) $(CFLAGS) -DINI_FILE=\"/usr/share/games/fairymax/fmax.ini\" fairymax.c -o fairymax
++ $(CC) $(CFLAGS) -DINI_FILE=\"${INI_FILE_fmax}\" fairymax.c -o fairymax
+
+ shamax: fairymax.c
+- $(CC) $(CFLAGS) -DINI_FILE=\"/usr/share/games/fairymax/fmax.ini\" -DSHATRANJ fairymax.c -o shamax
++ $(CC) $(CFLAGS) -DINI_FILE=\"${INI_FILE_fmax}\" -DSHATRANJ fairymax.c -o shamax
+
+ maxqi: maxqi.c
+- $(CC) $(CFLAGS) -DINI_FILE=\"/usr/share/games/fairymax/qmax.ini\" maxqi.c -o maxqi
++ $(CC) $(CFLAGS) -DINI_FILE=\"${INI_FILE_qmax}\" maxqi.c -o maxqi
+
+ install: ${ALL} ${srcdir}/data/*
+ cp -u ${srcdir}/fairymax $(DESTDIR)/usr/games
diff --git a/games/fairymax/files/patch-fairymax.pod b/games/fairymax/files/patch-fairymax.pod
new file mode 100644
index 000000000000..be818ed18fe9
--- /dev/null
+++ b/games/fairymax/files/patch-fairymax.pod
@@ -0,0 +1,23 @@
+--- fairymax.pod.orig 2010-12-08 10:03:32.000000000 +0100
++++ fairymax.pod 2011-04-23 01:11:01.000000000 +0200
+@@ -117,11 +117,20 @@
+
+ =back
+
++=head1 FILES
++
++%%DATADIR%%/fmax.ini
++
++%%DATADIR%%/qmax.ini
+
+ =head1 SEE ALSO
+
+ xboard(6)
+
++http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=fairymax.git
++
++http://home.hccnet.nl/h.g.muller/fairy.html
++
+ http://www.chessvariants.org/index/msdisplay.php?itemid=MSfairy-max
+
+ http://home.hccnet.nl/h.g.muller/max-src2.html
diff --git a/games/fairymax/pkg-descr b/games/fairymax/pkg-descr
new file mode 100644
index 000000000000..e584826fda6e
--- /dev/null
+++ b/games/fairymax/pkg-descr
@@ -0,0 +1,10 @@
+fairy-Max is a version of micro-Max that reads the piece description
+from a file fmax.ini, so that arbitrary fairy pieces can be implemen-
+ted. This version supports up to 15 piece types, and board sizes upto
+12x8 board. A Linux port exists in the format of a debian package.
+
+You can use it e.g. with games/xboard/:
+e.g.: xboard -boardSize Middling -variant courier -fcp fairymax
+
+GIT: http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=fairymax.git
+WWW: http://home.hccnet.nl/h.g.muller/fairy.html