aboutsummaryrefslogtreecommitdiff
path: root/games/fgrun/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-03-08 17:49:26 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-03-08 17:49:26 +0000
commit189357d1356a26c4245318d0817be2a670d32aa1 (patch)
tree801f7fa01817031981fccce3a4cf6514f548e49c /games/fgrun/Makefile
parentb0d96eee671b67fce1c6479a009914cadbf2ae0e (diff)
Notes
Diffstat (limited to 'games/fgrun/Makefile')
-rw-r--r--games/fgrun/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/games/fgrun/Makefile b/games/fgrun/Makefile
index eef15b5cfd77..1f22bf5ea215 100644
--- a/games/fgrun/Makefile
+++ b/games/fgrun/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fgrun
-PORTVERSION= 1.5.0
+PORTVERSION= 1.5.1
CATEGORIES= games
MASTER_SITES= SF
@@ -14,12 +14,11 @@ MAINTAINER= buganini@gmail.com
COMMENT= A graphical frontend to run FlightGear Flight Simulator
BUILD_DEPENDS= fltk-threads>=1.1.9:${PORTSDIR}/x11-toolkits/fltk-threads \
- osg>=2.6.1:${PORTSDIR}/graphics/osg \
- SimGear>=1.9.0:${PORTSDIR}/devel/simgear \
+ SimGear>=1.9.1:${PORTSDIR}/devel/simgear \
plib>=1.8.5:${PORTSDIR}/x11-toolkits/plib
RUN_DEPENDS= fltk-threads>=1.1.9:${PORTSDIR}/x11-toolkits/fltk-threads \
osg>=2.6.1:${PORTSDIR}/graphics/osg \
- SimGear>=1.9.0:${PORTSDIR}/devel/simgear \
+ SimGear>=1.9.1:${PORTSDIR}/devel/simgear \
fgfs:${PORTSDIR}/games/flightgear \
plib>=1.8.5:${PORTSDIR}/x11-toolkits/plib
@@ -35,6 +34,12 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+.if defined(WITH_OSG_DEVEL)
+LIB_DEPENDS+= osg.54:${PORTSDIR}/graphics/osg-devel
+.else
+LIB_DEPENDS+= osg.48:${PORTSDIR}/graphics/osg
+.endif
+
post-patch:
.if defined(WITHOUT_NLS)
@${REINPLACE_CMD} 's|SUBDIRS = src po msvc|SUBDIRS = src|' \