aboutsummaryrefslogtreecommitdiff
path: root/games/fgrun
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2014-05-14 12:14:58 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2014-05-14 12:14:58 +0000
commitba8e7aed1844bfef15dcad3bab9e52f082806325 (patch)
treea6c8c74f88017ac71d90eb0a58f6486ab874979d /games/fgrun
parent7e160d2e1952df144852715749ac62d5f7db4d78 (diff)
downloadports-ba8e7aed1844bfef15dcad3bab9e52f082806325.tar.gz
ports-ba8e7aed1844bfef15dcad3bab9e52f082806325.zip
Notes
Diffstat (limited to 'games/fgrun')
-rw-r--r--games/fgrun/Makefile9
-rw-r--r--games/fgrun/distinfo4
-rw-r--r--games/fgrun/files/patch-CMakeLists.txt (renamed from games/fgrun/files/patch-src-CMakeLists.txt)8
-rw-r--r--games/fgrun/files/patch-src-fgrun_pty.cxx16
-rw-r--r--games/fgrun/files/patch-src-run_posix.cxx15
-rw-r--r--games/fgrun/pkg-plist1
6 files changed, 23 insertions, 30 deletions
diff --git a/games/fgrun/Makefile b/games/fgrun/Makefile
index 2a9cf8e22ad1..2fc66f5f2efb 100644
--- a/games/fgrun/Makefile
+++ b/games/fgrun/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= fgrun
-PORTVERSION= 1.7.0
-PORTREVISION= 1
+PORTVERSION= 3.0.0
CATEGORIES= games
-MASTER_SITES= https://gitorious.org/${GO_ACCOUNT}/${GO_PROJECT}/archive/${GO_TAGNAME}.tar.gz?dummy=
+MASTER_SITES= https://gitorious.org/${GO_ACCOUNT}/${GO_PROJECT}/archive/${GO_TAGNAME}.tar.gz?dummy= \
+ LOCAL/martymac
MAINTAINER= buganini@gmail.com
COMMENT= A graphical frontend to run FlightGear Flight Simulator
@@ -23,13 +23,12 @@ WRKSRC= ${WRKDIR}/${GO_ACCOUNT}-${GO_PROJECT}
CMAKE_ARGS+= -DLIB_DIR=${PREFIX}/lib
-USE_GCC= yes
USES= cmake
USE_GL= gl
GO_ACCOUNT= fg
GO_PROJECT= fgrun
-GO_TAGNAME= 90e936c01e28feac4a9c3e28d5227980fb8f1e1d
+GO_TAGNAME= e13e42811239008fded7685d8f2311bb571f6a58
FETCH_ARGS?= -o ${DISTDIR}/${DISTFILES}
OPTIONS_DEFINE= NLS
diff --git a/games/fgrun/distinfo b/games/fgrun/distinfo
index 7e1e97cb113e..4a9409aad6dc 100644
--- a/games/fgrun/distinfo
+++ b/games/fgrun/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fgrun-1.7.0.tar.gz) = 768d2c5353e6260d1b5625781f66cd46f8fff9f8f1607ba1bd370c778193900c
-SIZE (fgrun-1.7.0.tar.gz) = 187221
+SHA256 (fgrun-3.0.0.tar.gz) = df8299cae9334fb6563be2cf0f78cfe397b569a3d64fbd3a39a26034132ab5d8
+SIZE (fgrun-3.0.0.tar.gz) = 194601
diff --git a/games/fgrun/files/patch-src-CMakeLists.txt b/games/fgrun/files/patch-CMakeLists.txt
index de4d62b7ef69..9b638ab43d9b 100644
--- a/games/fgrun/files/patch-src-CMakeLists.txt
+++ b/games/fgrun/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2013-11-18 06:56:58.000000000 +0800
-+++ CMakeLists.txt 2013-11-18 06:57:32.000000000 +0800
-@@ -138,7 +138,6 @@
+--- CMakeLists.txt.orig 2014-05-12 04:37:55.000000000 +0800
++++ CMakeLists.txt 2014-05-12 04:38:05.000000000 +0800
+@@ -137,7 +137,6 @@
if (ENABLE_NLS AND GETTEXT_FOUND)
@@ -8,7 +8,7 @@
FIND_LIBRARY(INTL_LIBRARY
NAMES intl
HINTS
-@@ -154,7 +153,6 @@
+@@ -153,7 +152,6 @@
if (NOT INTL_LIBRARY)
set( ENABLE_NLS 0 )
endif (NOT INTL_LIBRARY)
diff --git a/games/fgrun/files/patch-src-fgrun_pty.cxx b/games/fgrun/files/patch-src-fgrun_pty.cxx
index fbfdccda0aed..908d383c08f3 100644
--- a/games/fgrun/files/patch-src-fgrun_pty.cxx
+++ b/games/fgrun/files/patch-src-fgrun_pty.cxx
@@ -1,12 +1,14 @@
---- src/fgrun_pty.cxx.orig 2008-10-18 17:32:33.000000000 +0800
-+++ src/fgrun_pty.cxx 2008-10-18 17:33:12.000000000 +0800
-@@ -28,6 +28,9 @@
- # include <pty.h>
+--- src/fgrun_pty.cxx.orig 2014-05-12 04:35:04.000000000 +0800
++++ src/fgrun_pty.cxx 2014-05-12 04:35:29.000000000 +0800
+@@ -40,6 +40,11 @@
+ #include <fcntl.h> // O_RDWR
#endif
+#include <sys/types.h>
++#include <sys/ioctl.h>
++#include <termios.h>
+#include <libutil.h>
+
- #if defined(HAVE_UTMP_H)
- # include <utmp.h>
- #endif
+ #include <stdlib.h> //needed on some linux systems for grantpt()
+ #include <string.h> //strcpy is not necessarily already included
+ /**
diff --git a/games/fgrun/files/patch-src-run_posix.cxx b/games/fgrun/files/patch-src-run_posix.cxx
index db68a8a3a5eb..2059354fc979 100644
--- a/games/fgrun/files/patch-src-run_posix.cxx
+++ b/games/fgrun/files/patch-src-run_posix.cxx
@@ -1,6 +1,6 @@
---- src/run_posix.cxx.orig 2009-01-25 17:01:58.000000000 +0000
-+++ src/run_posix.cxx 2009-03-09 01:08:38.080801315 +0000
-@@ -59,7 +59,7 @@
+--- src/run_posix.cxx.orig 2014-05-12 04:32:03.000000000 +0800
++++ src/run_posix.cxx 2014-05-12 04:32:24.000000000 +0800
+@@ -60,7 +60,7 @@
#if defined(HAVE_TERMIOS_H)
struct termios term;
tcgetattr( STDOUT_FILENO, &term );
@@ -9,12 +9,3 @@
pid = pty_fork( &master, 0, &term, 0 );
#else
-@@ -171,7 +171,7 @@
- #if defined(HAVE_TERMIOS_H)
- struct termios term;
- tcgetattr( STDOUT_FILENO, &term );
-- term.c_oflag &= ~( OLCUC | ONLCR );
-+ term.c_oflag &= ~ONLCR;
-
- tsPid = pty_fork( &master, 0, &term, 0 );
- #else
diff --git a/games/fgrun/pkg-plist b/games/fgrun/pkg-plist
index 697c065a3670..ddb66d0d5b5d 100644
--- a/games/fgrun/pkg-plist
+++ b/games/fgrun/pkg-plist
@@ -3,6 +3,7 @@ bin/fgrun
%%NLS%%share/locale/es/LC_MESSAGES/fgrun.mo
%%NLS%%share/locale/fr/LC_MESSAGES/fgrun.mo
%%NLS%%share/locale/it/LC_MESSAGES/fgrun.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/fgrun.mo
%%NLS%%share/locale/nl/LC_MESSAGES/fgrun.mo
%%NLS%%share/locale/pl/LC_MESSAGES/fgrun.mo
%%NLS%%share/locale/pt/LC_MESSAGES/fgrun.mo