aboutsummaryrefslogtreecommitdiff
path: root/games/flare-game
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-09 23:48:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-09 23:48:14 +0000
commit13e736adc45dccbb36c4c877b0e0cff572fee229 (patch)
treec4f8b4848fd7217645acf055fe583f6bcb0c0d45 /games/flare-game
parent651cf6d56ec185f4544f5146b9762b5c13ccf560 (diff)
- Update flare to 0.19
- Split flare port to engine and game counterparts just as upstream did - Add patch from upstream git to display useful message when enigne in ran without game specified
Notes
Notes: svn path=/head/; revision=336034
Diffstat (limited to 'games/flare-game')
-rw-r--r--games/flare-game/Makefile35
-rw-r--r--games/flare-game/distinfo2
-rw-r--r--games/flare-game/pkg-descr7
-rw-r--r--games/flare-game/pkg-plist6
4 files changed, 50 insertions, 0 deletions
diff --git a/games/flare-game/Makefile b/games/flare-game/Makefile
new file mode 100644
index 000000000000..a705848df311
--- /dev/null
+++ b/games/flare-game/Makefile
@@ -0,0 +1,35 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= flare
+PORTVERSION= 0.19
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}-game/Linux/
+DISTNAME= ${PORTNAME}-game.${PORTVERSION}
+PKGNAMESUFFIX= -game
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Free Libre Action Roleplaying Engine
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= flare:${PORTSDIR}/games/flare-engine
+
+USES= cmake
+CMAKE_BUILD_TYPE= #empty
+INSTALLS_ICONS= yes
+
+CMAKE_ARGS= -DBINDIR="bin" -DDATADIR="share/flare"
+
+PORTDOCS= *
+PORTDATA= *
+
+DATADIR= ${PREFIX}/share/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/games/flare-game/distinfo b/games/flare-game/distinfo
new file mode 100644
index 000000000000..3792bfc657d1
--- /dev/null
+++ b/games/flare-game/distinfo
@@ -0,0 +1,2 @@
+SHA256 (flare-game.0.19.tar.gz) = 1b427bbf2e124cb6df40b9400de1d25aaadb6b0ccf764cf7b8d69f96d3008b34
+SIZE (flare-game.0.19.tar.gz) = 177779024
diff --git a/games/flare-game/pkg-descr b/games/flare-game/pkg-descr
new file mode 100644
index 000000000000..56278b2ddbc1
--- /dev/null
+++ b/games/flare-game/pkg-descr
@@ -0,0 +1,7 @@
+Flare is a a single-player 2D action RPG with fast-paced action and
+a dark fantasy style.
+
+It is built on the FLARE engine (Free/Libre Action Roleplaying
+Engine).
+
+WWW: http://flarerpg.org
diff --git a/games/flare-game/pkg-plist b/games/flare-game/pkg-plist
new file mode 100644
index 000000000000..1785574cf4a3
--- /dev/null
+++ b/games/flare-game/pkg-plist
@@ -0,0 +1,6 @@
+share/applications/flare.desktop
+share/icons/hicolor/scalable/apps/flare.svg
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons