aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-07 20:28:45 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-07 20:28:45 +0000
commitfa9a9cd603c77d0c24a520315fde2f48b06154e5 (patch)
tree4af74f0ba31030f3f8afbd4982ab677f47862e54 /games/flightgear/Makefile
parent6b11bbcf2f60017c69d9be58fc759f6e94702088 (diff)
downloadports-fa9a9cd603c77d0c24a520315fde2f48b06154e5.tar.gz
ports-fa9a9cd603c77d0c24a520315fde2f48b06154e5.zip
Notes
Diffstat (limited to 'games/flightgear/Makefile')
-rw-r--r--games/flightgear/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index cf8e64175fcb..b0a1ca82c36d 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -7,8 +7,7 @@
PORTNAME?= FlightGear
PORTVERSION?= ${FGVERSION}
-PORTREVISION= 1
-PORTREVISION?= 1
+PORTREVISION?= 0
CATEGORIES= games
MASTER_SITES+= ftp://ftp.flightgear.org/pub/fgfs/Source/:fg \
ftp://ftp.de.flightgear.org/pub/fgfs/Source/:fg
@@ -25,11 +24,10 @@ RUN_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${X11BASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
${X11BASE}/share/FlightGear/version:${PORTSDIR}/games/fgfs-base
-FGVERSION= 0.9.9
+FGVERSION= 0.9.10
USE_X_PREFIX= yes
USE_GL= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -41,11 +39,18 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not build on FreeBSD 4.x
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|' \
${WRKSRC}/configure
post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/utils/js_server/js_server ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>