aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear/patches.tools
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-07-03 06:36:37 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-07-03 06:36:37 +0000
commita12cebc97103a513a28193a4f964c8643cfb41ba (patch)
treea8b3c146d1df4f0d4f67987489c0b0212951a612 /games/flightgear/patches.tools
parenta7ae3c606801c645c199de8e7f8aec1328e7fe72 (diff)
downloadports-a12cebc97103a513a28193a4f964c8643cfb41ba.tar.gz
ports-a12cebc97103a513a28193a4f964c8643cfb41ba.zip
Notes
Diffstat (limited to 'games/flightgear/patches.tools')
-rw-r--r--games/flightgear/patches.tools/Makefile.gpc19
-rw-r--r--games/flightgear/patches.tools/disable-tools67
-rw-r--r--games/flightgear/patches.tools/gfc-patch-aa21
3 files changed, 107 insertions, 0 deletions
diff --git a/games/flightgear/patches.tools/Makefile.gpc b/games/flightgear/patches.tools/Makefile.gpc
new file mode 100644
index 000000000000..3d926ffa24e5
--- /dev/null
+++ b/games/flightgear/patches.tools/Makefile.gpc
@@ -0,0 +1,19 @@
+# Unix/Linux makefile for GPC 2.31
+#
+# Riley Rainey (riley.rainey@websimulations.com)
+
+CFLAGS = -O -g
+
+libgpc.a: gpc.o
+ rm -f $@
+ ar cr $@ $<
+ ranlib $@
+
+clean:
+ rm -f libgpc.a *.o core *~
+
+install: libgpc.a
+ -mkdir -p ${PREFIX}/lib
+ -mkdir -p ${PREFIX}/include
+ install -c libgpc.a ${PREFIX}/lib/libgpc.a
+ install -c gpc.h ${PREFIX}/include/gpc.h
diff --git a/games/flightgear/patches.tools/disable-tools b/games/flightgear/patches.tools/disable-tools
new file mode 100644
index 000000000000..935b2206ea36
--- /dev/null
+++ b/games/flightgear/patches.tools/disable-tools
@@ -0,0 +1,67 @@
+--- FlightGear-0.6.1/configure.in.orig Sun Jun 27 13:21:03 1999
++++ FlightGear-0.6.1/configure.in Sun Jun 27 13:21:13 1999
+@@ -244,37 +244,6 @@
+
+ AM_CONDITIONAL(HAVE_XWINDOWS, test "x$ac_cv_lib_X11_XCreateWindow" = "xyes" )
+
+-dnl Check if Generic Polygon Clipping library is installed
+-dnl (from http://www.cs.man.ac.uk/aig/staff/alan/software/)
+-AC_CHECK_HEADERS( gpc.h )
+-if test "x$ac_cv_header_gpc_h" != "xyes"; then
+- echo
+- echo "You need to have the GPC library installed on your system to build"
+- echo "some of the scenery generation tools, otherwise you won't be able."
+- echo "to create scenery."
+- echo
+- echo "Please see README.gpc for more details."
+- echo
+- echo "(pausing 5 seconds)"
+- sleep 5
+- echo
+-fi
+-
+-dnl Check if Geographic Foundation Classes library is installed
+-dnl (from ftp://ftp.flightgear.org/pub/fgfs/Source/)
+-AC_CHECK_HEADERS( gfc/gdbf.h )
+-if test "x$ac_cv_header_gfc_gdbf_h" != "xyes"; then
+- echo
+- echo "You need to have the GFC library installed on your system to build"
+- echo "some of the scenery generation tools, otherwise, they may fail."
+- echo
+- echo "Please see README.gfc for more details."
+- echo
+- echo "(pausing 5 seconds)"
+- sleep 5
+- echo
+-fi
+-
+ dnl Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS( \
+--- FlightGear-0.6.1/Makefile.in.orig Sun Jun 27 19:14:27 1999
++++ FlightGear-0.6.1/Makefile.in Sun Jun 27 19:15:08 1999
+@@ -67,7 +67,7 @@
+ base_LIBS = @base_LIBS@
+ opengl_LIBS = @opengl_LIBS@
+
+-SUBDIRS = Include Lib Simulator Tools Tests
++SUBDIRS = Include Lib Simulator Tests
+
+ EXTRA_DIST = FG-FAQ.v3 README.Unix README.Linux README.MacOS README.Win32 \
+ README.Win32-X README.autoconf README.gfc README.gpc README.plib \
+@@ -88,15 +88,9 @@
+ all: all-recursive all-am
+
+ .SUFFIXES:
+-$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
+- cd $(top_srcdir) && $(AUTOMAKE) --gnu --include-deps Makefile
+-
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
+-
+-$(ACLOCAL_M4): configure.in
+- cd $(srcdir) && $(ACLOCAL)
+
+ config.status: $(srcdir)/configure
+ $(SHELL) ./config.status --recheck
diff --git a/games/flightgear/patches.tools/gfc-patch-aa b/games/flightgear/patches.tools/gfc-patch-aa
new file mode 100644
index 000000000000..08b8d4b85dc8
--- /dev/null
+++ b/games/flightgear/patches.tools/gfc-patch-aa
@@ -0,0 +1,21 @@
+--- gfc-0.8.8.1b/utils/src/gmmap.h.orig Wed Feb 17 14:31:03 1999
++++ gfc-0.8.8.1b/utils/src/gmmap.h Sat Jun 26 21:43:18 1999
+@@ -12,7 +12,18 @@
+
+ #include <unistd.h>
+
++/* the next lines are to define BSD */
++/* see http://www.freebsd.org/handbook/porting.html for why we do this */
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ #ifdef _LINUX_
++#include <sys/mman.h>
++#include <sys/types.h>
++#endif
++
++#ifdef BSD
+ #include <sys/mman.h>
+ #include <sys/types.h>
+ #endif