aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2014-03-28 14:13:02 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2014-03-28 14:13:02 +0000
commitf54588cbe33927c581c7c8302e78ecac3e3f2388 (patch)
treebbe17caddb69cbbfd444484076f09d2ea44b8830 /games/flightgear
parentf1c48aa891a87d13c0cd11fe7bab195dc89acffc (diff)
downloadports-f54588cbe33927c581c7c8302e78ecac3e3f2388.tar.gz
ports-f54588cbe33927c581c7c8302e78ecac3e3f2388.zip
Notes
Diffstat (limited to 'games/flightgear')
-rw-r--r--games/flightgear/Makefile25
-rw-r--r--games/flightgear/distinfo4
-rw-r--r--games/flightgear/files/extra-patch-src-FDM-JSBSim-input_output-string_utilities.h30
-rw-r--r--games/flightgear/files/patch-3rdparty-iaxclient-lib-CMakeLists.txt11
-rw-r--r--games/flightgear/files/patch-3rdparty-iaxclient-lib-iaxclient.h11
-rw-r--r--games/flightgear/files/patch-3rdparty-iaxclient-lib-libiax2-src-iax.c11
-rw-r--r--games/flightgear/pkg-plist5
7 files changed, 86 insertions, 11 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 899e524d8f12..ddc406458fdc 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= flightgear
-PORTVERSION= 2.12.1
-PORTREVISION= 2
+PORTVERSION= 3.0.0
CATEGORIES= games
# see http://www.flightgear.org/templates.js
MASTER_SITES= http://mirrors.ibiblio.org/flightgear/ftp/Source/ \
@@ -21,25 +20,35 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng15.so:${PORTSDIR}/graphics/png \
libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libfltk.so:${PORTSDIR}/x11-toolkits/fltk \
- libosg.so:${PORTSDIR}/graphics/osg
+ libosg.so:${PORTSDIR}/graphics/osg \
+ libdbus-1.so:${PORTSDIR}/devel/dbus
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libSimGearCore.a:${PORTSDIR}/devel/simgear
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libSimGearCore.a:${PORTSDIR}/devel/simgear \
${LOCALBASE}/share/flightgear/version:${PORTSDIR}/games/flightgear-data
-USE_BZIP2= yes
USE_XORG= ice sm x11 xext xft xi xinerama xt xmu
USE_GL= gl glu glut
-USES= cmake openal:al,alut
+USE_SQLITE= 3
+
+USES= tar:bzip2 dos2unix cmake compiler:features openal:al,alut
+DOS2UNIX_REGEX= .*\.(c|h|cxx|cpp|hxx|hpp)
CMAKE_ARGS+= -DJPEG_FACTORY:BOOL=ON \
-DENABLE_JS_SERVER:BOOL=ON \
+ -DUSE_DBUS:BOOL=ON \
+ -DSYSTEM_SQLITE:BOOL=ON \
-DFG_DATA_DIR:PATH=${LOCALBASE}/share/${PORTNAME} \
- -DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man
+ -DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man \
+ -DFGCOM_DATA_PATH:PATH=${DATADIR}
+
+.include <bsd.port.pre.mk>
-.include <bsd.port.options.mk>
+.if ${COMPILER_FEATURES:Mlibc++}
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-FDM-JSBSim-input_output-string_utilities.h
+.endif
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/utils/js_server/js_server ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/flightgear/distinfo b/games/flightgear/distinfo
index bc0358b63161..127fb71b001c 100644
--- a/games/flightgear/distinfo
+++ b/games/flightgear/distinfo
@@ -1,2 +1,2 @@
-SHA256 (flightgear-2.12.1.tar.bz2) = bcc7478825c435bad1c93318c91d6a38d75d802bfbec4a3d2580e09b665240f2
-SIZE (flightgear-2.12.1.tar.bz2) = 3423670
+SHA256 (flightgear-3.0.0.tar.bz2) = e4bf1922825920a404539e6611c36eb5567b85d46a726fd8c6f9b19c138ba6e9
+SIZE (flightgear-3.0.0.tar.bz2) = 5874662
diff --git a/games/flightgear/files/extra-patch-src-FDM-JSBSim-input_output-string_utilities.h b/games/flightgear/files/extra-patch-src-FDM-JSBSim-input_output-string_utilities.h
new file mode 100644
index 000000000000..c6e096b3f437
--- /dev/null
+++ b/games/flightgear/files/extra-patch-src-FDM-JSBSim-input_output-string_utilities.h
@@ -0,0 +1,30 @@
+--- src/FDM/JSBSim/input_output/string_utilities.h.orig 2014-03-12 18:30:00.000000000 +0100
++++ src/FDM/JSBSim/input_output/string_utilities.h 2014-03-12 18:31:18.000000000 +0100
+@@ -73,9 +73,11 @@
+ extern bool is_number(const std::string& str);
+ std::vector <std::string> split(std::string str, char d);
+ /* Comment out to_string functions when they are defined already - C++ 11 defines these */
++/*
+ extern std::string to_string(int);
+ extern std::string to_string(double);
+ extern std::string to_string(float);
++*/
+ extern std::string replace(std::string str, const std::string& old, const std::string& newstr);
+ #else
+ #include <cctype>
+@@ -159,6 +161,7 @@
+ return str_array;
+ }
+ /* Comment out to_string functions when they are defined already - C++ 11 defines these */
++/*
+ string to_string(int i)
+ {
+ char buffer[32];
+@@ -179,6 +182,7 @@
+ if (!(o << x)) cerr << "Bad double to string conversion" << endl;
+ return o.str();
+ }
++*/
+
+ string replace(string str, const string& oldstr, const string& newstr)
+ {
diff --git a/games/flightgear/files/patch-3rdparty-iaxclient-lib-CMakeLists.txt b/games/flightgear/files/patch-3rdparty-iaxclient-lib-CMakeLists.txt
new file mode 100644
index 000000000000..4bd4f929261d
--- /dev/null
+++ b/games/flightgear/files/patch-3rdparty-iaxclient-lib-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- 3rdparty/iaxclient/lib/CMakeLists.txt.orig 2014-03-12 18:13:58.000000000 +0100
++++ 3rdparty/iaxclient/lib/CMakeLists.txt 2014-03-12 18:14:39.000000000 +0100
+@@ -88,7 +88,7 @@
+ libspeex/vq.c
+ )
+
+- include_directories(${PROJECT_SOURCE_DIR}/3rdparty/iaxclient/lib/libspeex/include)
++ include_directories(BEFORE ${PROJECT_SOURCE_DIR}/3rdparty/iaxclient/lib/libspeex/include)
+ endif(ENABLE_SPEXX)
+
+ if (ENABLE_ALSA)
diff --git a/games/flightgear/files/patch-3rdparty-iaxclient-lib-iaxclient.h b/games/flightgear/files/patch-3rdparty-iaxclient-lib-iaxclient.h
new file mode 100644
index 000000000000..189ee3d44479
--- /dev/null
+++ b/games/flightgear/files/patch-3rdparty-iaxclient-lib-iaxclient.h
@@ -0,0 +1,11 @@
+--- 3rdparty/iaxclient/lib/iaxclient.h.orig 2014-03-17 07:06:55.000000000 +0100
++++ 3rdparty/iaxclient/lib/iaxclient.h 2014-03-17 07:09:42.000000000 +0100
+@@ -45,6 +45,8 @@
+ #include <sys/socket.h>
+ #endif
+
++#include <sys/time.h>
++
+ #ifdef BUILDING_DLL
+ # if defined(WIN32) || defined(_WIN32_WCE)
+ # ifdef _MSC_VER
diff --git a/games/flightgear/files/patch-3rdparty-iaxclient-lib-libiax2-src-iax.c b/games/flightgear/files/patch-3rdparty-iaxclient-lib-libiax2-src-iax.c
new file mode 100644
index 000000000000..571ffef44e5f
--- /dev/null
+++ b/games/flightgear/files/patch-3rdparty-iaxclient-lib-libiax2-src-iax.c
@@ -0,0 +1,11 @@
+--- 3rdparty/iaxclient/lib/libiax2/src/iax.c.orig 2014-03-12 18:16:21.000000000 +0100
++++ 3rdparty/iaxclient/lib/libiax2/src/iax.c 2014-03-12 18:18:38.000000000 +0100
+@@ -72,7 +72,7 @@
+ #include <arpa/inet.h>
+ #include <time.h>
+
+-#if !defined(MACOSX) && !defined(__OpenBSD__)
++#if !defined(MACOSX) && !defined(__OpenBSD__) && !defined(__FreeBSD__)
+ #include <malloc.h>
+ #if !defined(SOLARIS)
+ #include <error.h>
diff --git a/games/flightgear/pkg-plist b/games/flightgear/pkg-plist
index 89c414add70f..9e9216bbd7e9 100644
--- a/games/flightgear/pkg-plist
+++ b/games/flightgear/pkg-plist
@@ -2,6 +2,7 @@ bin/GPSsmooth
bin/MIDGsmooth
bin/UGsmooth
bin/fgadmin
+bin/fgcom
bin/fgelev
bin/fgfs
bin/fgjs
@@ -16,6 +17,8 @@ bin/yasim-proptest
man/man1/fgfs.1.gz
man/man1/fgjs.1.gz
man/man1/fgpanel.1.gz
-man/man1/gl-info.1.gz
man/man1/js_demo.1.gz
man/man1/terrasync.1.gz
+%%DATADIR%%/positions.txt
+%%DATADIR%%/special_frequencies.txt
+@dirrm %%DATADIR%%