aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2012-05-02 09:16:04 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2012-05-02 09:16:04 +0000
commit670adacef4a61179965358b8588b62bdb5e87b77 (patch)
treee75c7325119c1f0d0f4a237493d9b200ea344def /games/flightgear
parentfc57b4a6da2c11c8ab1a16f5f07fdd853121fb93 (diff)
downloadports-670adacef4a61179965358b8588b62bdb5e87b77.tar.gz
ports-670adacef4a61179965358b8588b62bdb5e87b77.zip
Notes
Diffstat (limited to 'games/flightgear')
-rw-r--r--games/flightgear/Makefile1
-rw-r--r--games/flightgear/files/patch-src-AIModel-AIFlightPlanCreate.cxx12
-rw-r--r--games/flightgear/files/patch-src-AIModel-AIFlightPlanCreatePushBack.cxx12
-rw-r--r--games/flightgear/files/patch-src-ATCDCL-ATCutils.cxx11
-rw-r--r--games/flightgear/files/patch-src-Airports-runwayprefs.cxx11
-rw-r--r--games/flightgear/files/patch-src-Autopilot-inputvalue.cxx12
-rw-r--r--games/flightgear/files/patch-src-FDM-JSBSim-JSBSim.cxx12
-rw-r--r--games/flightgear/files/patch-src-FDM-YASim-YASim.cxx12
-rw-r--r--games/flightgear/files/patch-src-Instrumentation-KLN89-kln89.cxx12
-rw-r--r--games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_cal.cxx12
-rw-r--r--games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_nav.cxx11
-rw-r--r--games/flightgear/files/patch-src-Instrumentation-dclgps.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-ATC-Inputs.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-ATC-Outputs.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-AV400.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-AV400Sim.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-atlas.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-garmin.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-nmea.cxx11
-rw-r--r--games/flightgear/files/patch-src-Systems-electrical.cxx11
-rw-r--r--games/flightgear/files/patch-src-Systems-system_mgr.cxx11
21 files changed, 228 insertions, 0 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 1bf88af23aff..a871bb91336d 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flightgear
PORTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= games
# see http://www.flightgear.org/templates.js
MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/ \
diff --git a/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreate.cxx b/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreate.cxx
new file mode 100644
index 000000000000..d2827ffb333d
--- /dev/null
+++ b/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreate.cxx
@@ -0,0 +1,12 @@
+--- src/AIModel/AIFlightPlanCreate.cxx.orig 2012-04-28 20:11:14.268235838 +0300
++++ src/AIModel/AIFlightPlanCreate.cxx 2012-04-28 20:11:29.798235529 +0300
+@@ -18,6 +18,8 @@
+ *
+ **************************************************************************/
+
++#include <cstdlib>
++
+ #ifdef HAVE_CONFIG_H
+ # include <config.h>
+ #endif
+
diff --git a/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreatePushBack.cxx b/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreatePushBack.cxx
new file mode 100644
index 000000000000..d952a8d6441d
--- /dev/null
+++ b/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreatePushBack.cxx
@@ -0,0 +1,12 @@
+--- src/AIModel/AIFlightPlanCreatePushBack.cxx.orig 2012-04-29 00:33:37.069233986 +0300
++++ src/AIModel/AIFlightPlanCreatePushBack.cxx 2012-04-29 00:33:57.598237572 +0300
+@@ -18,6 +18,8 @@
+ *
+ **************************************************************************/
+
++#include <cstdlib>
++
+ #ifdef HAVE_CONFIG_H
+ # include <config.h>
+ #endif
+
diff --git a/games/flightgear/files/patch-src-ATCDCL-ATCutils.cxx b/games/flightgear/files/patch-src-ATCDCL-ATCutils.cxx
new file mode 100644
index 000000000000..181fd2e809af
--- /dev/null
+++ b/games/flightgear/files/patch-src-ATCDCL-ATCutils.cxx
@@ -0,0 +1,11 @@
+--- src/ATCDCL/ATCutils.cxx.orig 2012-04-28 17:24:45.174236639 +0300
++++ src/ATCDCL/ATCutils.cxx 2012-04-28 17:25:02.640237400 +0300
+@@ -23,6 +23,7 @@
+ #endif
+
+ #include <sstream>
++#include <cstdlib>
+
+ #include <simgear/math/SGMath.hxx>
+ #include <simgear/constants.h>
+
diff --git a/games/flightgear/files/patch-src-Airports-runwayprefs.cxx b/games/flightgear/files/patch-src-Airports-runwayprefs.cxx
new file mode 100644
index 000000000000..3ea13d8fbf70
--- /dev/null
+++ b/games/flightgear/files/patch-src-Airports-runwayprefs.cxx
@@ -0,0 +1,11 @@
+--- src/Airports/runwayprefs.cxx.orig 2012-04-28 17:05:44.544236696 +0300
++++ src/Airports/runwayprefs.cxx 2012-04-28 17:06:08.564242690 +0300
+@@ -26,6 +26,7 @@
+ #endif
+
+ #include <math.h>
++#include <cstdlib>
+ #include <cstring>
+
+ #include <simgear/compiler.h>
+
diff --git a/games/flightgear/files/patch-src-Autopilot-inputvalue.cxx b/games/flightgear/files/patch-src-Autopilot-inputvalue.cxx
new file mode 100644
index 000000000000..b21a20bb77ce
--- /dev/null
+++ b/games/flightgear/files/patch-src-Autopilot-inputvalue.cxx
@@ -0,0 +1,12 @@
+--- src/Autopilot/inputvalue.cxx.orig 2012-04-28 17:33:36.379238729 +0300
++++ src/Autopilot/inputvalue.cxx 2012-04-28 17:33:54.516724154 +0300
+@@ -18,6 +18,8 @@
+ // Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+ //
+
++#include <cstdlib>
++
+ #include "inputvalue.hxx"
+ #include <Main/fg_props.hxx>
+ using namespace FGXMLAutopilot;
+
diff --git a/games/flightgear/files/patch-src-FDM-JSBSim-JSBSim.cxx b/games/flightgear/files/patch-src-FDM-JSBSim-JSBSim.cxx
new file mode 100644
index 000000000000..0b2ec5c09515
--- /dev/null
+++ b/games/flightgear/files/patch-src-FDM-JSBSim-JSBSim.cxx
@@ -0,0 +1,12 @@
+--- src/FDM/JSBSim/JSBSim.cxx.orig 2012-04-30 11:31:18.119554386 +0300
++++ src/FDM/JSBSim/JSBSim.cxx 2012-04-30 11:31:38.251553602 +0300
+@@ -28,7 +28,7 @@
+ #include <simgear/compiler.h>
+ #include <simgear/sg_inlines.h>
+
+-#include <stdio.h> // size_t
++#include <cstdlib> // size_t
+ #include <string>
+
+ #include <simgear/constants.h>
+
diff --git a/games/flightgear/files/patch-src-FDM-YASim-YASim.cxx b/games/flightgear/files/patch-src-FDM-YASim-YASim.cxx
new file mode 100644
index 000000000000..5a4386025815
--- /dev/null
+++ b/games/flightgear/files/patch-src-FDM-YASim-YASim.cxx
@@ -0,0 +1,12 @@
+--- src/FDM/YASim/YASim.cxx.orig 2012-04-30 11:28:08.392553266 +0300
++++ src/FDM/YASim/YASim.cxx 2012-04-30 11:28:24.816555317 +0300
+@@ -3,6 +3,8 @@
+ # include "config.h"
+ #endif
+
++#include <cstdlib>
++
+ #include <simgear/debug/logstream.hxx>
+ #include <simgear/math/sg_geodesy.hxx>
+ #include <simgear/misc/sg_path.hxx>
+
diff --git a/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89.cxx b/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89.cxx
new file mode 100644
index 000000000000..09b105da84b7
--- /dev/null
+++ b/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89.cxx
@@ -0,0 +1,12 @@
+--- src/Instrumentation/KLN89/kln89.cxx.orig 2012-04-28 19:44:36.140236845 +0300
++++ src/Instrumentation/KLN89/kln89.cxx 2012-04-28 19:44:58.548236276 +0300
+@@ -1032,7 +1032,7 @@ void KLN89::DrawApt(int x, int y) {
+ ++j;
+ for(i=x-2; i<=x+2; ++i) _instrument->DrawPixel(i, j, (i != x ? true : false));
+ ++j;
+- for(i=x-2; i<=x+2; ++i) _instrument->DrawPixel(i, j, (abs(i - x) > 1 ? true : false));
++ for(i=x-2; i<=x+2; ++i) _instrument->DrawPixel(i, j, (std::abs(i - x) > 1 ? true : false));
+ ++j;
+ for(i=x-2; i<=x+2; ++i) _instrument->DrawPixel(i, j, (i != x ? true : false));
+ ++j;
+
diff --git a/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_cal.cxx b/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_cal.cxx
new file mode 100644
index 000000000000..cdad2f72d7ec
--- /dev/null
+++ b/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_cal.cxx
@@ -0,0 +1,12 @@
+--- src/Instrumentation/KLN89/kln89_page_cal.cxx.orig 2012-04-28 20:06:37.121237686 +0300
++++ src/Instrumentation/KLN89/kln89_page_cal.cxx 2012-04-28 20:06:54.865235431 +0300
+@@ -21,6 +21,8 @@
+ //
+ // $Id$
+
++#include <cstdlib>
++
+ #ifdef HAVE_CONFIG_H
+ # include "config.h"
+ #endif
+
diff --git a/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_nav.cxx b/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_nav.cxx
new file mode 100644
index 000000000000..16c155d3b4b0
--- /dev/null
+++ b/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_nav.cxx
@@ -0,0 +1,11 @@
+--- src/Instrumentation/KLN89/kln89_page_nav.cxx.orig 2012-04-30 17:00:03.000000000 +0200
++++ src/Instrumentation/KLN89/kln89_page_nav.cxx 2012-04-30 17:03:56.000000000 +0200
+@@ -21,6 +21,8 @@
+ //
+ // $Id$
+
++#include <cstdlib>
++
+ #ifdef HAVE_CONFIG_H
+ # include "config.h"
+ #endif
diff --git a/games/flightgear/files/patch-src-Instrumentation-dclgps.cxx b/games/flightgear/files/patch-src-Instrumentation-dclgps.cxx
new file mode 100644
index 000000000000..cd308966fde9
--- /dev/null
+++ b/games/flightgear/files/patch-src-Instrumentation-dclgps.cxx
@@ -0,0 +1,11 @@
+--- src/Instrumentation/dclgps.cxx.orig 2012-04-28 19:17:14.631235381 +0300
++++ src/Instrumentation/dclgps.cxx 2012-04-28 19:17:34.070236096 +0300
+@@ -39,6 +39,7 @@
+
+ #include <fstream>
+ #include <iostream>
++#include <cstdlib>
+
+ using namespace std;
+
+
diff --git a/games/flightgear/files/patch-src-Network-ATC-Inputs.cxx b/games/flightgear/files/patch-src-Network-ATC-Inputs.cxx
new file mode 100644
index 000000000000..098192a1c9c2
--- /dev/null
+++ b/games/flightgear/files/patch-src-Network-ATC-Inputs.cxx
@@ -0,0 +1,11 @@
+--- src/Network/ATC-Inputs.cxx.orig 2012-04-29 01:15:22.403234567 +0300
++++ src/Network/ATC-Inputs.cxx 2012-04-29 01:16:16.046237193 +0300
+@@ -31,6 +31,7 @@
+ # include <sys/types.h>
+ # include <sys/stat.h>
+ # include <fcntl.h>
++# include <stdlib.h>
+ # include <unistd.h>
+ # include <istream>
+ #endif
+
diff --git a/games/flightgear/files/patch-src-Network-ATC-Outputs.cxx b/games/flightgear/files/patch-src-Network-ATC-Outputs.cxx
new file mode 100644
index 000000000000..22521ad5b800
--- /dev/null
+++ b/games/flightgear/files/patch-src-Network-ATC-Outputs.cxx
@@ -0,0 +1,11 @@
+--- src/Network/ATC-Outputs.cxx.orig 2012-04-29 01:16:36.569235929 +0300
++++ src/Network/ATC-Outputs.cxx 2012-04-29 01:16:53.428236074 +0300
+@@ -31,6 +31,7 @@
+ # include <sys/types.h>
+ # include <sys/stat.h>
+ # include <fcntl.h>
++# include <stdlib.h>
+ # include <unistd.h>
+ # include <ostream>
+ #endif
+
diff --git a/games/flightgear/files/patch-src-Network-AV400.cxx b/games/flightgear/files/patch-src-Network-AV400.cxx
new file mode 100644
index 000000000000..8be5dfdd587f
--- /dev/null
+++ b/games/flightgear/files/patch-src-Network-AV400.cxx
@@ -0,0 +1,11 @@
+--- src/Network/AV400.cxx.orig 2012-04-29 01:21:15.898235552 +0300
++++ src/Network/AV400.cxx 2012-04-29 01:21:32.302236489 +0300
+@@ -25,6 +25,7 @@
+ # include "config.h"
+ #endif
+
++#include <cstdlib>
+ #include <cstring>
+
+ #include <simgear/debug/logstream.hxx>
+
diff --git a/games/flightgear/files/patch-src-Network-AV400Sim.cxx b/games/flightgear/files/patch-src-Network-AV400Sim.cxx
new file mode 100644
index 000000000000..8fde1f46c414
--- /dev/null
+++ b/games/flightgear/files/patch-src-Network-AV400Sim.cxx
@@ -0,0 +1,11 @@
+--- src/Network/AV400Sim.cxx.orig 2012-04-29 01:21:53.059237359 +0300
++++ src/Network/AV400Sim.cxx 2012-04-29 01:22:08.308236000 +0300
+@@ -29,6 +29,7 @@
+ # include "config.h"
+ #endif
+
++#include <cstdlib>
+ #include <cstring>
+
+ #include <simgear/debug/logstream.hxx>
+
diff --git a/games/flightgear/files/patch-src-Network-atlas.cxx b/games/flightgear/files/patch-src-Network-atlas.cxx
new file mode 100644
index 000000000000..2abe511a6b9e
--- /dev/null
+++ b/games/flightgear/files/patch-src-Network-atlas.cxx
@@ -0,0 +1,11 @@
+--- src/Network/atlas.cxx.orig 2012-04-29 11:25:56.839235311 +0300
++++ src/Network/atlas.cxx 2012-04-29 11:26:08.073235344 +0300
+@@ -24,6 +24,7 @@
+ # include "config.h"
+ #endif
+
++#include <cstdlib>
+ #include <cstring>
+
+ #include <simgear/debug/logstream.hxx>
+
diff --git a/games/flightgear/files/patch-src-Network-garmin.cxx b/games/flightgear/files/patch-src-Network-garmin.cxx
new file mode 100644
index 000000000000..b3c73112f10c
--- /dev/null
+++ b/games/flightgear/files/patch-src-Network-garmin.cxx
@@ -0,0 +1,11 @@
+--- src/Network/garmin.cxx.orig 2012-04-29 11:43:22.790235105 +0300
++++ src/Network/garmin.cxx 2012-04-29 11:43:38.200345541 +0300
+@@ -25,6 +25,7 @@
+ #endif
+
+ #include <iostream>
++#include <cstdlib>
+ #include <cstring>
+
+ #include <simgear/debug/logstream.hxx>
+
diff --git a/games/flightgear/files/patch-src-Network-nmea.cxx b/games/flightgear/files/patch-src-Network-nmea.cxx
new file mode 100644
index 000000000000..ca10856b74fa
--- /dev/null
+++ b/games/flightgear/files/patch-src-Network-nmea.cxx
@@ -0,0 +1,11 @@
+--- src/Network/nmea.cxx.orig 2012-04-29 11:44:11.629236922 +0300
++++ src/Network/nmea.cxx 2012-04-29 11:44:22.384235831 +0300
+@@ -24,6 +24,7 @@
+ # include "config.h"
+ #endif
+
++#include <cstdlib>
+ #include <cstring>
+
+ #include <simgear/debug/logstream.hxx>
+
diff --git a/games/flightgear/files/patch-src-Systems-electrical.cxx b/games/flightgear/files/patch-src-Systems-electrical.cxx
new file mode 100644
index 000000000000..5567382a39f5
--- /dev/null
+++ b/games/flightgear/files/patch-src-Systems-electrical.cxx
@@ -0,0 +1,11 @@
+--- src/Systems/electrical.cxx.orig 2012-04-30 10:16:40.139557199 +0300
++++ src/Systems/electrical.cxx 2012-04-30 10:16:50.765555099 +0300
+@@ -24,6 +24,7 @@
+ # include <config.h>
+ #endif
+
++#include <cstdlib>
+ #include <cstring>
+
+ #include <simgear/structure/exception.hxx>
+
diff --git a/games/flightgear/files/patch-src-Systems-system_mgr.cxx b/games/flightgear/files/patch-src-Systems-system_mgr.cxx
new file mode 100644
index 000000000000..91937bf14b52
--- /dev/null
+++ b/games/flightgear/files/patch-src-Systems-system_mgr.cxx
@@ -0,0 +1,11 @@
+--- src/Systems/system_mgr.cxx.orig 2012-04-30 10:59:27.756554918 +0300
++++ src/Systems/system_mgr.cxx 2012-04-30 10:59:44.991555084 +0300
+@@ -16,6 +16,7 @@
+ #include <Main/globals.hxx>
+ #include <Main/util.hxx>
+
++#include <cstdlib>
+ #include <iostream>
+ #include <string>
+ #include <sstream>
+