aboutsummaryrefslogtreecommitdiff
path: root/games/flobopuyo
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-07 09:10:20 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-07 09:10:20 +0000
commit38b9facd27558116815867f2438d47daf654cb0f (patch)
tree5af6bc297733c5146da7b8762b09a2912c930f7c /games/flobopuyo
parentca6a7c5fafe39dbbea5be7fe11d73622c11757e4 (diff)
downloadports-38b9facd27558116815867f2438d47daf654cb0f.tar.gz
ports-38b9facd27558116815867f2438d47daf654cb0f.zip
Notes
Diffstat (limited to 'games/flobopuyo')
-rw-r--r--games/flobopuyo/Makefile5
-rw-r--r--games/flobopuyo/files/patch-InputManager.cpp11
2 files changed, 15 insertions, 1 deletions
diff --git a/games/flobopuyo/Makefile b/games/flobopuyo/Makefile
index 50031922f97c..7687ad654e91 100644
--- a/games/flobopuyo/Makefile
+++ b/games/flobopuyo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= flobopuyo
PORTVERSION= 0.20
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= games
MASTER_SITES= http://www.ios-software.com/flobopuyo/ \
http://mirror.amdmi3.ru/distfiles/
@@ -11,6 +11,9 @@ MASTER_SITES= http://www.ios-software.com/flobopuyo/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Clone of the famous PuyoPuyo
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= bison gmake dos2unix tar:tgz
DOS2UNIX_FILES= IosVector.cpp PuyoGame.cpp
USE_SDL= sdl mixer image
diff --git a/games/flobopuyo/files/patch-InputManager.cpp b/games/flobopuyo/files/patch-InputManager.cpp
new file mode 100644
index 000000000000..03a0fed723e7
--- /dev/null
+++ b/games/flobopuyo/files/patch-InputManager.cpp
@@ -0,0 +1,11 @@
+--- InputManager.cpp.orig 2004-10-09 07:41:12.000000000 +0900
++++ InputManager.cpp 2015-05-06 22:08:05.341688383 +0900
+@@ -164,7 +164,7 @@
+ }
+
+ int JoystickAxisSwitch::id() const {
+- return 3000 + which * 50 + axis + (maximum?1:0);
++ return 3000 + which * 50 + axis * 2 + (maximum?1:0);
+ }
+
+ bool JoystickAxisSwitch::isArrowUp() const {