aboutsummaryrefslogtreecommitdiff
path: root/games/flobopuyo
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-12 15:01:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-12 15:01:45 +0000
commitdaffe00d4a57c0ef6a21947a8121b8d233d8d3a5 (patch)
tree713942325bda393305edb21d46cd7f38d213aebc /games/flobopuyo
parent51498efaebaad1106dcf0d3f70c8feaa14c411ee (diff)
downloadports-daffe00d4a57c0ef6a21947a8121b8d233d8d3a5.tar.gz
ports-daffe00d4a57c0ef6a21947a8121b8d233d8d3a5.zip
Notes
Diffstat (limited to 'games/flobopuyo')
-rw-r--r--games/flobopuyo/Makefile1
-rw-r--r--games/flobopuyo/files/patch-IosVector.cpp14
-rw-r--r--games/flobopuyo/files/patch-PuyoGame.cpp16
3 files changed, 16 insertions, 15 deletions
diff --git a/games/flobopuyo/Makefile b/games/flobopuyo/Makefile
index 55e666878a11..9e677c6f7bd1 100644
--- a/games/flobopuyo/Makefile
+++ b/games/flobopuyo/Makefile
@@ -15,6 +15,7 @@ COMMENT= Clone of the famous PuyoPuyo
USES= bison
USE_GMAKE= yes
USE_SDL= sdl mixer image
+USE_DOS2UNIX= yes
MAKE_JOBS_SAFE= yes
DESKTOP_ENTRIES="FloboPuyo" \
diff --git a/games/flobopuyo/files/patch-IosVector.cpp b/games/flobopuyo/files/patch-IosVector.cpp
index fe406550f522..c34661591323 100644
--- a/games/flobopuyo/files/patch-IosVector.cpp
+++ b/games/flobopuyo/files/patch-IosVector.cpp
@@ -1,10 +1,10 @@
--- IosVector.cpp.orig 2007-10-30 13:24:55.000000000 +0100
+++ IosVector.cpp 2007-10-30 13:25:29.000000000 +0100
@@ -102,6 +102,6 @@
- void IosVector::dumpVector() const {
- fprintf(stderr, "Size: %d\n", getSize());
- for (int i = 0, j = getSize() ; i < j ; i++)
-- fprintf(stderr, "elt[%d]=%d ", i, (int)getElementAt(i));
-+ fprintf(stderr, "elt[%d]=%p ", i, getElementAt(i));
- fprintf(stderr, "\n");
- }
+ void IosVector::dumpVector() const {
+ fprintf(stderr, "Size: %d\n", getSize());
+ for (int i = 0, j = getSize() ; i < j ; i++)
+- fprintf(stderr, "elt[%d]=%d ", i, (int)getElementAt(i));
++ fprintf(stderr, "elt[%d]=%p ", i, getElementAt(i));
+ fprintf(stderr, "\n");
+ }
diff --git a/games/flobopuyo/files/patch-PuyoGame.cpp b/games/flobopuyo/files/patch-PuyoGame.cpp
index 244798c65fb4..128e074417a5 100644
--- a/games/flobopuyo/files/patch-PuyoGame.cpp
+++ b/games/flobopuyo/files/patch-PuyoGame.cpp
@@ -1,11 +1,11 @@
--- PuyoGame.cpp.orig 2007-10-30 13:27:05.000000000 +0100
+++ PuyoGame.cpp 2007-10-30 13:28:39.000000000 +0100
@@ -45,7 +45,7 @@
- return (PuyoState)newItem;
- }
- else
-- return (PuyoState)(int)(sequenceItems.getElementAt(sequence));
-+ return (PuyoState)(long)(sequenceItems.getElementAt(sequence));
- }
-
- PuyoPuyo::PuyoPuyo(PuyoState state)
+ return (PuyoState)newItem;
+ }
+ else
+- return (PuyoState)(int)(sequenceItems.getElementAt(sequence));
++ return (PuyoState)(long)(sequenceItems.getElementAt(sequence));
+ }
+
+ PuyoPuyo::PuyoPuyo(PuyoState state)