aboutsummaryrefslogtreecommitdiff
path: root/games/foobillard
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:16:14 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:16:14 +0000
commitbe6c15b5c6de864408ba3f414a57f20ff622a2d0 (patch)
tree86bd1ae6afedaa57f4eef276444e85b00f8c8e63 /games/foobillard
parent2428d822895b6225746f9e1d2bed3143711fcf14 (diff)
downloadports-be6c15b5c6de864408ba3f414a57f20ff622a2d0.tar.gz
ports-be6c15b5c6de864408ba3f414a57f20ff622a2d0.zip
Add USES=xorg USES=gl, ports categories g
Add USES=xorg and USES=gl to ports in categories starting with 'g'. While here, try to sprinkle other USES (mostly gnome and sdl) as needed.
Notes
Notes: svn path=/head/; revision=516845
Diffstat (limited to 'games/foobillard')
-rw-r--r--games/foobillard/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index e4b50c222111..14d270d954b5 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -24,7 +24,7 @@ NVIDIA_BUMPREF_DESC= NVidia extensions
FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
-USES= gmake
+USES= gmake xorg
GNU_CONFIGURE= yes
USE_XORG= xaw ice
@@ -39,9 +39,11 @@ DESKTOP_ENTRIES= "Foobillard" \
false
.if ${PORT_OPTIONS:MSDL}
+USES+= sdl
USE_SDL= sdl
CONFIGURE_ARGS+= --enable-SDL
.else
+USES+= gl
USE_GL= glut
CONFIGURE_ARGS+= --enable-glut
.endif