aboutsummaryrefslogtreecommitdiff
path: root/games/freecell-solver/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-04-04 07:54:38 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-04-04 07:54:38 +0000
commita530dcf321f4c5a5ee4cc22436e69e350bfe851b (patch)
treef94d2d4433fad998cd904df5c28593a055702395 /games/freecell-solver/Makefile
parent65f102a6303264f96b7cb7b8271a65efa908a6cc (diff)
Notes
Diffstat (limited to 'games/freecell-solver/Makefile')
-rw-r--r--games/freecell-solver/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index a78f895aa111..d47dbc006f97 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= freecell-solver
-PORTVERSION= 2.8.7
+PORTVERSION= 2.8.10
CATEGORIES= games
MASTER_SITES= http://vipe.technion.ac.il/~shlomif/freecell-solver/ \
http://fc-solve.berlios.de/
@@ -15,7 +15,9 @@ MASTER_SITES= http://vipe.technion.ac.il/~shlomif/freecell-solver/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A program that automatically solves games of Freecell
-USE_INC_LIBTOOL_VER=13
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
MAN6= fc-solve-board_gen.6 fc-solve.6 \
@@ -25,4 +27,7 @@ MAN6= fc-solve-board_gen.6 fc-solve.6 \
make_pysol_freecell_board.py.6 \
pi-make-microsoft-freecell-board.6
+post-patch:
+ @${REINPLACE_CMD} -e '/<malloc\.h>/d' ${WRKSRC}/alloc.c
+
.include <bsd.port.mk>