aboutsummaryrefslogtreecommitdiff
path: root/games/freecell-solver/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-06-04 10:00:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-06-04 10:00:12 +0000
commit1049b2122eb03747cff97e5cd116cde947a1ffc7 (patch)
treef627e7df9afd7299c64bb5fc71eb9f8a59512421 /games/freecell-solver/Makefile
parent8d3b6c95158e08fd2d3f1ffb33c65bbfcb94b3d7 (diff)
downloadports-1049b2122eb03747cff97e5cd116cde947a1ffc7.tar.gz
ports-1049b2122eb03747cff97e5cd116cde947a1ffc7.zip
Notes
Diffstat (limited to 'games/freecell-solver/Makefile')
-rw-r--r--games/freecell-solver/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 3bf50ddcd8ef..70e294dc254f 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= freecell-solver
-PORTVERSION= 3.16.0
+PORTVERSION= 3.18.1
CATEGORIES= games
MASTER_SITES= http://fc-solve.shlomifish.org/downloads/fc-solve/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A program that automatically solves games of Freecell
+COMMENT= Open source framework for solving Freecell
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING.txt
@@ -16,8 +16,9 @@ OPTIONS_DEFINE= TCMALLOC DOCS EXAMPLES
TCMALLOC_DESC= Use Google's TCMalloc
USE_BZIP2= yes
+USES= cmake:outsource
USE_PERL5_BUILD=yes
-USES= cmake
+CMAKE_ARGS= -DFCS_WITH_TEST_SUITE:BOOL=OFF
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
@@ -39,7 +40,10 @@ CMAKE_ARGS+= -DFCS_AVOID_TCMALLOC:BOOL=ON
post-patch:
.for f in CMakeLists.txt
- @${REINPLACE_CMD} -e 's|"pthread"|"${PTHREAD_LIBS}"|' ${WRKSRC}/${f}
+ @${REINPLACE_CMD} -e 's|"pthread"|"-pthread"|' ${WRKSRC}/${f}
+.endfor
+.for f in Shlomif_Common.cmake
+ @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/cmake/${f}
.endfor
.for f in children-playing-ball.sh sentient-pearls.sh
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/Presets/presets/${f}