aboutsummaryrefslogtreecommitdiff
path: root/games/freecell-solver/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-15 07:38:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-15 07:38:32 +0000
commit1910799fd9b0feb74dc055d4d074122a435f1241 (patch)
treeeb0650f71700222b4b7c855806601251d9a2533d /games/freecell-solver/Makefile
parenta62f11ae4770fd2ccf3698c014c169bb76a75fea (diff)
Notes
Diffstat (limited to 'games/freecell-solver/Makefile')
-rw-r--r--games/freecell-solver/Makefile30
1 files changed, 10 insertions, 20 deletions
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index c96800699e9d..c1bac47c3d36 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= freecell-solver
-PORTVERSION= 3.2.0
+PORTVERSION= 3.6.0
CATEGORIES= games
MASTER_SITES= http://freebsd.unixfreunde.de/sources/ \
BERLIOS/fc-solve
@@ -15,15 +15,16 @@ MASTER_SITES= http://freebsd.unixfreunde.de/sources/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A program that automatically solves games of Freecell
-OPTIONS= JUDY "Use libJudy for states and stacks storage" off \
- REDBLACK "Use libredblack for states and stacks storage" off \
- TCMALLOC "Use Google's TCMalloc" off
+LICENSE= MIT
+
+OPTIONS= TCMALLOC "Use Google's TCMalloc" off
USE_BZIP2= yes
USE_PERL5_BUILD= yes
USE_CMAKE= yes
CMAKE_USE_PTHREAD= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
MAN6= fc-solve-board_gen.6 \
fc-solve.6 \
@@ -37,27 +38,16 @@ CFLAGS+= -I${LOCALBASE}/include
.include <bsd.port.pre.mk>
-.if defined(WITH_JUDY) && defined(WITH_REDBLACK)
-IGNORE= you cannot enable both JUDY and REDBLACK
-.endif
-
-.if defined(WITH_JUDY)
-LIB_DEPENDS+= Judy.1:${PORTSDIR}/devel/judy
-CMAKE_ARGS+= -DFCS_STACK_STORAGE:STRING="FCS_STACK_STORAGE_JUDY" \
- -DFCS_STATE_STORAGE:STRING="FCS_STATE_STORAGE_JUDY"
-.endif
-
-.if defined(WITH_REDBLACK)
-LIB_DEPENDS+= redblack.2:${PORTSDIR}/devel/libredblack
-CMAKE_ARGS+= -DFCS_STACK_STORAGE:STRING="FCS_STACK_STORAGE_LIBREDBLACK_TREE" \
- -DFCS_STATE_STORAGE:STRING="FCS_STATE_STORAGE_LIBREDBLACK_TREE"
-.endif
-
.if defined(WITH_TCMALLOC)
LIB_DEPENDS+= tcmalloc.0:${PORTSDIR}/devel/google-perftools
CMAKE_ARGS+= -DFCS_USE_TCMALLOC:BOOL=ON
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' \
+ ${WRKSRC}/Presets/presets/children-playing-ball.sh \
+ ${WRKSRC}/Presets/presets/sentient-pearls.sh
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}