aboutsummaryrefslogtreecommitdiff
path: root/games/freecell-solver
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-01-06 18:08:19 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-01-06 18:08:19 +0000
commitb66396ee8314daeb3a1e733e7316a8807c5740c4 (patch)
tree13acf334a1b86426aa8c4404c5d5acd087f46076 /games/freecell-solver
parentb02204608f5c05424790fe7a9c9a2b2eb1cce73e (diff)
downloadports-b66396ee8314daeb3a1e733e7316a8807c5740c4.tar.gz
ports-b66396ee8314daeb3a1e733e7316a8807c5740c4.zip
Notes
Diffstat (limited to 'games/freecell-solver')
-rw-r--r--games/freecell-solver/Makefile8
-rw-r--r--games/freecell-solver/distinfo6
-rw-r--r--games/freecell-solver/files/patch-CMakeLists.txt23
-rw-r--r--games/freecell-solver/pkg-plist1
4 files changed, 26 insertions, 12 deletions
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 2b854c26567c..4721bcb4d6af 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= freecell-solver
-PORTVERSION= 4.12.1
-PORTREVISION= 1
+PORTVERSION= 4.14.1
CATEGORIES= games
MASTER_SITES= http://fc-solve.shlomifish.org/downloads/fc-solve/
@@ -20,9 +19,10 @@ BUILD_DEPENDS= p5-Path-Tiny>=0.076:devel/p5-Path-Tiny \
OPTIONS_DEFINE= DOCS EXAMPLES TCMALLOC
TCMALLOC_DESC= Use Google's TCMalloc
-USES= cmake:outsource compiler:c11 perl5 shebangfix tar:xz
+USES= cmake:outsource compiler:c11 perl5 python:3.4+ shebangfix tar:xz
USE_PERL5= build
-SHEBANG_FILES= board_gen/make_pysol_freecell_board.py
+SHEBANG_FILES= board_gen/make_pysol_freecell_board.py \
+ board_gen/transpose-freecell-board.py
CMAKE_ARGS= -DFCS_WITH_TEST_SUITE:BOOL=OFF
USE_LDCONFIG= yes
diff --git a/games/freecell-solver/distinfo b/games/freecell-solver/distinfo
index 936700225841..69f13198aea9 100644
--- a/games/freecell-solver/distinfo
+++ b/games/freecell-solver/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1497723139
-SHA256 (freecell-solver-4.12.1.tar.xz) = 607d6e3980fc9883bbf71c6df8e84eff6a16baece5fb7e9a898e74a38c738193
-SIZE (freecell-solver-4.12.1.tar.xz) = 391304
+TIMESTAMP = 1510100388
+SHA256 (freecell-solver-4.14.1.tar.xz) = b805e1261ebf0e5ae2c1e7877f9553eb06274e84c140badc8f453fb97d235076
+SIZE (freecell-solver-4.14.1.tar.xz) = 391912
diff --git a/games/freecell-solver/files/patch-CMakeLists.txt b/games/freecell-solver/files/patch-CMakeLists.txt
index a1f126e21a36..876a05d719ee 100644
--- a/games/freecell-solver/files/patch-CMakeLists.txt
+++ b/games/freecell-solver/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2017-06-09 15:03:09 UTC
+--- CMakeLists.txt.orig 2017-10-06 15:32:19 UTC
+++ CMakeLists.txt
-@@ -636,7 +636,7 @@ IF ("${FCS_ENABLE_DBM_SOLVER}")
+@@ -598,7 +598,7 @@ IF ("${FCS_ENABLE_DBM_SOLVER}")
SET (DEBONDT_DELTA_STATES 1)
ENDIF ()
@@ -9,7 +9,7 @@
# LINK_DIRECTORIES("/home/shlomif/progs/C/pthreads/rwlock/fcfs-rwlock/pthreads")
# INCLUDE_DIRECTORIES("/home/shlomif/progs/C/pthreads/rwlock/fcfs-rwlock/pthreads")
-@@ -703,7 +703,7 @@ ENDIF ()
+@@ -665,7 +665,7 @@ ENDIF ()
IF (CMAKE_USE_PTHREADS_INIT)
FCS_ADD_EXEC(freecell-solver-multi-thread-solve threaded_range_solver.c)
@@ -18,7 +18,7 @@
ENDIF ()
IF (UNIX)
-@@ -872,7 +872,7 @@ INSTALL(
+@@ -823,7 +823,7 @@ INSTALL(
FILES
"${CMAKE_CURRENT_BINARY_DIR}/lib${CPACK_PACKAGE_NAME}.pc"
DESTINATION
@@ -27,7 +27,20 @@
)
# Rebuild config.h if ver.txt has changed.
-@@ -1061,7 +1061,7 @@ IF(ASCIIDOC_FOUND)
+@@ -947,10 +947,10 @@ ENDMACRO()
+ IF(ASCIIDOC_FOUND)
+
+ SET (_pdf_targets)
+- ADD_COPY_TARGET( "asciidoc__css" "/etc/asciidoc/stylesheets/asciidoc.css"
++ ADD_COPY_TARGET( "asciidoc__css" "/usr/local/etc/asciidoc/stylesheets/asciidoc.css"
+ "${CMAKE_CURRENT_SOURCE_DIR}/asciidoc.css")
+ TRAIL_SPACE_COPY_TARGET( "asciidoc__js"
+- "/etc/asciidoc/javascripts/asciidoc.js"
++ "/usr/local/etc/asciidoc/javascripts/asciidoc.js"
+ "${CMAKE_CURRENT_SOURCE_DIR}/asciidoc.js")
+ FOREACH(_file ${_docfiles})
+ GET_FILENAME_COMPONENT(_file_we ${_file} NAME_WE)
+@@ -1036,7 +1036,7 @@ IF(ASCIIDOC_FOUND)
ADD_CUSTOM_COMMAND(
OUTPUT "${_manpage}"
COMMAND "xsltproc" "--output" "${_manpage}"
diff --git a/games/freecell-solver/pkg-plist b/games/freecell-solver/pkg-plist
index 58f1ea4ee3cf..38e01433924d 100644
--- a/games/freecell-solver/pkg-plist
+++ b/games/freecell-solver/pkg-plist
@@ -41,6 +41,7 @@ man/man6/transpose-freecell-board.py.6.gz
%%DATADIR%%/presets/blue-yonder.sh
%%DATADIR%%/presets/children-playing-ball.sh
%%DATADIR%%/presets/conspiracy-theory.sh
+%%DATADIR%%/presets/cookie-monster.sh
%%DATADIR%%/presets/cool-jives.sh
%%DATADIR%%/presets/crooked-nose.sh
%%DATADIR%%/presets/enlightened-ostrich.sh