aboutsummaryrefslogtreecommitdiff
path: root/games/freeciv/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-12-22 11:21:03 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-12-22 11:21:03 +0000
commitddb172c03b26737fcba1697910c4dee9366bf932 (patch)
treebe004c33358da3b566f07f3e4e84c4934426d6c3 /games/freeciv/Makefile
parent51215a30bd31eb9c435004e75a8c796ad2c132f4 (diff)
downloadports-ddb172c03b26737fcba1697910c4dee9366bf932.tar.gz
ports-ddb172c03b26737fcba1697910c4dee9366bf932.zip
Notes
Diffstat (limited to 'games/freeciv/Makefile')
-rw-r--r--games/freeciv/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/games/freeciv/Makefile b/games/freeciv/Makefile
index 97dc8b13b165..416bca056cd7 100644
--- a/games/freeciv/Makefile
+++ b/games/freeciv/Makefile
@@ -31,6 +31,7 @@ PORT_VERBS= civ
MAN6= civserver.6 civclient.6
.ifndef WITHOUT_X11
+PORTREVISION= 1
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.5:${PORTSDIR}/graphics/png \
ggz.5:${PORTSDIR}/games/libggz \
@@ -59,4 +60,9 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in|${XARGS} ${REINPLACE_CMD} -e\
'/pkgdatadir/s|$$[(]datadir[)]/@PACKAGE@|${DATADIR}|'
+.ifndef WITHOUT_X11
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/data/civclient.dsc ${DATADIR}/
+.endif
+
.include <bsd.port.mk>